Subject: [79attendees] Android location reporting Maastrict

From: "Haluska, John J" <[email-masked]>
Date: Tue, 9 Nov 2010 20:57:38 -0500

An interesting observation that some might find interesting -  I noticed that my Android  phone (running WiFi only)  is reporting my location as Maastricht, presumably based on  previously reported location of access point MAC addresses.

---

From: Richard Barnes <[email-masked]>
Date: Wed, 10 Nov 2010 10:06:20 +0800

Common problem for meeting networks these days.  During the San Francisco
meeting, SkyHook got hold of the IETF AP MAC address list (full disclosure:
I emailed it to them), and when we showed up on Stockholm, everyone's
iPhones showed them solidly in the San Francisco Hilton.

If you're interested in fixing this, come to the GEOPRIV meeting on Friday
morning!

--Richard

On Wed, Nov 10, 2010 at 9:57 AM, Haluska, John J <[email-masked]>wrote:

>  An interesting observation that some might find interesting -  I noticed
> that my Android  phone (running WiFi only)  is reporting my location as
> Maastricht, presumably based on  previously reported location of access
> point MAC addresses.
>
>
>
>
>
> _______________________________________________
> 79attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/79attendees
>
>

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 10 Nov 2010 10:10:03 +0800

On Tue, Nov 09, 2010 at 08:57:38PM -0500,
 Haluska, John J <[email-masked]> wrote 
 a message of 107 lines which said:

> An interesting observation that some might find interesting -  I
> noticed that my Android  phone (running WiFi only) 

You mean no GSM? Because, AFAIK, GSM too can send localisation and
time information, no?

> is reporting my location as Maastricht,

Works for me, I am located in Beijing (no 3G and no GPS, so it can be
only Wifi or GSM). Android 2.2.

---

From: "Haluska, John J" <[email-masked]>
Date: Tue, 9 Nov 2010 21:16:31 -0500

I've enabled only wifi and GPS. I've got CDMA turned off.

---

From: Adam Roach <[email-masked]>
Date: Wed, 10 Nov 2010 10:19:59 +0800

I've noticed that Firefox under OS X is reporting me as being in the 
MECC in Maastricht, too. I suspect some of the IETF APs got inventoried 
as being in Maastricht when we were there.

/a

On 11/10/10 10:16 AM, Haluska, John J wrote:
>   Haluska, John J<[email-masked]>  wrote

---

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 10 Nov 2010 10:25:07 +0800

> You mean no GSM? Because, AFAIK, GSM too can send localisation and

That's true in theory, but it is rarely true in practice.  GSM has the capability to have a handset request its location from the network (MT-LR in 23.271), but this capability is often either not present, or disabled in the network.

More likely from a GSM perspective is that the Google location service gets a cell identifier and infers location from that.  In this case, this probably isn't happening and the MAC addresses of the wifi APs will be what is being used, as Richard pointed out.

--Martin

---

From: "Haluska, John J" <[email-masked]>
Date: Tue, 9 Nov 2010 22:18:02 -0500

FYI, after walking through the building my location has been updated to the correct location. Probably the GPS receiver was able to get a view of enough satellites during the walk past the large windows, etc. to get a fix.  It'll be interesting to see what happens when I get out of view of the satellites and in a place where I can only see wifi again.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Haluska, John J
Sent: Wednesday, November 10, 2010 9:58 AM
To: [email-masked]
Subject: [79attendees] Android location reporting Maastrict