Subject: [84attendees] Hyatt Elevators

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 1 Aug 2012 11:52:21 -0400

Given the amazing ability of our NOC team at completely reengineering the wireless network in the hotel in Paris, I wonder if we could get them to hack the Hyatt elevator system? We waited about 10 minutes to get the assigned elevator last night. It was overcrowded, and tried to pick up more passengers on the way up.

I'm guessing they believed some hype about efficiency, and didn't install enough capacity.  As we all know, more dumb bandwidth always beats attempts to make smarter, smaller pipes.  They apparently don't know that in elevator design.

---

From: Pelletier Ray <[email-masked]>
Date: Wed, 1 Aug 2012 11:56:27 -0400

+1

Could we get an App for that?

On Aug 1, 2012, at 11:52 AM, Rosen, Brian wrote:

> _______________________________________________
> 84attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/84attendees

---

From: joel jaeggli <[email-masked]>
Date: Wed, 01 Aug 2012 08:59:01 -0700

>> I'm guessing they believed some hype about efficiency, and didn't
>> install enough capacity.  As we all know, more dumb bandwidth
>> always beats attempts to make smarter, smaller pipes.  They
>> apparently don't know that in elevator design.

I don't think you'll like the consequences of managing the queue depth 
through random discard.

---

From: Jim Gettys <[email-masked]>
Date: Wed, 01 Aug 2012 09:05:19 -0700

> I don't think you'll like the consequences of managing the queue depth

We might coddle you with ECN marking.

Happy?
            - Jim

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 1 Aug 2012 09:07:20 -0700

> We might coddle you with ECN marking.

I had noted in the elevator yesterday that we're lucky we don't use IP methodologies in the face of congestion.  The analog of "dropped packets" would be ... unpleasant.

---

From: Scott Brim <[email-masked]>
Date: Wed, 1 Aug 2012 09:08:57 -0700

> We might coddle you with ECN marking.

codel

---

From: Samuel Weiler <[email-masked]>
Date: Wed, 1 Aug 2012 12:10:23 -0400 (EDT)

For amusement, imagine that you're blind and attempt to use the 
accessibility interface.

-- Sam

---

From: Jim Gettys <[email-masked]>
Date: Wed, 01 Aug 2012 09:12:47 -0700

>> We might coddle you with ECN marking.
We pronounce CoDel "coddle" deliberately, both because it's easier to
say, but also because it is trying to overcome the bias against packet
drop as an evil thing.  Telling people you are coddling their packet has
a warm and fuzzy implication....
                    - Jim

---

From: "John G. Scudder" <[email-masked]>
Date: Wed, 1 Aug 2012 09:14:45 -0700

> For amusement, imagine that you're blind and attempt to use the 

Did. Regretted.

--John

---

From: Ted Hardie <[email-masked]>
Date: Wed, 1 Aug 2012 09:21:35 -0700

On Wed, Aug 1, 2012 at 9:12 AM, Jim Gettys <[email-masked]> wrote:

>  Telling people you are coddling their packet has

Not to cooks; there it has a (very!) warm implication, but not so fuzzy:

http://en.wikipedia.org/wiki/Coddled_egg

Ted

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Wed, 01 Aug 2012 09:27:41 -0700

Didn't we have a similiar issue in Prague ? The mention of blind people 
struggling to get around brought back some rather hazy memories.

~C.

---

From: "Kenny Hong (kehong)" <[email-masked]>
Date: Wed, 1 Aug 2012 16:34:43 +0000

http://hondacelebrationoflight.com/

---

From: Christoph Blecker <[email-masked]>
Date: Wed, 1 Aug 2012 09:52:24 -0700

It's worth noting that it was estimated 400,000 people were in
Downtown Vancouver last Saturday for it, so make sure to allow extra
time getting anywhere later on today.

Cheers,
Christoph

---

From: Rob Evans <[email-masked]>
Date: Wed, 1 Aug 2012 10:02:01 -0700

> time getting anywhere later on today.

If you do go to the fireworks this evening, don't expect to get anywhere in a hurry afterwards...  After the fireworks on Saturday, most of those 400,000 people fed out through Denman and Davie Streets, which were packed denser than a Hyatt elevator at 8:59am.

Regards,
Rob

---

From: Michael Richardson <[email-masked]>
Date: Wed, 01 Aug 2012 13:07:57 -0400

>>>>> "Rosen," == Rosen, Brian <[email-masked]> writes:
    Rosen> Given the amazing ability of our NOC team at completely
    Rosen> reengineering the wireless network in the hotel in Paris, I
    Rosen> wonder if we could get them to hack the Hyatt elevator
    Rosen> system? We waited about 10 minutes to get the assigned
    Rosen> elevator last night. It was overcrowded, and tried to pick
    Rosen> up more passengers on the way up.

having experienced it only during the newcoming session on Sunday, it
seemed a fail... it had no way to gauge demand.

someone did a simulation using stochastic arrival times, and failed to
think about what happens in a *conference* hotel when a session is out.

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: Tassos Chatzithomaoglou <[email-masked]>
Date: Wed, 01 Aug 2012 10:12:00 -0700

Any recommendations about where to sit and watch them? maybe near the 
platform?
I visited english bay yesterday and i got the impression that you have 
too many options to choose.

Tassos

---

From: Alexander Mayrhofer <[email-masked]>
Date: Wed, 1 Aug 2012 17:17:09 +0000

> Any recommendations about where to sit and watch them? maybe near the platform?
> I visited english bay yesterday and i got the impression that you have too many options to choose.

I was there on Saturday, sitting on the beach of English Bay. It was definitely crowded, to the point of being scary and dangerous, particularly right after the fireworks were over, when people all stood up at the same time, and some stumbled over people who hadn't managed to get up quick enough.

Expect to sit on the bare ground. If you keep on standing, people behind you will "force" you down.

Oh, and in the audience, it smelled like they were not actually blowing up fireworks, but rather all of BC's weed reserves ;) - that might bother some people.

Alex

---

From: Tim Bray <[email-masked]>
Date: Wed, 1 Aug 2012 10:23:21 -0700

You don’t have to be that close to really enjoy them. They’re big.  -T

---

From: Ben Campbell <[email-masked]>
Date: Wed, 1 Aug 2012 10:28:27 -0700

> You don’t have to be that close to really enjoy them. They’re big.  -T

Any thoughts on non-close spots with a good view?

---

From: Phil Hunt <[email-masked]>
Date: Wed, 1 Aug 2012 10:33:11 -0700

You can also go to the marine museum beach area in kitsilano (far side of Burrard bridge).  No idea on how crowded. 

Phil

---

From: "Timothy J. Salo" <[email-masked]>
Date: Wed, 01 Aug 2012 12:35:11 -0500

Apparently, the use of stairs is deprecated at the Hyatt.  I tried
to use the stairs to get from the fourth floor to the third.  I
ended up having to walk down to the plaza level in search of an
unlocked door, only to find an exit door that claimed to be alarmed.
I ended up climbing back up to the fourth floor, but via a different
set of stairs.

-tjs

---

From: Joseph Yee <[email-masked]>
Date: Wed, 1 Aug 2012 13:35:05 -0400

I got this suggestion from local...

The festival area (the beach area of the shore fest and beach area
around Burrard bridge) is where people drink and party hard.  Area to
avoid if that's not your preference.  The beach area north west of the
firework platform is also good  to see the firework and more family
friendly.

Joseph

---

From: JinHyeock Choi <[email-masked]>
Date: Thu, 2 Aug 2012 02:36:53 +0900

> Any thoughts on non-close spots with a good view?

Maybe on the Burrard bridge?
Some people on it last SAT.

JinHyeock

---

From: Jonathan Lennox <[email-masked]>
Date: Wed, 1 Aug 2012 13:38:18 -0400

There are stairs between the third to the fourth floors on the corner of the fourth floor opposite the terminal room.  The doors are explicitly marked "access to Regency Ballroom" or some such.

--
Jonathan Lennox
[email-masked]

---

From: Jonathan Lennox <[email-masked]>
Date: Wed, 1 Aug 2012 13:38:48 -0400

Does anyone know whether the windows in the Hyatt 34th floor lounge face the right direction?

--
Jonathan Lennox
[email-masked]

---

From: "Rauschenbach, Uwe (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 1 Aug 2012 19:39:51 +0200

We were standing on the Burrard bridge (near end) last Sunday. It was OK, not too crowded, even though we arrived very close to the start of the event. It's a little far away from the actual fireworks, but you have a great overview. 

Uwe

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Phil Hunt
Sent: Wednesday, August 01, 2012 10:33 AM
To: Tim Bray
Cc: 84attendees
Subject: Re: [84attendees] Fireworks tonight along English bay

Phil

---

From: Andy Newton <[email-masked]>
Date: Wed, 1 Aug 2012 17:41:43 +0000

> I ended up climbing back up to the fourth floor, but via a different

Odd, I've taken the stairs down several times. It is annoying that you can't exist on the 3rd and 2nd floors from the stairwell, but the bottom door into the lobby (right across from the elevators) never set off any alarms that I know of.

-andy

---

From: Scott Brim <[email-masked]>
Date: Wed, 1 Aug 2012 10:43:58 -0700

> think about what happens in a *conference* hotel when a session is out.

Exactly what I think but that's surprising considering the main
purpose of the hotel.

---

From: Zoltán Lajos Kis <[email-masked]>
Date: Wed, 1 Aug 2012 19:44:04 +0200

I watched the fireworks from Burrard bridge. I only got there 20mins before start and still managed to get into the first line.
The place is good if you can get a spot in the first or second line. There was no squeezing from ppl behind.

The walk back on Burrard street was slooow. But at least I spotted a skunk :o)

Zoltan.

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of JinHyeock Choi [[email-masked]]
Sent: Wednesday, August 01, 2012 7:36 PM
To: Ben Campbell
Cc: 84attendees; Tim Bray
Subject: Re: [84attendees] Fireworks tonight along English bay

JinHyeock

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Wed, 1 Aug 2012 14:07:22 -0400

I expect that many of the rooms in the Sheraton Wall Centre have a good view of English Bay.

Dale

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Jonathan Lennox [[email-masked]]
Sent: Wednesday, August 01, 2012 1:38 PM
To: Ben Campbell
Cc: 84attendees; Tim Bray
Subject: Re: [84attendees] Fireworks tonight along English bay

--
Jonathan Lennox
[email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Wed, 1 Aug 2012 11:20:10 -0700

> think about what happens in a *conference* hotel when a session is out.

They also failed to account for the presence of bad data: people trying to game the system to get an elevator to arrive sooner, which I have witnessed, and people who mis-key the floor because the UI is badly sized, which I do about every second time I try to operate it.   I have accidentally sent quite a few elevators to Floor 26 because I missed the "lower floors" button.

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Wed, 1 Aug 2012 14:29:47 -0400

> From: Rosen, Brian [[email-masked]]
> 
> It was overcrowded, and tried to pick up more passengers on the way up.

Which is odd.  They've had elevators that can detect when they're
overloaded for years.  And it shouldn't be hard to program the
controller to detect the various overload conditions and implement
policies that have better fairness properties than the default
policies.

Dale

---

From: Barry Leiba <[email-masked]>
Date: Wed, 1 Aug 2012 15:09:33 -0400

> policies that have better fairness properties than the default

The problem is that the system commits a resource (specific elevator
letter) to you when you call for service, and there's no way for it to
change that.  It has no idea how many people will be getting in for a
particular call.  If you're on 3 and trying to go up, it might tell you to
ue elevator D.  But if there was one call on 2 to go up, they were assigned
to elevator D, but it was a group of ten people who got on... the elevator
might be full when it gets to 3.  Even if the elevator "knows" that,
there's no way it can tell you, standing on the third floor in front of
elevator D, that you should move over to A.

Barry

---

From: Jakob Heitz <[email-masked]>
Date: Wed, 1 Aug 2012 15:24:19 -0400

Depends on the definition of "overcrowded".
"You can spit on the guy next to you"
is not the right definition.

--
Jakob Heitz.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Worley, Dale R (Dale)
Sent: Wednesday, August 01, 2012 11:30 AM
To: '84attendees'
Subject: Re: [84attendees] Hyatt Elevators

Dale

---

From: "John G. Scudder" <[email-masked]>
Date: Wed, 1 Aug 2012 12:28:01 -0700

How about "elevator has a hard time getting moving, hesitates, tries again"?

--John

---

From: Ole Jacobsen <[email-masked]>
Date: Wed, 1 Aug 2012 12:36:29 -0700 (PDT)

And this is different from traditional multi-car elevators how?

Ole

Ole J. Jacobsen
Editor and Publisher,  The Internet Protocol Journal
Cisco Systems
Tel: +1 408-527-8972   Mobile: +1 415-370-4628
E-mail: [email-masked]  URL: http://www.cisco.com/ipj
Skype: organdemo

---

From: "Pat Thaler" <[email-masked]>
Date: Wed, 1 Aug 2012 20:15:56 +0000

The elevators make the point that "software defined" is only as good as the software, not automatically better. I've stayed in this hotel for similarly large meetings with the prior traditional elevator control system and didn't run into the same congestion. 

It doesn't seem like the system is designed to optimize for congestion handling. For instance, in the end of day crush period, I entered my floor and noticed that the next 4 people were all assigned to the D elevator along with me even though they had wildly different floors. Meanwhile, E arrived and I noticed that it was going to my floor. It wasn't crowded. Why didn't the system assign me to E which was already destined to my floor?  

If there is a lot of demand, wouldn't it handle it more efficiently if it used some elevators for a lower set of floors so they could make quicker round trips and other elevators for the upper floors? 

Perhaps the design focus was elsewhere like idling some elevators when demand is low to reduce power consumption?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ole Jacobsen
Sent: Wednesday, August 01, 2012 12:36 PM
To: Barry Leiba
Cc: Worley, Dale R (Dale); 84attendees
Subject: Re: [84attendees] Hyatt Elevators

Ole

Ole J. Jacobsen

---

From: Dean Willis <[email-masked]>
Date: Wed, 1 Aug 2012 15:18:44 -0500

> policies that have better fairness properties than the default

North American elevators are usually designed such that they are "overcrowded" by local standards long before they become "overloaded".  Even as fat as we are, we have a larger sense of personal space than our prodigious girths might be accorded in other regions. And we have a tradition of over-engineering the loading of service devices -- that's why my "3/4 ton" pickup can easily carry well over a ton of masonry.

Programming an elevator to count PEOPLE, rather than load-weight, is actually pretty tricky. One approach is to count loading-pulses or load-increments on the weight sensor as people step into the elevator. Most builders don't bother, as they hope you'll go ahead and wedge yourself into the overcrowded-but-not-overloaded elevator in favor of energy efficiency.

--
Dean

---

From: Sean Leonard <[email-masked]>
Date: Wed, 1 Aug 2012 14:15:56 -0700

So, is there a plan for IETFers to meet and go as a group at some time tonight?

Sean

---

From: "George, Wes" <[email-masked]>
Date: Wed, 1 Aug 2012 17:37:23 -0400

> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Ben Campbell
> Sent: Wednesday, August 01, 2012 1:28 PM
> To: Tim Bray
> Cc: 84attendees

[WEG] Don't let the potential for a crowd intimidate you, it's worth it to be close because they actually light off fireworks that stay on or near the barge that would be harder to see from farther away. It was the first time I had seen floating fireworks burning in the water, very cool.

I stood at the fenceline at the entrance to the park/seating area (corner of Denman and Davie) and was able to see quite well without being told to sit down. Got there about 45 minutes ahead of the display, and afterwards other than some weirdness with a knot of people standing still instead of walking and therefore blocking traffic flow right at the intersection of those two streets, didn't find a major issue with the crowd.

Wes George

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Stuart Cheshire <[email-masked]>
Date: Wed, 1 Aug 2012 14:38:00 -0700

On 1 Aug 2012, at 12:09, Barry Leiba wrote:

> change that.

This is the fatal flaw in the system. It commits to a particular elevator
too soon.

With a normal bank of elevators, if elevator A is held up by a bunch of
people being slow getting in or out, then another elevator can still stop
at another floor where other people are waiting. With these Hyatt
Elevators, those other people may have already been "promised" elevator A,
and the system has no way to retract or revise that promise.

On the plus side, with these fancy Hyatt elevators, if you want to press
*all* the buttons, you can now do that from the outside, without the
traditional inconvenience of having to get *inside* the elevator to do that.

Stuart Cheshire

---

From: Barry Leiba <[email-masked]>
Date: Wed, 1 Aug 2012 17:45:55 -0400

> traditional inconvenience of having to get *inside* the elevator to do that.

That was YOU?

b

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 2 Aug 2012 16:10:35 -0700

On Wed, Aug 1, 2012 at 10:41 AM, Andy Newton <[email-masked]> wrote:

>
> Odd, I've taken the stairs down several times. It is annoying that you
> can't exist on the 3rd and 2nd floors from the stairwell, but the bottom
> door into the lobby (right across from the elevators) never set off any
> alarms that I know of.
>
>
Dunno what your existential problem is.  I've existed periodically on the
2nd and 3rd floors since Sunday.

-MSK

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 2 Aug 2012 16:12:05 -0700

> http://hondacelebrationoflight.com/
I'd like to point out that this is the second Canadian meeting in a row
that had major fireworks shows during.  Bravo, IAOC!  Please keep it up, at
least for all the Canadian venues.

-MSK

---

From: Andy Newton <[email-masked]>
Date: Fri, 3 Aug 2012 00:30:12 +0000

On Aug 2, 2012, at 4:10 PM, Murray S. Kucherawy wrote:

> Dunno what your existential problem is.  I've existed periodically on the 2nd and 3rd floors since Sunday.

:)

Quite a few people existed on the 3rd floor when the ice cream came out.

-andy

---

From: Brian Campbell <[email-masked]>
Date: Thu, 2 Aug 2012 19:06:55 -0700

A few photos of the fireworks last night:

http://flic.kr/p/cJz4R7
http://flic.kr/p/cJyS5S
http://flic.kr/p/cJyY6Q

On Thu, Aug 2, 2012 at 4:12 PM, Murray S. Kucherawy <[email-masked]> wrote:
> I'd like to point out that this is the second Canadian meeting in a row that
> had major fireworks shows during.  Bravo, IAOC!  Please keep it up, at least
> for all the Canadian venues.
>
> -MSK
>
>

---

From: Steven Bellovin <[email-masked]>
Date: Thu, 2 Aug 2012 23:16:37 -0700

Very nice!  My only good shot is at https://plus.google.com/104851702391844555696/posts/gRShCH3CFRT
(taken from the 34th Floor lounge)

>> for all the Canadian venues.

		--Steve Bellovin, https://www.cs.columbia.edu/~smb

---

From: Rajeev Bector <[email-masked]>
Date: Fri, 3 Aug 2012 09:39:19 -0700

Fireworks were pretty cool with the music sync and all that. I almost didnt
go there.. thinking yet another july 4th type fireworks.

Some of my shots.

http://www.flickr.com/photos/bector/sets/72157630885684454/

Rajeev

On Thu, Aug 2, 2012 at 11:16 PM, Steven Bellovin <[email-masked]>wrote:

> Very nice!  My only good shot is at
> https://plus.google.com/104851702391844555696/posts/gRShCH3CFRT
> that

---

From: Wes Hardaker <[email-masked]>
Date: Sat, 04 Aug 2012 22:30:48 -0700

> A few photos of the fireworks last night:

Don't forget (everyone on flickr) to add your pictures to the IETF
group.

Here's the best of my firework shots:

  https://plus.google.com/u/0/102459657085454157956/posts/P2Ph9Y5DFg7

The light before the event was fantastic too on Saturday night (jul
27).

  http://www.flickr.com/photos/hardaker/7713472528/in/photostream

-- 
Wes Hardaker
SPARTA, Inc.