Subject: [87attendees] Glasses Case

From: Ben Campbell <[email-masked]>
Date: Mon, 29 Jul 2013 23:24:12 +0200

HI,

I seem to have misplaced a black, clamshell eyeglasses case. I've got the glasses, so the case would be empty. Has anyone seen it?

Thanks!

Ben.

---

From: Ben Campbell <[email-masked]>
Date: Tue, 30 Jul 2013 09:15:02 +0200

Thanks to the excellent service of the Intercontinental, my glasses and their case have been reunited.

Thanks!

Ben.