Subject: [87attendees] Seven-bit shirts?

From: Paul Hoffman <[email-masked]>
Date: Wed, 31 Jul 2013 11:33:21 +0200

Dropping leading zeros in octets? Really?

---

From: <[email-masked]>
Date: Wed, 31 Jul 2013 11:40:22 +0200

Nowhere it is stated that this is a octet!
And look at the shirt there is lower case 2 at the end.
So that is the mathematical binary system.
That does not need octets ;-)

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Paul Hoffman
Gesendet: Mittwoch, 31. Juli 2013 11:33
An: [email-masked]
Betreff: [87attendees] Seven-bit shirts?

Dropping leading zeros in octets? Really?
_______________________________________________
87attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/87attendees

---

From: Scott Brim <[email-masked]>
Date: Wed, 31 Jul 2013 13:14:00 +0200

> And look at the shirt there is lower case 2 at the end.

In this crowd, there's no need for the 2.  We can recognize binary when
we encounter it.

By the way: "Never trust a man who can count to 1027 on his fingers."

swb

---

From: "John R Levine" <[email-masked]>
Date: 31 Jul 2013 13:28:37 +0200

> Dropping leading zeros in octets? Really?

If you don't want your shirt, I'll cheerfully take it off your hands.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
"I dropped the toothpaste", said Tom, crestfallenly.

PS: How often have they run out of tee shirts ? :(

---

From: Julian Reschke <[email-masked]>
Date: Wed, 31 Jul 2013 13:32:35 +0200

On 2013-07-31 13:28, John R Levine wrote:
> ...

Same here.

Best regards, Julian (just arrived and shirts are gone!)

---

From: Radek Krejčí <[email-masked]>
Date: Wed, 31 Jul 2013 13:40:20 +0200

> Best regards, Julian (just arrived and shirts are gone!)

+1

they were gone already yesterday morning

RK

---

From: Ted Lemon <[email-masked]>
Date: Wed, 31 Jul 2013 11:42:56 +0000

> Dropping leading zeros in octets? Really?

You can fit five of them in a 36-bit word, with a bit left over.   It's a big win.

---

From: "John R Levine" <[email-masked]>
Date: 31 Jul 2013 13:46:28 +0200

> You can fit five of them in a 36-bit word, with a bit left over.   It's a big win.

It's not left over, it tells you it's a sequence number.

Regards,

---

From: Scott Brim <[email-masked]>
Date: Wed, 31 Jul 2013 11:49:36 +0000

I will give a size L to the first caller.  Slightly used.

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 31 Jul 2013 13:50:35 +0200

>> You can fit five of them in a 36-bit word, with a bit left over.

You can sort people by age based on whether they know this.

---

From: Scott Brim <[email-masked]>
Date: Wed, 31 Jul 2013 11:55:08 +0000

>I will give a size L to the first caller.  Slightly used.

and ... gone.

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 31 Jul 2013 15:21:06 +0200

> You can sort people by age based on whether they know this.

Then there were those of us that worked with 60-bit words.  Much better 
for things like Linear Programming and such..,,,

-- 
Standard Robert Moskowitz
Senior Technical Advisor
Security & Standards
Verizon Business Systems
C:248-928-6233
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: Randall Gellens <[email-masked]>
Date: Wed, 31 Jul 2013 06:57:38 -0700

>  In this crowd, there's no need for the 2.  We can recognize binary when

I didn't get that the 2 meant binary...I'm not used to doing it that 
way.  A preceding character, sure.  Single tick marks enclosing, 
sure.  Subscripts?  Not so much.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Cabbage:  A familiar kitchen-garden vegetable about as large and wise
as a man's head.

---

From: Simon Perreault <[email-masked]>
Date: Wed, 31 Jul 2013 16:10:32 +0200

Le 2013-07-31 15:57, Randall Gellens a écrit :
> way.  A preceding character, sure.  Single tick marks enclosing, sure.
> Subscripts?  Not so much.

It's common math notation.

http://mathworld.wolfram.com/Base.html

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 31 Jul 2013 18:24:35 +0200

> http://mathworld.wolfram.com/Base.html

It was the way we did it back before the world all became hex. Doing 
things like base 12 was always fun.

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 31 Jul 2013 19:11:00 +0200

> for things like Linear Programming and such..,,,

I have experience with 12, 16, 24, 32, 36, 48, 60, 64 bit words.

And with 7,8,9 bit characters.

But IMO the 5 7-bit characters per 36 bit words was the weirdest.

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 31 Jul 2013 19:14:43 +0200

Revised list - I forgot some...

> I have experience with 12, 16, 24, 32, 36, 48, 60, 64 bit words.

12, 16, 18, 20, 24, 32, 36, 48, 60, 64 bit words.

---

From: Randall Gellens <[email-masked]>
Date: Wed, 31 Jul 2013 12:40:04 -0700

>  You can sort people by age based on whether they know this.

I used to develop O.S. software on a system that could fit eight 
6-bit characters or six 8-bit characters in each (48-bit) word. 
Everyone had a favorite hex pattern to fill initialized data that 
jumped out at you on a dump, and with 16 hexades you could more 
opportunity to spell things or make interesting patterns.

-------------- Randomly selected tag: ---------------
I always avoid prophesying beforehand, because it is a much better
policy to prophesy after the event has already taken place.
    --Winston Churchill

---

From: Vinayak Hegde <[email-masked]>
Date: Thu, 1 Aug 2013 01:17:44 +0530

This discussion (especially having 2 at the end) reminds me of this geeky
joke "There are 10 kinds of people in the world - those who understand
binary and those who don't" :)

-- Vinayak

On Wed, Jul 31, 2013 at 7:27 PM, Randall Gellens <[email-masked]>wrote:

> I didn't get that the 2 meant binary...I'm not used to doing it that way.
>  A preceding character, sure.  Single tick marks enclosing, sure.
>  Subscripts?  Not so much.
>
> --
> Randall Gellens
> ______________________________**_________________
> 87attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/87attendees<https://www.ietf.org/mailman/listinfo/87attendees>
>

---

From: Enno Rey <[email-masked]>
Date: Wed, 31 Jul 2013 21:27:42 +0200

> binary and those who don't" :)

which unfortunately only works in writing, not "at the bar"...

best

Enno

-- 
Enno Rey

ERNW GmbH - Carl-Bosch-Str. 4 - 69115 Heidelberg - www.ernw.de
Tel. +49 6221 480390 - Fax 6221 419008 - Cell +49 174 3082474

Handelsregister Mannheim: HRB 337135
Geschaeftsfuehrer: Enno Rey

Troopers 2013 Videos online: http://www.youtube.com/user/TROOPERScon?feature=watch

=======================================================
Blog: www.insinuator.net || Conference: www.troopers.de
=======================================================

---

From: Randall Gellens <[email-masked]>
Date: Wed, 31 Jul 2013 12:42:46 -0700

>  It's common math notation.

Sure, back in school.  But not in my day-to-day world.

-------------- Randomly selected tag: ---------------
Being president is like running a cemetery: You've got a lot of
people under you and nobody's listening.
      -- William Jefferson Clinton

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 31 Jul 2013 22:11:07 +0200

Le 31/07/2013 21:27, Enno Rey a écrit :
>> This discussion (especially having 2 at the end) reminds me of this
>> geeky joke "There are 10 kinds of people in the world - those who
>> understand binary and those who don't" :)
>

At the bar, one would say 'there are one-zero kinds of people in the
world... those who wear binary watches and those who dont'

Alex

>>> I didn't get that the 2 meant binary...I'm not used to doing it
>>> that way. A preceding character, sure.  Single tick marks
>>> enclosing, sure. Subscripts?  Not so much.
>>>
>>> -- Randall Gellens Opinions are personal;    facts are suspect;
>>> I speak for myself only -------------- Randomly selected tag:
>>> --------------- Cabbage:  A familiar kitchen-garden vegetable
>>> about as large and wise as a man's head.
>>>
>>> ______________________________**_________________ 87attendees
>>> mailing list [email-masked]
>> _______________________________________________ 87attendees mailing
>> list [email-masked]

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 31 Jul 2013 22:20:49 +0200

> understand binary and those who don't" :)

Is this that aggressive ietf cultural thing that drives people away that 
was covered this evening????

>
> -- Vinayak
>
> On Wed, Jul 31, 2013 at 7:27 PM, Randall Gellens 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     [email-masked] <mailto:[email-masked]>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 31 Jul 2013 22:54:55 +0000

On Jul 31, 2013, at 10:20 PM, Robert Moskowitz <[email-masked]> wrote:
> Is this that aggressive ietf cultural thing that drives people away that was covered this evening????

No.

(Seriously, no.  In-jokes may turn people off, and that's also bad for inclusiveness, but that's not the same issue.)