Subject: [93attendees] Terrific (small) city museum 2 blocks from Hilton

From: Lisa Lorenzin <[email-masked]>
Date: Wed, 22 Jul 2015 10:56:46 +0000

If you're into history and/or archaeology and have an hour or two free between 9am-6pm this week, check out the Prague City Museum!

Highlights:

* A _fascinating_ handmade 1:480 model of 1820s-30s Prague with a full 3D digitization (catch the 6-min 3D video flythrough every half-hour starting at 9:30)

* An impressive collection of archaeological artifacts from the Neolothic forward

* A very clear, informative history of the city itself evolving through the various imperial dynasties, wars, religious conflicts, etc.

You can see the whole museum in 2 hours, but even an hour is time well spent. (And it's only 120CZK admission.)

To get there, walk out LL, cross through the shopping arcade, and cross Sokolovska toward the Florenc metro station. Turn right on Sokolovska, walk up to the corner, cross Ke Stvanici, and go left towards the large ornate mustard-yellow building a block down, which is the museum. Street address: Na Porici 52. It's a 5-10 minute walk depending on crossing traffic & your walking speed...

Regards,

Lisa

Lisa Lorenzin

Principal Solutions Architect, Pulse Secure

919-384-7275<tel:919-384-7275> | [email-masked]<mailto: [email-masked]>

Please pardon brevity - sent from my phone

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 23 Jul 2015 21:16:06 +0000

My family went there today and they loved it. Only cost ~200 Kr for 3 of them.

Thanks!

From: 93attendees <[email-masked]<mailto:[email-masked]>> on behalf of Lisa Lorenzin <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 22, 2015 at 6:56 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [93attendees] Terrific (small) city museum 2 blocks from Hilton

Highlights:

Regards,

Lisa

Lisa Lorenzin