Subject: [93attendees] Good place to Exchange Euros for Czech Koruna

From: Vinayak Hegde <[email-masked]>
Date: Wed, 15 Jul 2015 17:52:44 +0530

Hi,

Any recommendations of places for exchanging Euros for Czech Koruna
near the Airport, Intercontinental or Hilton. In my experience, most
places near the airport have a huge markup + charge processing fees.
Want to avoid them.

Thanks
Vinayak

---

From: Jan Novak <[email-masked]>
Date: Wed, 15 Jul 2015 12:43:57 +0000

Hi,

These have good exchange rates (always look also for commission not just the rate):

http://czech-exchange.cz/en/
http://www.exchange.cz/  - no English page here
(https://www.google.cz/maps/place/EXCHANGE+s.r.o./@50.08803,14.418815,17z/data=!3m1!4b1!4m2!3m1!1s0x0:0xcd5190f6e091a879?hl=cs)

The rates at the airport or at the hotels too (I assume, never tried there) are always
the worst you can ever get ...

Jan

-----Original Message-----
From: 93attendees [mailto:[email-masked]] On Behalf Of Vinayak Hegde
Sent: 15 July 2015 13:23
To: [email-masked]
Subject: [93attendees] Good place to Exchange Euros for Czech Koruna

Hi,

Any recommendations of places for exchanging Euros for Czech Koruna near the Airport, Intercontinental or Hilton. In my experience, most places near the airport have a huge markup + charge processing fees.
Want to avoid them.

Thanks
Vinayak

_______________________________________________
93attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/93attendees

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 15 Jul 2015 05:46:00 -0700

Travelex at the airport even officially wrote down on the receipt a markup
of > 10% exchanging USD to CZK, so be aware.

-- 
---
Toerless Eckert, [email-masked]

---

From: Piotr Wydrych <[email-masked]>
Date: Wed, 15 Jul 2015 14:48:03 +0200

Vinayak, All,

> places near the airport have a huge markup + charge processing fees.

I always used <http://eurochange.cz/kudy-k-nam/> when in Prague. 20 
minutes by foot (ca. 1 mile) from Hilton or Intercontinental.

Best,
Piotr 'GhosT' Wydrych
-- 
Piotr 'GhosT' Wydrych .. xmpp:wydrych//agh.edu.pl .. http://wydrych.net/

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?

---

From: Dave Thompson <[email-masked]>
Date: Wed, 15 Jul 2015 14:47:12 +0000 (UTC)

I've always found ATM's to be a place to get a good exchange rate.   Banks have access to the best exchange rates.  ATM charges a fixed fee, and your card fee is known ahead of time.      So for example, ATM fee ~$2, and card issuer fee between 1.0 to 3.0% depending on your issuer.    Compare this to a  typical 10% airport exchange cost.     If going this way, you should tell your bank ahead of time of your travel plans, else you may set off the automatic security flag and accidentally get your card shut off. 

     On Wednesday, July 15, 2015 7:48 AM, Piotr Wydrych <[email-masked]> wrote:

 Vinayak, All,

Best,
Piotr 'GhosT' Wydrych

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 15 Jul 2015 14:57:07 +0000

This has always been my strategy, too. And I use a card from Schwab, who refunds all ATM fees and charges no international exchange fees. I also consistently get a better exchange rate than the one my company gets on the charges I put on the corporate credit card.
Barbara

From: 93attendees [mailto:[email-masked]] On Behalf Of Dave Thompson
Sent: Wednesday, July 15, 2015 10:47 AM
To: Piotr Wydrych; Vinayak Hegde
Cc: [email-masked]
Subject: Re: [93attendees] Good place to Exchange Euros for Czech Koruna

On Wednesday, July 15, 2015 7:48 AM, Piotr Wydrych <[email-masked]<mailto:[email-masked]>> wrote:

Vinayak, All,

Best,
Piotr 'GhosT' Wydrych

_______________________________________________
93attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/93attendees

---

From: Kirill Nikitin <[email-masked]>
Date: Thu, 16 Jul 2015 09:55:42 +0300

Hi,

Previous time I was in Prague. I exchanged money at offices at "Politických
vězňů" street (had done some research before for the best exchange rate) which
is close to the main train station (Hlavní nádraží). There are about 5
offices on the street, mostly arab-owned, and offer very good rates even
for smaller amounts. It is the best if you have euro (or dollars) in cash
to exchange. When you enter one of the offices, you can tell a cashier
there how much you would like to exchange. He then type on a calculator how
much CZK you would get for that amount of euro. You can then count if the
exchange rate is consistent with one that they claim and exchange if
everything is correct.
I think this is one of the most popular places for exchange in Prague. At
least, I used them last time and everything went well.

To get there:
Take metro at Florenc-C (station next to Hilton) for 2 stops till Museum-C
station. Then take an exit to Washingtonova street (a delight
for Americans:))  and walk towards the main train station. Basically, the
very first crossroad will be with Politických vězňů. You will see boards
with exchange rates then.

Best,
Kirill

Kirill Nikitin
[email-masked]
+46 720326184

2015-07-15 17:57 GMT+03:00 STARK, BARBARA H <[email-masked]>:

>  This has always been my strategy, too. And I use a card from Schwab, who
> refunds all ATM fees and charges no international exchange fees. I also
> consistently get a better exchange rate than the one my company gets on the
> charges I put on the corporate credit card.
>
> Barbara
>
>
>
> *From:* 93attendees [mailto:[email-masked]] *On Behalf Of *Dave
> Thompson
> *Sent:* Wednesday, July 15, 2015 10:47 AM
> *To:* Piotr Wydrych; Vinayak Hegde
> *Cc:* [email-masked]
> *Subject:* Re: [93attendees] Good place to Exchange Euros for Czech Koruna
>
>
>
> I've always found ATM's to be a place to get a good exchange rate.   Banks
> have access to the best exchange rates.  ATM charges a fixed fee, and your
> card fee is known ahead of time.      So for example, ATM fee ~$2, and card
> issuer fee between 1.0 to 3.0% depending on your issuer.    Compare this to
> a  typical 10% airport exchange cost.     If going this way, you should
> tell your bank ahead of time of your travel plans, else you may set off the
> automatic security flag and accidentally get your card shut off.
>
>
>
>
>

---

From: "George, Wes" <[email-masked]>
Date: Sun, 19 Jul 2015 05:04:02 -0400

FWIW, the Google tells me that the current rate is 27.05CZK to the Euro
and 24.98 to the USD. There is an automated changing machine in the Hilton
lobby, advertising buy rates of 25.23CZK:Euro and 23.11:USD, so if you
don't go the ATM route, at least you know of one place where the markup is
lower than the 10% mentioned elsewhere.

Thanks,

Wes

>places near the airport have a huge markup + charge processing fees.

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Sun, 19 Jul 2015 15:10:35 +0000

Have tried the changing machine in Hilton lobby, inserting 100 Euro and it gives me 2390 CZK, apprarently it takes some extra fees.

Regards,
Jie
________________________________________
From: 93attendees [[email-masked]] on behalf of George, Wes [[email-masked]]
Sent: Sunday, July 19, 2015 17:04
To: Vinayak Hegde; [email-masked]
Subject: Re: [93attendees] Good place to Exchange Euros for Czech Koruna

Thanks,

Wes

---

From: "Liushucheng (Will)" <[email-masked]>
Date: Sun, 19 Jul 2015 21:33:39 +0000

Even worse one is taxi driver, whose currency is 1Euro=20CZK!
It's seems that the best current practice until now is ATM if your bank only charge 1.5~3%, very close to the one Google said.

Cheers,
Will

> From: 93attendees [mailto:[email-masked]] On Behalf Of
> Dongjie (Jimmy)
> Sent: Sunday, July 19, 2015 5:11 PM
> To: George, Wes; Vinayak Hegde; [email-masked]
> Have tried the changing machine in Hilton lobby, inserting 100 Euro and it
> gives me 2390 CZK, apprarently it takes some extra fees.
> 
> Regards,
> Jie
> and 24.98 to the USD. There is an automated changing machine in the
> Hilton lobby, advertising buy rates of 25.23CZK:Euro and 23.11:USD, so if
> you don't go the ATM route, at least you know of one place where the
> markup is lower than the 10% mentioned elsewhere.
> 
> Thanks,
> 
> Wes
> 
> 
> 
> 
> This E-mail and any of its attachments may contain Time Warner Cable
> proprietary information, which is privileged, confidential, or subject to
> copyright belonging to Time Warner Cable. This E-mail is intended solely
> for the use of the individual or entity to which it is addressed. If you are
> not the intended recipient of this E-mail, you are hereby notified that any
> dissemination, distribution, copying, or action taken in relation to the
> contents of and attachments to this E-mail is strictly prohibited and may
> be unlawful. If you have received this E-mail in error, please notify the
> sender immediately and permanently delete the original and any copy of
> this E-mail and any printout.

---

From: <[email-masked]>
Date: Sun, 19 Jul 2015 16:37:36 -0500

Just wanted to double check, the Hilton lobby changing machine accepts dollars right?

Thanks in advance,
Ramki

-----Original Message-----
From: 93attendees [mailto:[email-masked]] On Behalf Of Liushucheng (Will)
Sent: Sunday, July 19, 2015 2:34 PM
To: Dongjie (Jimmy); George, Wes; Vinayak Hegde; [email-masked]
Subject: Re: [93attendees] Good place to Exchange Euros for Czech Koruna

Cheers,
Will

> Have tried the changing machine in Hilton lobby, inserting 100 Euro 
> and it gives me 2390 CZK, apprarently it takes some extra fees.
> 
> Regards,
> Jie
> FWIW, the Google tells me that the current rate is 27.05CZK to the 
> Euro and 24.98 to the USD. There is an automated changing machine in 
> the Hilton lobby, advertising buy rates of 25.23CZK:Euro and 
> 23.11:USD, so if you don't go the ATM route, at least you know of one 
> place where the markup is lower than the 10% mentioned elsewhere.
> 
> Thanks,
> 
> Wes
> 
> 
> 
> 
> proprietary information, which is privileged, confidential, or subject 
> to copyright belonging to Time Warner Cable. This E-mail is intended 
> solely for the use of the individual or entity to which it is 
> addressed. If you are not the intended recipient of this E-mail, you 
> are hereby notified that any dissemination, distribution, copying, or 
> action taken in relation to the contents of and attachments to this 
> E-mail is strictly prohibited and may be unlawful. If you have 
> received this E-mail in error, please notify the sender immediately 
> and permanently delete the original and any copy of this E-mail and any printout.

---

From: Vinayak Hegde <[email-masked]>
Date: Mon, 20 Jul 2015 21:34:40 +0530

> the worst you can ever get ...

This place was quick and the exchange rate was good (26.66 to the Euro
a couple days back). If you are at the Intercontinental then this
place is a good bet.

I had a horrible experience at the Citibank ATM. I had a Citibank card
and though being a customer I could get a good rate. I got a 10%
markup. So be sure if you are using your home crad. So much for
avoiding the travelex counters at the airport.

Thanks
Vinayak