Subject: [93attendees] Meeting schedule

From: Randall Gellens <[email-masked]>
Date: Mon, 20 Jul 2015 15:16:09 -0700

The meeting schedule, in my view, runs too late in the evening. 
Tonight's session ended at 7:50 PM, meaning it was 8:15 before one 
could even start trying to go to dinner.  This means it's 9:00 before 
one is able to eat, which in my view, is far too late.  I know people 
hated the old-old schedule that went until 10, but at least that had 
a dinner break at a 6:00, a reasonable hour; if we absolutely must go 
late, that was a better way to do it.  The schedule this time forces 
people to either try to sleep on a full stomach (which I can't do), 
skip dinner, or stay up way late and be sleep-deprived, fueled by 
caffeine and adrenaline (which I think makes for very bad meetings 
and bad technical work).

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
It seems like the less a statesman amounts to, the more he loves
the flag.

---

From: Ole Jacobsen <[email-masked]>
Date: Mon, 20 Jul 2015 16:40:01 -0700 (PDT)

On Mon, 20 Jul 2015, Randall Gellens wrote:

> The meeting schedule, in my view, runs too late in the evening. Tonight's
> session ended at 7:50 PM, meaning it was 8:15 before one could even start
> trying to go to dinner.  This means it's 9:00 before one is able to eat, which
> in my view, is far too late.  I know people hated the old-old schedule that
> went until 10, but at least that had a dinner break at a 6:00, a reasonable
> hour; if we absolutely must go late, that was a better way to do it.  The
> schedule this time forces people to either try to sleep on a full stomach
> (which I can't do), skip dinner, or stay up way late and be sleep-deprived,
> fueled by caffeine and adrenaline (which I think makes for very bad meetings
> and bad technical work).
> 
> -- 
> Randall Gellens

Randall,

I agree with you, but the topic deserves discussion beyond the current 
attendee list, so I have taken the liberty of copying the IESG and 
IAOC on this reply.

As you know, the "European dinner schedule" was introduced at one of 
our Paris meetings to account for the fact that many restaurants there 
would not even be open at our previous 17:30 - 18:00 end time. It 
seems that some of our current end times have slipped beyond the 
original concept, so I think this deserves some further discussion.

(Of course I have a personal interest in this since I am arranging an 
event in Yokohama that I am hoping to start at 19:00, but I still 
agree that we need to re-think the schedule)

Ole Jacobsen
Principal without Chorus
Organdemo.info
http://www.yokohama-organdemo.org/

---

From: Kireeti Kompella <[email-masked]>
Date: Mon, 20 Jul 2015 23:48:15 +0000

Speaking for myself, I far prefer this schedule to one that constrains you to an hour and a half of dinner, and wants you to then come back and meet some more. 

Kireeti.

> On Jul 21, 2015, at 01:40, Ole Jacobsen <[email-masked]> wrote:
> 
> 
> _______________________________________________
> 93attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/93attendees

---

From: Ole Jacobsen <[email-masked]>
Date: Mon, 20 Jul 2015 16:52:49 -0700 (PDT)

On Mon, 20 Jul 2015, Kireeti Kompella wrote:

> Speaking for myself, I far prefer this schedule to one that 
> constrains you to an hour and a half of dinner, and wants you to 
> then come back and meet some more.
> 
> Kireeti.
> 

And I agree with that as well! But the current long day, which for
many includes breakfast meetings, runs 7am to [nearly] 8pm which
probably does not contribute to overall productivity.

So many meetings, so little time....

Ole

---

From: Randy Bush <[email-masked]>
Date: Tue, 21 Jul 2015 02:18:01 +0200

> Speaking for myself, I far prefer this schedule to one that constrains
> you to an hour and a half of dinner, and wants you to then come back
> and meet some more.

yup

---

From: Bob Hinden <[email-masked]>
Date: Tue, 21 Jul 2015 06:30:57 +0200

> On Jul 21, 2015, at 1:48 AM, Kireeti Kompella <[email-masked]> wrote:
> 

I prefer that as well.  I never liked the earlier dinner break schedule.

Bob

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 21 Jul 2015 16:48:49 +1200

>> then come back and meet some more.

I think of the current arrangement as the "Paris schedule", because
we introduced it for IETF 63, since the old schedule with "dinner"
at 5:30 p.m. would have been laughable in Paris, where many restaurants
simply don't serve meals that early.

But people liked it better, for the reason Kireeti gave, so it stuck.

> probably does not contribute to overall productivity.

As long as people want to arrive on Sunday and leave on Friday
afternoon, it's hard to see what to change.

    Brian

---

From: Yoav Nir <[email-masked]>
Date: Tue, 21 Jul 2015 07:15:51 +0200

> afternoon, it's hard to see what to change.

The two plenaries add up to 5 hours. If they didn’t take up real meeting time, we could shorten each meeting day by one hour.

That would mean getting the plenaries back to the end of the day, and anyone who wanted an early dinner could skip them.

But regardless, for “real IETF-ers”, the ones who don’t come for just a few sessions, an IETF week is always pretty intense.

Yoav

---

From: "Howard, Lee" <[email-masked]>
Date: Tue, 21 Jul 2015 01:47:03 -0400

I haven¹t gone back to look at all previous meeting schedules, but I
looked at the most recent one:
https://datatracker.ietf.org/meeting/92/agenda.html

WG meetings ended at 1830 or 1840 daily. Plenaries started late, as
with Social, Bits-n-Bites, but at least the latter two provided food.

So is it the case that daytime plenaries tacked on an hour to the
schedule? That effort failed, because after just one day of meetings, I¹m
going to miss the tech plenary, because I need a nap after my breakfast
meeting.

Lee

>caffeine and adrenaline (which I think makes for very bad meetings

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 21 Jul 2015 10:17:13 +0200

I also prefer going back to the plenaries at the end of the day. I
understand that having them in the morning is more convenient for the
hotel, but they're here to serve us, not vice versa.

Cheers,
Andy

On Tue, Jul 21, 2015 at 7:15 AM, Yoav Nir <[email-masked]> wrote:

> The two plenaries add up to 5 hours. If they didn’t take up real meeting
> time, we could shorten each meeting day by one hour.
>
> That would mean getting the plenaries back to the end of the day, and
> anyone who wanted an early dinner could skip them.
>
> But regardless, for “real IETF-ers”, the ones who don’t come for just a
> few sessions, an IETF week is always pretty intense.
>
> Yoav
>
>

---

From: Alia Atlas <[email-masked]>
Date: Tue, 21 Jul 2015 04:21:12 -0400

This IETF we had more WG meeting time requested than could be met.  With
concern requested, the time requested did decrease.

The plenaries are in the morning because it allows the rooms to be reset
during lunch.  Having them in the evening would have eaten the meeting
rooms for the time slot before the plenary which would have further
decreased the available meeting time for WG meetings.

I'm in the technical plenary now and it seems to be quite well attended.

Regards,
Alia

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 21 Jul 2015 10:27:27 +0200

Alia,

That must have been a particular issue for this hotel, becuase in most
other IETFs, the meeting rooms were opened up during the snack break for
the plenary.

Cheers,
Andy

---

From: "Ben Campbell" <[email-masked]>
Date: Tue, 21 Jul 2015 10:44:20 +0200

> I'm in the technical plenary now and it seems to be quite well 

Let's see what the energy level is in the last meeting of the day. 
Long-day fatigue is likely to have more impact on working group meetings 
than on plenaries.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 21 Jul 2015 10:58:27 +0200

Ben,

This may have been particularly unique to the dramatic change in time zone
and meeting after dinner, but when we met in Adelaide, we still had the
schedule where we had dinner and then returned for meetings from 19:30 to
22:00. I was in the MPLS WG meeting that evening, and at least half the
room was fast asleep.

Cheers,
Andy

---

From: Kyle Rose <[email-masked]>
Date: Tue, 21 Jul 2015 05:14:36 -0400

Agreed.

I think the primary issue is that there are too many sessions per day,
presumably to minimize overlap. One could skip the late sessions if
desired (as I did yesterday), but in my case I was still unable to eat
dinner until 9:00 because I had dinner plans with fellow attendees who
*were* at those sessions. I'd almost rather the conference go one
additional day and otherwise be done by 6:00 every night.

---

From: Randall Gellens <[email-masked]>
Date: Tue, 21 Jul 2015 02:34:53 -0700

> then come back and meet some more.

It's a question of what to optimize for:
	- Sheer quantity of meeting time
	- Opportunity for attendees to have adequate sleep
	- Opportunities for attendees to eat
	- Opportunities for ad-hoc meetings and socializing

Personally, I value my health and strongly believe that my ability to 
get adequate sleep has a direct and immediate impact on my ability to 
contribute meaningfully and do high-quality work, and suggest that 
this holds true for others.  I know many others feel they are able to 
function on little sleep and lots of caffeine and adrenaline, and 
would disregard any studies suggesting they are deluding oneself.

-------------- Randomly selected tag: ---------------
The idea that Bill Gates has appeared like a knight in shining armor
to lead all customers out of a mire of technological chaos neatly
ignores the fact that it was he who, by peddling second-rate technology,
led them into it in the first place.                    --Douglas Adams

---

From: Randall Gellens <[email-masked]>
Date: Tue, 21 Jul 2015 02:36:53 -0700

>  additional day and otherwise be done by 6:00 every night.

I'd be fine with extending by an extra day, and/or having WG sessions 
on Sunday or later on Friday.

-------------- Randomly selected tag: ---------------
Very funny, Scotty.  Now beam down my clothes.

---

From: Jared Mauch <[email-masked]>
Date: Tue, 21 Jul 2015 05:41:32 -0400

On Tue, Jul 21, 2015 at 02:34:53AM -0700, Randall Gellens wrote:
> >you to an hour and a half of dinner, and wants you to then come back and
> >meet some more.
> 
> Personally, I value my health and strongly believe that my ability to get
> adequate sleep has a direct and immediate impact on my ability to contribute
> meaningfully and do high-quality work, and suggest that this holds true for
> others.  I know many others feel they are able to function on little sleep
> and lots of caffeine and adrenaline, and would disregard any studies
> suggesting they are deluding oneself.

        I have certainly seen an increase in interim meetings occuring
for various WGs that I track. I think this is a good thing trying to
get the work moved along.  Two WGs I plan to attend ended up
on Mon + Fri.  With the location and family obligations
at home, Friday ended up being my trek-home day meaning I will
miss these WGs.  I know scheduling is hard and I talked to the WG
chairs to ask for them to provide some input on the scheduling this
time.  I've already heard feedback that it should be better next time,
and for that I think those who offer up their time to help make the IETF
what it is, despite all the on-list and off-list gripes that occur.

        - Jared

-- 
Jared Mauch  | pgp key available via finger from [email-masked]
clue++;      | http://puck.nether.net/~jared/  My statements are only mine.

---

From: joel jaeggli <[email-masked]>
Date: Tue, 21 Jul 2015 10:41:30 +0200

> other IETFs, the meeting rooms were opened up during the snack break for

Not really, we typically organize the rooms typically such that the
plenary room is un-occupied in the immediately proceeding meeting.

there are a bunch of inputs to the precise arrangement of the schedule.
this particular arrangement is driven by a number of accommodations,
which are not likely to precisely replicated in the future.

> Cheers,
> Andy
> 
> On Tue, Jul 21, 2015 at 10:21 AM, Alia Atlas <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     This IETF we had more WG meeting time requested than could be met. 
>     With concern requested, the time requested did decrease.
> 
>     The plenaries are in the morning because it allows the rooms to be
>     reset during lunch.  Having them in the evening would have eaten the
>     meeting rooms for the time slot before the plenary which would have
>     further decreased the available meeting time for WG meetings.
> 
>     On Tue, Jul 21, 2015 at 4:17 AM, Andrew G. Malis <[email-masked]
>     <mailto:[email-masked]>> wrote:
> 
>         I also prefer going back to the plenaries at the end of the day.
>         I understand that having them in the morning is more convenient
>         for the hotel, but they're here to serve us, not vice versa.
> 
>         Cheers,
>         Andy
> 
> 
>         On Tue, Jul 21, 2015 at 7:15 AM, Yoav Nir <[email-masked]
>         <mailto:[email-masked]>> wrote:
> 
> 
>             On Jul 21, 2015, at 6:48 AM, Brian E Carpenter
>             <[email-masked]
>             <mailto:[email-masked]>> wrote:
> 
>             The two plenaries add up to 5 hours. If they didn’t take up
>             real meeting time, we could shorten each meeting day by one
>             hour.
> 
>             That would mean getting the plenaries back to the end of the
>             day, and anyone who wanted an early dinner could skip them.
> 
>             But regardless, for “real IETF-ers”, the ones who don’t come
>             for just a few sessions, an IETF week is always pretty intense.
> 
>             Yoav
> 
> 
>             [email-masked] <mailto:[email-masked]>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 21 Jul 2015 22:16:25 +1200

On 21/07/2015 21:36, Randall Gellens wrote:
> I'd be fine with extending by an extra day, and/or having WG sessions on Sunday or later on Friday.

Let me disagree strongly. Saturday and Sunday are already full days for
some people - writing code rather than going to meetings, in many cases.
Sunday, Friday and Saturday are each unacceptable to some people for
personal reasons; using Friday morning is a compromise. Many people would
find taking more than 5 days out of the office impossible. I don't think
that we can completely avoid late evenings.

I hear a rumour of scaling back to only one plenary (like the old days).
That seems very desirable.

    Brian

---

From: Ted Lemon <[email-masked]>
Date: Tue, 21 Jul 2015 07:23:30 -0400

> That would mean getting the plenaries back to the end of the day, and anyone who wanted an early dinner could skip them.

That is an excellent argument for having the plenaries in the morning, I guess, but I suspect that wasn’t your intent.   If the plenaries aren’t working, we should fix them, not skip them.

---

From: Yoav Nir <[email-masked]>
Date: Tue, 21 Jul 2015 13:37:19 +0200

> On Jul 21, 2015, at 1:23 PM, Ted Lemon <[email-masked]> wrote:
> 
> On Jul 21, 2015, at 1:15 AM, Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:

I don’t know how to answer that without a stated goal of what plenaries are supposed to accomplish.

---

From: Andy Newton <[email-masked]>
Date: Tue, 21 Jul 2015 11:38:32 +0000

> On Jul 21, 2015, at 10:21 AM, Alia Atlas <[email-masked]> wrote:
> 
> This IETF we had more WG meeting time requested than could be met.  With concern requested, the time requested did decrease.
> 
> The plenaries are in the morning because it allows the rooms to be reset during lunch.  Having them in the evening would have eaten the meeting rooms for the time slot before the plenary which would have further decreased the available meeting time for WG meetings.
> 

I have a lot of sympathy for the secretariat and staff with regards to constant room rearrangements.

Another solution to the problem is to put the plenaries on Friday.

-andy

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 21 Jul 2015 23:51:20 +1200

> I don’t know how to answer that without a stated goal of what plenaries are supposed to accomplish.

It's clear that two main purposes of the plenaries are
a) for all our 'management' groups to report transparently to the community;
b) for the community to give honest open feedback to the 'management', or
to raise issues of general interest that don't fit anywhere else.

I am a little puzzled about the goal of the technical presentations
in the IAB plenary, but I'm ready to be educated.

    Brian

---

From: Dave Crocker <[email-masked]>
Date: Tue, 21 Jul 2015 14:04:21 +0200

> some people - writing code rather than going to meetings, in many cases.

+10

We should be looking for ways to reduce the number of meeting hours, not
to increase them.

However, this would require far more stringent filtering of session
requests, and to date, there has been neither community demand, nor IETF
management resolve, to do this.

d/
-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Ted Lemon <[email-masked]>
Date: Tue, 21 Jul 2015 08:10:10 -0400

> that we can completely avoid late evenings.

Another option would be to make more efficient use of meeting time.   Still, after all these years, the presentation/discussion format assumes that nobody has read the drafts, and that nevertheless everything is qualified to speak at the mic.   Sales pitches are great, but should be brief; discussions should be among people who have read the documents.   And political discussions probably ought not to occur in working group meetings, because they just waste time.

I think that if we just said “the schedule will be four days, regular business hours only, with a half day on Friday ending at noon, and the plenary on Monday at 9,” and chunked sessions down to an hour each, we’d get a lot more value out of the meeting, because we could have fewer tracks, more meetings, and chairs and participants would have to be strategic about what presentations to allow and what form the presentations would take.   It always bugs me when I see a working group consuming six hours or more of agenda time.

This is partly motivated by a belief that what in-person meetings accomplish best is people who are doing real work talking face to face.   Most of the discussion that occurs at the mic is wasted time; most of the presentations are wasted time.  This is the source of the truism that most of the work at the IETF occurs during the breaks.   It would be nice if we could change that.

Speaking as someone who is currently missing his first IETF since Oslo, I’m asking myself whether I’m actually losing out.   The fact is that the most useful discussions I’ve participated in in this IETF have all been the jabber room; the presentations have been of minimal use, and the microphone discussions haven’t been particularly constructive.   This is not to say that they are _completely_ useless, just that they aren’t a particularly good use of the quite expensive f2f time we all generally have three times every year.

---

From: Jeff Haas <[email-masked]>
Date: Tue, 21 Jul 2015 14:14:08 +0200

> On Jul 21, 2015, at 2:04 PM, Dave Crocker <[email-masked]> wrote:
> 

How well have we done the last few meetings, including this one, at having full session times?  If we have fractional sessions, do we have any possibility of squeezing two groups into a single room?

-- Jeff

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 21 Jul 2015 12:15:48 +0000

Given that we now record meetings in audio and video, it seems that mostly-presentation meetings (including status updates) could be parallel-tracked to regular working group sessions. Today's IAB plenary was interesting, but the information content would have been roughly the same if watched later. (We can then see if Netflix carries the session, and consider an IAB plenary binge watching session.)

These sessions are useful for new attendees and they beat sitting in the terminal room, but allowing people a choice between early dinner and status updates (and catching the video version later, if needed) seems like a reasonable trade-off, given the constrained design space.

This obviously doesn't work for the IESG plenary.

________________________________________
From: 93attendees <[email-masked]> on behalf of Dave Crocker <[email-masked]>
Sent: Tuesday, July 21, 2015 8:04 AM
To: [email-masked]
Cc: [email-masked]; Ole Jacobsen; The IESG
Subject: Re: [93attendees] Meeting schedule

+10

d/

---

From: Alia Atlas <[email-masked]>
Date: Tue, 21 Jul 2015 08:17:01 -0400

On Tue, Jul 21, 2015 at 8:14 AM, Jeff Haas <[email-masked]> wrote:

> How well have we done the last few meetings, including this one, at having
> full session times?  If we have fractional sessions, do we have any
> possibility of squeezing two groups into a single room?
>

Sometimes we do that.  I believe that PIM and MBONED are doing that again
this time.

Alia

---

From: Ted Lemon <[email-masked]>
Date: Tue, 21 Jul 2015 08:20:47 -0400

> I don’t know how to answer that without a stated goal of what plenaries are supposed to accomplish.

The purpose of the plenaries is (1) to get the community all together and thinking about some problem relevant to the IETF (tech plenary) and (2) to get the community all together and thinking about how to run the IETF properly (admin plenary).

I think both could be streamlined and made more useful, and I actually think the tech plenary tends to be a missed opportunity—interesting, but not all that relevant to building connection within the IETF or making IETF participants aware of what other IETF participants are working on.   That’s a shame.

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 21 Jul 2015 08:22:08 -0400

On Tue, Jul 21, 2015 at 8:17 AM, Alia Atlas <[email-masked]> wrote:

>> How well have we done the last few meetings, including this one, at
>> having full session times?  If we have fractional sessions, do we have any

IPsecMe and COSE shared a room.  This was nice as we had some more crypto
folks in the room for COSE and hopefully piqued their interest.

-- 

Best regards,
Kathleen

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 21 Jul 2015 12:54:31 +0000

Another random scheduling idea: Schedule the plenaries during the lunch slot, since processing sandwiches and slides in parallel is known to work. To make this more efficient and to have the right number of vegetarian/turkey/... options at hand, pre-sell lunch tickets during registration, similar to the social event tickets.

Henning

---

From: Ted Lemon <[email-masked]>
Date: Tue, 21 Jul 2015 08:57:11 -0400

> Another random scheduling idea: Schedule the plenaries during the lunch slot, since processing sandwiches and slides in parallel is known to work. To make this more efficient and to have the right…

Vegetarian sandwiches made by hotel chefs can be safely assumed to suck.   I would either skip the plenary or dash out for food if they were done this way.

---

From: Ole Jacobsen <[email-masked]>
Date: Tue, 21 Jul 2015 06:00:58 -0700 (PDT)

On Tue, 21 Jul 2015, Ted Lemon wrote:

> Vegetarian sandwiches made by hotel chefs can be safely assumed to 
> suck.  I would either skip the plenary or dash out for food if they 
> were done this way.
> 

Can you please discuss the merits of a lunchtime plenary instead of
focusing on the catering details? There are clearly pros and cons of
using the lunch break for an all-attendees events, but I doubt the
most pressing issue is the quality of the sandwiches! (Plus that is
*clearly* a solvable problem)

Thanks,

Ole

---

From: Randall Gellens <[email-masked]>
Date: Tue, 21 Jul 2015 05:40:18 -0700

At 8:10 AM -0400 7/21/15, Ted Lemon wrote:

>  Another option would be to make more efficient use of meeting time. 
> Still, after all these years, the presentation/discussion format 
> assumes that nobody has read the drafts, and that nevertheless 
> everything is qualified to speak at the mic.   Sales pitches are 
> great, but should be brief; discussions should be among people who 
> have read the documents.   And political discussions probably ought 
> not to occur in working group meetings, because they just waste 
> time.
>
>  I think that if we just said "the schedule will be four days, 
> regular business hours only, with a half day on Friday ending at 
> noon, and the plenary on Monday at 9," and chunked sessions down to 
> an hour each, we'd get a lot more value out of the meeting, because 
> we could have fewer tracks, more meetings, and chairs and 
> participants would have to be strategic about what presentations to 
> allow and what form the presentations would take.   It always bugs 
> me when I see a working group consuming six hours or more of agenda 
> time.
>
>  This is partly motivated by a belief that what in-person meetings 
> accomplish best is people who are doing real work talking face to 
> face.   Most of the discussion that occurs at the mic is wasted 
> time; most of the presentations are wasted time.  This is the 
> source of the truism that most of the work at the IETF occurs 
> during the breaks.   It would be nice if we could change that.

I'm all for having shorter sessions be the norm, as that helps get WG 
agendas to focus on the issues that are not reaching conclusion on 
the list.  If, say, 60 minutes was the norm, and WGs with many active 
drafts and/or many active issues that need discussion able to have 
some number of hopefully consecutive slots, that might help a lot.

I also think we should have a few slots during the week when no WGs 
are scheduled, for use in scheduling ad-hoc discussions.  These could 
be perhaps 30-45 minutes and possibly scheduled just prior to breaks, 
allowing more time for involved discussions.

-------------- Randomly selected tag: ---------------
Invention is the mother of necessity.       --Thorstein Veblen

---

From: Charlie Perkins <[email-masked]>
Date: Tue, 21 Jul 2015 05:59:11 -0700

Hello Ted,

Recent technical plenaries have been very interesting and I hope they 
will continue.  WG chairs could conceivably preview the upcoming 
technical plenary topics and recommend topics of likely specific 
interest to their WG members.  That might be very helpful to take 
advantage of opportunities for building connections within the IETF.  I 
say "conceivably" because the chairs usually have plenty of other urgent 
tasks and deadlines to deal with.

Regards,
Charlie P.

On 7/21/2015 5:20 AM, Ted Lemon wrote:
> On Jul 21, 2015, at 7:37 AM, Yoav Nir <[email-masked] 
> The purpose of the plenaries is (1) to get the community all together 
> and thinking about some problem relevant to the IETF (tech plenary) 
> and (2) to get the community all together and thinking about how to 
> run the IETF properly (admin plenary).
>
> I think both could be streamlined and made more useful, and I actually 
> think the tech plenary tends to be a missed opportunity—interesting, 
> but not all that relevant to building connection within the IETF or 
> making IETF participants aware of what other IETF participants are 
> working on.   That’s a shame.
>
>
>

---

From: Aaron Falk <[email-masked]>
Date: Tue, 21 Jul 2015 15:24:05 +0200

On Tue, Jul 21, 2015 at 2:54 PM, Henning Schulzrinne <
[email-masked]> wrote:

> Another random scheduling idea: Schedule the plenaries during the lunch
> slot, since processing sandwiches and slides in parallel is known to work.
> To make this more efficient and to have the right number of
> vegetarian/turkey/... options at hand, pre-sell lunch tickets during
> registration, similar to the social event tickets.
>

I like this idea.

--aaron

---

From: Ted Lemon <[email-masked]>
Date: Tue, 21 Jul 2015 09:26:33 -0400

On Jul 21, 2015, at 9:00 AM, Ole Jacobsen <[email-masked]> wrote:
> focusing on the catering details? 

That is one of the non-merits of a lunchtime plenary.   It is one that would literally cause me to skip a plenary, which I normally consider very important to attend.   Check your privilege.   Seriously.   Not everybody has the same easy food experience you do at IETF.

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 21 Jul 2015 13:29:29 +0000

As long as the number of people with special food needs is smallish, this should be manageable, possibly at the cost of missing the first 15 minutes. This obviously works better in places like Prague, with plenty of take-out and grocery store options.

________________________________
From: Ted Lemon <[email-masked]>
Sent: Tuesday, July 21, 2015 9:26 AM
To: Ole Jacobsen
Cc: Henning Schulzrinne; The IESG; [email-masked]; [email-masked]
Subject: Re: [IAOC] [93attendees] Meeting schedule

On Jul 21, 2015, at 9:00 AM, Ole Jacobsen <[email-masked]<mailto:[email-masked]>> wrote:
Can you please discuss the merits of a lunchtime plenary instead of
focusing on the catering details?

---

From: Yoav Nir <[email-masked]>
Date: Tue, 21 Jul 2015 15:31:46 +0200

> On Jul 21, 2015, at 2:54 PM, Henning Schulzrinne <[email-masked]> wrote:
> 

This goes back to the question of whether we expect everyone to want to go to the plenary (yes, I know what the dictionary says about “plenary”)

I don’t believe all 1533 of us are interested in the content of the plenaries. 

Yoav

---

From: Ted Lemon <[email-masked]>
Date: Tue, 21 Jul 2015 09:36:56 -0400

> As long as the number of people with special food needs is smallish, this should be manageable, possibly at the cost of missing the first 15 minutes. This obviously works better in places like Prag…

Impositions always seem small if you are not the one bearing them.   I would appreciate it if you could stop denying that the problem with your proposal that I have raised is a problem.   It may be that what I want is actually not important, but it’s a real problem for me, even if it’s not a problem for you.   Furthermore, solving the problem that we are making poor use of time during IETF f2f meetings by cramming the agenda with yet another interval when we don’t have a break is not going to solve the problem.   Instead, it’s going to result in more people skipping the plenary.

Why not instead solve the problem that we don’t make good use of IETF meeting time?

---

From: Ted Lemon <[email-masked]>
Date: Tue, 21 Jul 2015 09:37:54 -0400

> I don’t believe all 1533 of us are interested in the content of the plenaries. 

Fair enough, but is that a problem with us, or with the plenaries?   Do you really think that we don’t need to have ietf-wide meetings at all?   To me the siloization of the IETF seems like a bug, not a feature.

---

From: Dave Crocker <[email-masked]>
Date: Tue, 21 Jul 2015 15:41:02 +0200

> Furthermore, solving the problem that we are making poor use of time
> during IETF f2f meetings by cramming the agenda with yet another
> interval when we don’t have a break is not going to solve the problem.

This is the only interesting aspect of this thread:  ignoring the
underlying problem, in favor of creating new ones.

d/

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 21 Jul 2015 13:55:44 +0000

My experience differs - the working groups I have attended so far this week all made good use of their allocated time (and, in some cases, could have used a bit more).

We have been talking about "more efficient use of time" as long as I've been attending IETF meetings, and the basics haven't changed much. Thus, in the sense of engineering practicality, there is a food trade-off: imposition of sub-optimal lunch for an activity that can consumed asynchronously (for many) or very long meeting days.

________________________________
From: Ted Lemon <[email-masked]>
Sent: Tuesday, July 21, 2015 9:36 AM
To: Henning Schulzrinne
Cc: Ole Jacobsen; [email-masked]; The IESG; [email-masked]
Subject: Re: [93attendees] [IAOC] Meeting schedule

On Jul 21, 2015, at 9:29 AM, Henning Schulzrinne <[email-masked]<mailto:[email-masked]>> wrote:
As long as the number of people with special food needs is smallish, this should be manageable, possibly at the cost of missing the first 15 minutes. This obviously works better in places like Prague, with plenty of take-out and grocery store options.

Impositions always seem small if you are not the one bearing them.   I would appreciate it if you could stop denying that the problem with your proposal that I have raised is a problem.   It may be that what I want is actually not important, but it's a real problem for me, even if it's not a problem for you.   Furthermore, solving the problem that we are making poor use of time during IETF f2f meetings by cramming the agenda with yet another interval when we don't have a break is not going to solve the problem.   Instead, it's going to result in more people skipping the plenary.

Why not instead solve the problem that we don't make good use of IETF meeting time?

---

From: Ole Jacobsen <[email-masked]>
Date: Tue, 21 Jul 2015 06:58:18 -0700 (PDT)

On Tue, 21 Jul 2015, Ted Lemon wrote:

> That is one of the non-merits of a lunchtime plenary.  It is one 
> that would literally cause me to skip a plenary, which I normally 
> consider very important to attend.  Check your privilege.  
> Seriously.  Not everybody has the same easy food experience you do 
> at IETF.

Oh, come on Ted, you're not being reasonable!

Henning used the word "sandwiches" and you immediately jumped to the 
conclusion that all hotel-made veggie ones are bad and for THAT reason 
this would kill the idea for you. Can you just for one minute try to 
think about some, any food option that you could combine with a 
plenary, something that could be implemented in a grab-an-go fashion?
Can we just for ONCE discuss a general idea and concept in the IETF 
without getting bogged down in engineering details? I realize that if
lunch involves wine, romantic music and and a 12-course tasting menu
it might be difficult to implement in combination with a plenary, but
I hope that isn't what we are talking about.

As for "privilege," I have no idea what you're talking about, but then
again English is only my second language.

:-(

Ole

---

From: Stephen Botzko <[email-masked]>
Date: Tue, 21 Jul 2015 16:02:51 +0200

The meetings I've been in also managed their use of time quite well.

I think the breaks are needed though.  Many times they are used for
important side-bars that get people on the same page.

Doing more presentations electronically (not during the meeting) would free
up more meeting time.  I think this could also be done with the admin
plenary.

On Tue, Jul 21, 2015 at 3:55 PM, Henning Schulzrinne <
[email-masked]> wrote:

>  My experience differs - the working groups I have attended so far this
> week all made good use of their allocated time (and, in some cases, could
> have used a bit more).
>
>
>  We have been talking about "more efficient use of time" as long as I've
> been attending IETF meetings, and the basics haven't changed much. Thus, in
> the sense of engineering practicality, there is a food trade-off:
> imposition of sub-optimal lunch for an activity that can consumed
> asynchronously (for many) or very long meeting days.
>
>  ------------------------------
> *From:* Ted Lemon <[email-masked]>
> *Sent:* Tuesday, July 21, 2015 9:36 AM
> *To:* Henning Schulzrinne
> *Cc:* Ole Jacobsen; [email-masked]; The IESG; [email-masked]
> *Subject:* Re: [93attendees] [IAOC] Meeting schedule
>
> As long as the number of people with special food needs is smallish, this
> should be manageable, possibly at the cost of missing the first 15 minutes.
> This obviously works better in places like Prague, with plenty of take-out
> and grocery store options.
>
>
> Impositions always seem small if you are not the one bearing them.   I
> would appreciate it if you could stop denying that the problem with your
> proposal that I have raised is a problem.   It may be that what I want is
> actually not important, but it’s a real problem for me, even if it’s not a
> problem for you.   Furthermore, solving the problem that we are making poor
> use of time during IETF f2f meetings by cramming the agenda with yet
> another interval when we don’t have a break is not going to solve the
> problem.   Instead, it’s going to result in more people skipping the
> plenary.
>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 21 Jul 2015 10:07:03 -0400

> My experience differs - the working groups I have attended so far this week all made good use of their allocated time (and, in some cases, could have used a bit more). 

Hm.   Of the working groups I have attended, I’d say at least half of the working group time was wasted on long presentations about work that participants should already be familiar with.   Many of the comments, probably 50%, at the microphone did not reflect any serious thought on the part of the commenter, and did not add useful insight to the discussion.   I have seen some good discussions, but these have been in the minority.   I see a lot of working groups with packed agendas where each draft gets ten minutes.   It’s impossible to have a constructive discussion about a draft that needs discussion in ten minutes.   Ten minutes is way too long for a sales pitch about a draft.

I sympathize with your skepticism, but I haven’t seen a lot of effort to change the status quo.  What I am suggesting is that if we seriously just say “look, the hours we have for meetings are limited to business hours, and you have to figure out how you’re going to best use your limited time,” and divide the time up evenly between requestors, maybe with exceptions if they can be clearly justified, we will stop providing incentives for working group chairs to just ask for as much time as they can and not try to make good use of the time they get.

The reason we haven’t seen this work is because we haven’t tried it.   We haven’t really tried anything.   The only discipline that chairs have experienced in the past is as a result of schedule congestion, and in general the IESG just throws themselves on the scheduling sword and makes it work based on chairs’ requests.   I am proposing that we stop doing that.

---

From: Ole Jacobsen <[email-masked]>
Date: Tue, 21 Jul 2015 07:07:45 -0700 (PDT)

On Tue, 21 Jul 2015, Ted Lemon wrote:

> Impositions always seem small if you are not the one bearing them.  
> I would appreciate it if you could stop denying that the problem 
> with your proposal that I have raised is a problem.  It may be that 
> what I want is actually not important, but it’s a real problem for 
> me, even if it’s not a problem for you.  Furthermore, solving the 
> problem that we are making poor use of time during IETF f2f meetings 
> by cramming the agenda with yet another interval when we don’t have 
> a break is not going to solve the problem.  Instead, it’s going to 
> result in more people skipping the plenary.
> 

And I would appreciate if you would stop implying that a specific 
detailed food option is or was implied by Henning's suggestion. Can we 
discuss the question: "Can we have lunch during the plenary?" instead, 
please?

As for making better use of meeting time, yes, I agree with you and
that is why I bounced the question to the wider audience beyond the
attendee list. And I also agree that having lunch during the plenary
may not be the best option, but I think it at least merits some 
discussion. We do, after all, regularly host similar events with the
lunchtime host speakers etc.

Ole 

PS

Just for the record: The hotel-prepared sandwiches here in Prague have 
been quite excellent, but that really is neither here nor there.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 21 Jul 2015 10:09:07 -0400

> plenary, something that could be implemented in a grab-an-go fashion?

No, Ole, for two reasons.   First, I actually have _years_ of experience with hotel sandwiches, and so I have a concrete basis for knowing that your optimism is unfounded.   I know for a fact based on personal experience that grab-and-go lunches do not work.

Second, because what Henning proposed is exactly the wrong thing to do, irrespective of the quality of the sandwiches.   We can’t make the week bigger, and we need to stop trying.

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 21 Jul 2015 16:14:26 +0200

Hi Brian,

>From my point of view, the goal of these presentations is to highlight
technical topics that we (on the IAB) think might be of interest to a
broad cross-section of the IETF community.  In my experience, we try
to pick issues that are likely to affect several different areas in
the IETF, that still have open work that relate to IETF protocols, and
that we think will have general appeal.  Admittedly, our judgement is
not always perfect; and some such presentations are more successful
than others.  But that is the goal.  We also have a principle that
such plenary presentations should be technically interesting or
entertaining, and ideally both.

Naturally, for some portion of the population we will sometimes fail
in this aim every time.  If you're another expert in the particular
field in question it's quite unlikely you'll learn anything in a
presentation aimed at a plenary audience (though even there, you might
learn something about how -- or how not -- to present the issues to
such an audience).

I hope that's useful.

Andrew (speaking for myself)

-- 
Andrew Sullivan
[email-masked]

---

From: Lixia Zhang <[email-masked]>
Date: Tue, 21 Jul 2015 07:15:43 -0700

> On Jul 20, 2015, at 3:16 PM, Randall Gellens <[email-masked]> wrote:
> 
> The meeting schedule, in my view, runs too late in the evening. Tonight's session ended at 7:50 PM, meaning it was 8:15 before one could even start trying to go to dinner.  This means it's 9:00 before one is able to eat, which in my view, is far too late.  I know people hated the old-old schedule that went until 10, but at least that had a dinner break at a 6:00, a reasonable hour; if we absolutely must go late, that was a better way to do it.  The schedule this time forces people to either try to sleep on a full stomach (which I can't do), skip dinner, or stay up way late and be sleep-deprived, fueled by caffeine and adrenaline (which I think makes for very bad meetings and bad technical work).

In the spirit of brainstorm, here is my 2 cents:

1/ if making the room arrangement is an issue, why dont we minimize this hassle by doing it once instead of twice?

i.e. running IAB and IESG plenary back-to-back.

2/ we can devote either one morning or one afternoon to it.
(I think morning would be better, so that there is lunch break to re-arrange the room; if afternoon, then there is still this issue of re-arrange the room quick so that we can have WG meetings after that).

3/ if morning but 2.5 hours looks a bit short: start at 8:30AM, and/or run to 12:00?
Given IETF covers breakfast one way or the other, this does not suffer from the food quality concerns as some people expressed regarding doing a plenary over lunch time.

Lixia

PS: haven't had time to read all the msgs on this thread, so forgive me if the idea is already mentioned.

---

From: Mary Barnes <[email-masked]>
Date: Tue, 21 Jul 2015 09:19:28 -0500

> lunchtime host speakers etc.
[MB] Based upon the current meeting schedules, we only have one slot left
whereby one could consider scheduling a plenary during lunch.  We already
have ISOC speakers on Tuesday, WG chairs on Wednesday and host lunch
speakers on Thursday.  And, Friday lunchtime is used by IESG/IAB to wrap-up
and ISOC to hold their meetings with members. So, it might be reasonable to
discuss the option of perhaps having the IAB tech topic during Monday's
lunch.  But, I don't think all aspects of IAB tech plenary or admin plenary
are well suited for a lunchtime session.  And, I don't think it's
necessarily fair to add the burden of arranging lunches for the masses to
the secretariat's responsibilities and the IETF budget, unless of course
folks want to exchange the $s that are allocated for cookies for sandwiches
on Mondays.  [/MB]

> been quite excellent, but that really is neither here nor there.

[MB] That may be, but you have no dietary restrictions and for those of us
that do, the options have not been good and in most cases Monday is our day
to do our reconnaissance to find something that does work.  It would be
really good if folks that don't have dietary restrictions not make
judgements on concerns raised by those that do. [/MB]

---

From: Randall Gellens <[email-masked]>
Date: Tue, 21 Jul 2015 07:16:16 -0700

At 12:54 PM +0000 7/21/15, Henning Schulzrinne wrote:

>  Another random scheduling idea: Schedule the plenaries during the 
> lunch slot, since processing sandwiches and slides in parallel is 
> known to work.

In my experience, this works for fairly small values of "works", but 
it depends on how much stock you put in people's ability to 
multi-task.

-------------- Randomly selected tag: ---------------
There are two ways of constructing a software design: One way
is to make is so simple that there are obviously no
deficiencies, and the other way is to make it so complicated
that there are no obvious deficiencies."     --C. A. R. Hoare

---

From: Randall Gellens <[email-masked]>
Date: Tue, 21 Jul 2015 07:27:08 -0700

>  i.e. running IAB and IESG plenary back-to-back.

We used to do this.  The plenary session used to run past midnight.

-------------- Randomly selected tag: ---------------
People must not attempt to impose their own 'truth' on others.  The
right to profess the truth must always be upheld, but not in a way
that involves contempt for those who may think differently.
                                              --John Paul II, 1/1/91

---

From: Ole Jacobsen <[email-masked]>
Date: Tue, 21 Jul 2015 07:45:53 -0700 (PDT)

On Tue, 21 Jul 2015, Mary Barnes wrote:

> [MB] That may be, but you have no dietary restrictions and for those 
> of us that do, the options have not been good and in most cases 
> Monday is our day to do our reconnaissance to find something that 
> does work.  It would be really good if folks that don't have dietary 
> restrictions not make judgements on concerns raised by those that 
> do. [/MB]

I get that there are folks with dietary restrictions, and I have not
(knowingly) made "....judgements on concerns raised by those that
do..." I was trying to steer the conversation in the direction of
"can we have lunch and a plenary at the same time?" and not derail
into a discussion of specific food options. The former is a question
about how we manage our time, can we multi-task, etc, etc. The latter
is an implementation detail in my view. It may well be that the food
issue is not solvable, but I think that's further down the road in
this discussion IMO.

I am sure there are MANY folks who would prefer NOT to have to sit
through presentations during lunch, want to get away from the venue,
meet with others in smaller groups, etc, etc, and those were the
kind of arguments I was expecting.

Ole

---

From: Vinayak Hegde <[email-masked]>
Date: Tue, 21 Jul 2015 20:42:55 +0530

> Another random scheduling idea: Schedule the plenaries during the lunch slot, since processing sandwiches and slides in parallel is known to work. To make this more efficient and to have the right…

This is a good idea. The only downside that I see is that eats into
time for side-meeting and corridor tracks which are important to get
work done. Some times these are the only alternative when there are
cashing schedules.

-- Vinayak

---

From: Lixia Zhang <[email-masked]>
Date: Tue, 21 Jul 2015 08:34:34 -0700

> On Jul 21, 2015, at 7:27 AM, Randall Gellens <[email-masked]> wrote:
> 

1/ that was then, this is now.  Might be worth reconsidering.

2/ doing it in the morning has one advantage over an evening meeting (which can drag forever): lunch time makes a hard stop.

---

From: Jari Arkko <[email-masked]>
Date: Wed, 22 Jul 2015 00:37:52 +0200

Thanks for an interesting discussion. FWIW, I think the IESG / IAOC are looking at these
discussions so maybe we can just have it on this list.

First, I wanted to highlight that this week’s schedule wrt the morning plenaries is an experiment.
The lunch break allows the room setup conversion to take place without disturbing our meeting
time.

We’ve discussed the plenaries in the IESG/IAB Sunday meeting, and are considering a joint,
shorter (¨2.5h) plenary for IETF-94. This would further compress the time that we use for
reporting, but should still allow a brief(er) technical topic to be discussed and some amount
of time for asking questions from the leadership boards. The saved time could be used
for working group meetings, breaks for those important side discussions or that important
rest. This is like we had it some years ago, but it would be an experiment to see how it
works in today’s IETF.

Thoughts?

Also, we are very acutely aware of the tradeoffs between adequate rest in an intense week,
time for the WGs to do their interesting work, time for the unofficial and unscheduled discussions
to happen, and the constraints on lengthening the week. We have always tried to balance
these, and feedback on where we are with that is very much appreciated.

Part of the reason that we have such an intense meeting this time is that there are
so many working groups and that people find interesting work to do. I think that’s
good. It is also a good thing that many of the most active WGs are using virtual
interim meetings to progress their work.

There are no magic solutions to offer more time; don’t think we can extend the week.
We’ll just have to do even more between meetings, use time even smarter in the
meetings, and use more parallelism.

Jari

---

From: Randall Gellens <[email-masked]>
Date: Wed, 22 Jul 2015 02:32:00 -0700

At 12:37 AM +0200 7/22/15, Jari Arkko wrote:

>  We've discussed the plenaries in the IESG/IAB Sunday meeting, and 
> are considering a joint,
>  shorter (s2.5h) plenary for IETF-94. This would further compress 
> the time that we use for
>  works in today's IETF.

I think it's worth a try.

>  these, and feedback on where we are with that is very much appreciated.

I wonder if it might be possible to try and tweak this by:

   - Having most slots be shorter (e.g., 60 minutes)
   - When WG chairs request slot(s), ask them to rate how critical f2f time is
     o f2f time vital for making progress on x drafts
     o f2f time useful for making progress in WG generally
     o f2f time potentially useful

When scheduling is done, give priority to "vital" WG slots (some 
groups might not get a slot).

-------------- Randomly selected tag: ---------------
[To have] butter on your head: Hungarian expression meaning guilty
of something.

---

From: Ted Lemon <[email-masked]>
Date: Wed, 22 Jul 2015 07:12:52 -0400

On Jul 22, 2015, at 5:32 AM, Randall Gellens <[email-masked]> wrote:
> When scheduling is done, give priority to "vital" WG slots (some groups might not get a slot).

This is a great suggestion.   In addition, I would suggest:

Having a single slot per day that’s for cross-area advertising, takes a half hour, is not area-specific, and is short.   You get two minutes for an elevator pitch, and it’s about a document that would be discussed somewhere that day.   Competition for slots would be based on the amount and level of actual work that has occurred on that document since the previous IETF, plus the AD’s and chairs’ impression of how important cross-area review is.   No Q&A, and if you run to the end of your slot, your microphone gets cut and the next presenter’s microphone gets turned on.   In some cases it might make sense for someone who is not a document author to do a talk on a document because they are concerned about some issue in the document and want to raise awareness about it.

This is probably not correct as proposed, but trying it as proposed would help us to understand what would be correct.

Another suggestion: keep some slots open, so that when a discussion in one of the short slots turns out to be productive, an additional slot can be forked later in the week to continue it.  A bit of a risk that people would skip the last day if we did this, but people who want to get work done might not.

---

From: joel jaeggli <[email-masked]>
Date: Wed, 22 Jul 2015 07:20:05 +0200

> How well have we done the last few meetings, including this one, at having full session times?  If we have fractional sessions, do we have any possibility of squeezing two groups into a single room?

sunset4/v6ops
pim/mboned
opsarea/opsawg

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 22 Jul 2015 12:48:58 +0000

In IETF 89 STRAW and AVTEXT got scheduled to meet in parallel in two different rooms (in a slot longer than either of us had requested), and we agreed with AD/secretariat to meet sequentially in the same room. There was no specific handover time (beyond an estimate on the agenda), the second group started a few minutes after the previous group finished.

Partly as a result of this, for IETF 90 they agreed to make more 1 hour slots available, although possible they could still go even further in this direction.

Keith

> -----Original Message-----
> From: 93attendees [mailto:[email-masked]] On 
> Behalf Of joel jaeggli
> Sent: 22 July 2015 06:20
> To: Jeff Haas; [email-masked]
> Cc: [email-masked]; Ole Jacobsen; The IESG; [email-masked]
> >> We should be looking for ways to reduce the number of 
> meeting hours, 
> >> not to increase them.
> > 
> > How well have we done the last few meetings, including this 
> one, at having full session times?  If we have fractional 
> sessions, do we have any possibility of squeezing two groups 
> into a single room?
> 
> sunset4/v6ops
> pim/mboned
> opsarea/opsawg
> 
> > -- Jeff
> > 
> > 
> 
> 
>