Subject: [93attendees] have an extra CPAP part?

From: Aaron Falk <[email-masked]>
Date: Sun, 19 Jul 2015 13:31:43 +0200

A part from my CPAP (for sleep apnea) fell off as I was packing and last
night was rather awful without it.  Seems unlikely but I wonder if anyone
is traveling with an extra part.  Looks like this
<https://www.respshop.com/images/RespShop-60560-ResMed-Swift-LT-4.jpg>.

--aaron

---

From: Aaron Falk <[email-masked]>
Date: Sun, 19 Jul 2015 16:37:22 +0200

Problem solved.  Many thanks to those who offered to help!