Subject: [98attendees] Nikon charger for loan?

From: Jari Arkko <[email-masked]>
Date: Tue, 28 Mar 2017 19:11:46 -0500

Anyone happen to have a charger for Nikon cameras
(EN-EL15 battery, used in D750, D7200, D7100, D7000,
D600, etc)? I’d love to be able to loan one for couple of
hours… managed to accidentally drain my battery.

Jari

---

From: Jari Arkko <[email-masked]>
Date: Tue, 28 Mar 2017 19:38:54 -0500

Thank you for the offers. I have found a charger for loan, much appreciated!

Jari