Subject: [98attendees] Jabberroom software without libpurple

From: Niels ten Oever <[email-masked]>
Date: Wed, 22 Mar 2017 12:01:02 +0100

Hi all,

With the remote code execution issues with libpurple [0], which has been plagued with issues for a while, what software would you recommend using for Jabberrooms? Adium (Mac) and Pidgin (Linux) relied on libpurple and Tor Messenger and CoyIM support XMPP, but not jabber rooms.

All suggestions would be very much appreciated.

Best,

Niels

[0] http://seclists.org/fulldisclosure/2017/Mar/57

PS mcabber might be a solution, but something with a bit of a GUI might be nice.

---

From: Alexandre PETRESCU <[email-masked]>
Date: Wed, 22 Mar 2017 12:28:15 +0100

I continue using Exodus.

Is it involving the purple library?

Alex

Le 22/03/2017 à 12:01, Niels ten Oever a écrit :
> Hi all,
>
> With the remote code execution issues with libpurple [0], which has 
> been plagued with issues for a while, what software would you 
> recommend using for Jabberrooms? Adium (Mac) and Pidgin (Linux) relied 
> on libpurple and Tor Messenger and CoyIM support XMPP, but not jabber 
> rooms.
>
> _______________________________________________
> 98attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/98attendees

---

From: Yoshiro YONEYA <[email-masked]>
Date: Wed, 22 Mar 2017 23:06:57 +0900

Hi,

I had been thinking the same question with you!

I used to use Psi, but it seems no longer maintained, so I'm going to use 
Mozilla Thunderbird at IETF98.

I tried to join [email-masked] a few minutes ago, and it worked 
fine.
https://www.ietf.org/jabber/logs/plenary/2017-03-22.html

Regards,

-- 
Yoshiro YONEYA <[email-masked]>

---

From: [email-masked]
Date: 23 Mar 2017 04:01:28 -0000

In article <[email-masked]> you write:
>Adium (Mac) and Pidgin (Linux) relied on libpurple and Tor Messenger and CoyIM support XMPP, but not jabber rooms.

I've been using Jitsi which is written in Java.  Works nicely on my
Mac, better in my opinion than Adium.  On Ubuntu I've set it up and it
seems about the same as on my Mac.

R's,
John

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 23 Mar 2017 08:34:14 +0000

The UI of both jitsi and thunderbird is not really great. Anyone know of other options?

Lars

---

From: Yoav Nir <[email-masked]>
Date: Thu, 23 Mar 2017 11:16:47 +0200

On the Mac at least, both the native Messages app and Psi work.  I know Psi is not being maintained, but it sill works, and it’s available on other platforms.

As for jitsi, I’m feeling really stupid now, because I couldn’t find how to join a group chat.

Yoav

> On 23 Mar 2017, at 10:34, Eggert, Lars <[email-masked]> wrote:
>

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 23 Mar 2017 13:07:59 +0100 (CET)

On Wed, 22 Mar 2017, Niels ten Oever wrote:

> With the remote code execution issues with libpurple [0], which has been 
> plagued with issues for a while, what software would you recommend using 
> for Jabberrooms? Adium (Mac) and Pidgin (Linux) relied on libpurple and 
> Tor Messenger and CoyIM support XMPP, but not jabber rooms.

I recommend using the remote participation tool (Meetecho) that is web 
based. The messagetext window to the left is the jabber room.

It works fine in recent versions of Firefox and Chrome for instance.

https://www.ietf.org/meeting/98/remote-participation.html

"Meetecho offers a synchronized view of the official Jabber room, the 
current slides being presented, a shared note taking editor, and an 
audio/video stream from the room. All sessions (including tutorials) will 
be supported by Meetecho at IETF 98."

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 23 Mar 2017 12:26:52 +0000

On 2017-3-23, at 10:16, Yoav Nir <[email-masked]> wrote:
> On the Mac at least, both the native Messages app and Psi work.

Doh. It never occurred to me to try Messages. Thanks!

Lars

---

From: Yoav Nir <[email-masked]>
Date: Thu, 23 Mar 2017 14:58:09 +0200

Me neither, but when I tested  Psi and joined a room someone was there to test Messages

Sent from my Windows 10 phone

From: Eggert, Lars
Sent: Thursday, March 23, 2017 14:27
To: Yoav Nir
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [98attendees] Jabberroom software without libpurple

Lars

---

From: "John R. Levine" <[email-masked]>
Date: 23 Mar 2017 09:47:53 -0400

> As for jitsi, I’m feeling really stupid now, because I couldn’t find how to join a group chat.

It's in the normal menu, File->Add chat room.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: "Matthew A. Miller" <[email-masked]>
Date: Thu, 23 Mar 2017 08:32:06 -0600

If you're ok with a minimal graphical client, Swift < https://swift.im >
might be for you.  I've used it on MacOS, and binaries available for
Windows and Ubuntu/Debian.

- m&m

Matthew A. Miller
< http://goo.gl/LM55L >

---

From: Yoav Nir <[email-masked]>
Date: Thu, 23 Mar 2017 17:04:35 +0200

> On 23 Mar 2017, at 15:47, John R. Levine <[email-masked]> wrote:
> 

Thanks. For some reason I missed it.  Is there a button for changing the chat room subject like there is in Psi?  ‘cause I’m missing that as well.

Yoav