Subject: RE: [AAA-WG]: Re: Response routing?

From: "Martin Julien (ECE)" <[email-masked]>
Date: Mon, 12 Feb 2001 17:52:15 +0100

I meant the Destination AVP would be used for routing the last HOP, when no Route-Record AVP is available, because no other proxies are required to route to the originating server.

However, adding a Route-Record AVP in the originating server of Request messages would simplify and make more consistent the routing scheme in proxies and I think would be much simpler to support, right?

Martin

> -----Original Message-----
> From: Martin Julien (ECE) [mailto:[email-masked]]
> Sent: Monday, February 12, 2001 5:43 PM
> To: 'Patrice Calhoun'; Martin Julien
> Cc: [email-masked]
> Subject: RE: [AAA-WG]: Re: Response routing?
> 
> 
> Thanks! That answers my question. 
> 
> However, do you think that we should leave a routing question 
> answered by an application specific implementation, like 
> yours in the first HOP proxy? Should it be specified in the 
> draft that a first HOP proxy should keep a state info so that 
> it can route back the response to the originator? Or possibly 
> the Destination AVP used as the Destination Host-Name or the 
> originator of the request? 
> 
> Only as a suggestion, would it be nice to have the Host-Name 
> AVP replaced by Orig-Host-Name AVP, and the Destination AVP 
> replaced by Dest-Host-Name AVP.
> 
> Martin
> 
> > -----Original Message-----
> > From: Patrice Calhoun [mailto:[email-masked]]
> > Sent: Monday, February 12, 2001 4:56 PM
> > To: Martin Julien
> > Cc: David Spence; [email-masked]; Patrice Calhoun
> > Subject: [AAA-WG]: Re: Response routing?
> > 
> > 
> > > Hi,
> > > 
> > > Tell me if I'm wrong, but I thought that routing responses from a 
> > > Diameter node was based on (as in -18 Base draft):
> > > 
> > > 1) If there are Route-Record AVPs in the request (Query) 
> > message, the 
> > > last Route-Record AVP is used as the first HOP destination 
> > of the reply. 
> > > So the Route-Record AVPs are used until the last proxy before the 
> > > originator of the request. However, from there, what AVP is 
> > used for 
> > > routing to the originator node?
> > 
> > What I do, is that the first hop inserts a Proxy-State AVP. In the
> > Proxy-State-Info AVP, I include the FQDN of the originator of 
> > the request.
> > Then I add my Record-Route AVP.
> > 
> > > 
> > > 2) If there is no Route-Record AVPs in the request, then 
> > the reply is 
> > > sent back to the originator of the request using the 
> > Host-Name AVP of 
> > > the request as the destination. However, this routing is 
> > done at the IP 
> > > level only, right?
> > Not using the Host-Name AVP. I insert the value of the 
> > Host-Name AVP in my
> > Proxy-State-Info AVP. I am not sure what you mean by IP level 
> > only, though.
> > This is all application level routing.
> > 
> > > The STA (in the -18 draft of the Base protocol) defines the 
> > > Routing-Realm AVP in its list of optional AVP in its 
> > message structure. 
> > > This is very confusing to me, since it suggests that 
> > replies might not 
> > > have to go through the same proxies. I guess responses 
> > should never use 
> > > the Routing-Realm AVP.
> > 
> > That is correct, and I need to fix that up. Thanks for 
> > pointing this error out
> > to me.
> > 
> > > 
> > > I thought that Proxy-State AVPs were not used for routing, 
> > or are they? 
> > > Are we suggesting that each proxy defines a Proxy-State AVP 
> > or keeps an 
> > > internal state so that it knows how to route back messages to the 
> > > originator?
> > 
> > A proxy can put pretty much whatever it wants in the 
> > Proxy-State AVP. Right
> > now, my code just adds the FQDN, but in the future I may need 
> > to also insert
> > additional data. The Proxy-State is not used for routing 
> > per-say, but if one
> > puts the information needed to route the message, then it could be.
> > 
> > However, the use of the Proxy-State is implementation specific.
> > 
> > > Can we really have a stateless proxy?, or is it a proxy 
> > that forwards a 
> > > Proxy-State AVP?
> > my proxy is currently stateless.
> > 
> > PatC
> > 
> > 
>

---

From: Patrice Calhoun <[email-masked]>
Date: Mon, 12 Feb 2001 08:58:59 -0800 (PST)

Correct, having ALL Diameter nodes add their Record-Route AVP would make for a
much more consistent scheme. Do people want/think that NASes and FAs should
add this, and require less special code on the first hop?

PatC
> I meant the Destination AVP would be used for routing the last HOP, when no
> Route-Record AVP is available, because no other proxies are required to
> route to the originating server.
> 
> However, adding a Route-Record AVP in the originating server of Request
> messages would simplify and make more consistent the routing scheme in
> proxies and I think would be much simpler to support, right?
> 
> Martin
>

---

From: David Spence <[email-masked]>
Date: Mon, 12 Feb 2001 13:23:52 -0500

That would be a good idea.

However, there is an issue with Route-Record(!) that I'm not sure has been
addressed in all this.  Route-Record works great within transactions for
routing responses and answers.  But it works less well for routing new
transactions that take place late in a session because the set of servers
that are up may have changed.  If they have changed, then there needs to be
AVPs within the message by which it can be routed if the Route-Record
routing fails.  And then, of course, the prohibition on further processing a
message if your server name does not appear in the last Route-Record AVP
would have to be removed.

-- 
David Spence                            email: [email-masked]
Interlink Networks, Inc.                phone: (734) 821-1203
775 Technology Drive, Suite 200         fax:   (734) 821-1235
Ann Arbor, MI 48108           
U.S.A.