Subject: RE: [AAA-WG]: Re: Response routing?

From: "Martin Julien (ECE)" <[email-masked]>
Date: Mon, 12 Feb 2001 17:42:57 +0100

Thanks! That answers my question. 

However, do you think that we should leave a routing question answered by an application specific implementation, like yours in the first HOP proxy? Should it be specified in the draft that a first HOP proxy should keep a state info so that it can route back the response to the originator? Or possibly the Destination AVP used as the Destination Host-Name or the originator of the request? 

Only as a suggestion, would it be nice to have the Host-Name AVP replaced by Orig-Host-Name AVP, and the Destination AVP replaced by Dest-Host-Name AVP.

Martin

> -----Original Message-----
> From: Patrice Calhoun [mailto:[email-masked]]
> Sent: Monday, February 12, 2001 4:56 PM
> To: Martin Julien
> Cc: David Spence; [email-masked]; Patrice Calhoun
> Subject: [AAA-WG]: Re: Response routing?
> 
> 
> > Hi,
> > 
> > Tell me if I'm wrong, but I thought that routing responses from a 
> > Diameter node was based on (as in -18 Base draft):
> > 
> > 1) If there are Route-Record AVPs in the request (Query) 
> message, the 
> > last Route-Record AVP is used as the first HOP destination 
> of the reply. 
> > So the Route-Record AVPs are used until the last proxy before the 
> > originator of the request. However, from there, what AVP is 
> used for 
> > routing to the originator node?
> 
> What I do, is that the first hop inserts a Proxy-State AVP. In the
> Proxy-State-Info AVP, I include the FQDN of the originator of 
> the request.
> Then I add my Record-Route AVP.
> 
> > 
> > 2) If there is no Route-Record AVPs in the request, then 
> the reply is 
> > sent back to the originator of the request using the 
> Host-Name AVP of 
> > the request as the destination. However, this routing is 
> done at the IP 
> > level only, right?
> Not using the Host-Name AVP. I insert the value of the 
> Host-Name AVP in my
> Proxy-State-Info AVP. I am not sure what you mean by IP level 
> only, though.
> This is all application level routing.
> 
> > The STA (in the -18 draft of the Base protocol) defines the 
> > Routing-Realm AVP in its list of optional AVP in its 
> message structure. 
> > This is very confusing to me, since it suggests that 
> replies might not 
> > have to go through the same proxies. I guess responses 
> should never use 
> > the Routing-Realm AVP.
> 
> That is correct, and I need to fix that up. Thanks for 
> pointing this error out
> to me.
> 
> > 
> > I thought that Proxy-State AVPs were not used for routing, 
> or are they? 
> > Are we suggesting that each proxy defines a Proxy-State AVP 
> or keeps an 
> > internal state so that it knows how to route back messages to the 
> > originator?
> 
> A proxy can put pretty much whatever it wants in the 
> Proxy-State AVP. Right
> now, my code just adds the FQDN, but in the future I may need 
> to also insert
> additional data. The Proxy-State is not used for routing 
> per-say, but if one
> puts the information needed to route the message, then it could be.
> 
> However, the use of the Proxy-State is implementation specific.
> 
> > Can we really have a stateless proxy?, or is it a proxy 
> that forwards a 
> > Proxy-State AVP?
> my proxy is currently stateless.
> 
> PatC
> 
>

---

From: Patrice Calhoun <[email-masked]>
Date: Mon, 12 Feb 2001 08:46:25 -0800 (PST)

> However, do you think that we should leave a routing question answered by an
> application specific implementation, like yours in the first HOP proxy?
> Should it be specified in the draft that a first HOP proxy should keep a
> state info so that it can route back the response to the originator? Or
> possibly the Destination AVP used as the Destination Host-Name or the
> originator of the request? 

Yes, the next version will have all of these procedures defined much clearer.

> Only as a suggestion, would it be nice to have the Host-Name AVP replaced by
> Orig-Host-Name AVP, and the Destination AVP replaced by Dest-Host-Name AVP.

What would these be used for?

PatC