Subject: [AAA-WG]: Session Termination, MAY or MUST?

From: "Martin Julien (ECE)" <[email-masked]>
Date: Wed, 28 Feb 2001 11:09:01 +0100

Hi,

From the draft-ietf-aaa-diameter-00.txt, I am wondering 
why the set of messages for Session Termination is not 
clearly a MUST in the specification. In fact, there are 
a whole bunch of MAY and SHOULD.

In section 3.6, there is a MAY, which means that 
compliance to the specification does not require 
support for Session Termination, right?

"The Diameter Base Protocol provides a set of messages 
that MAY be used by any peer to explicitly request that 
a previously authenticated and/or authorized session 
be terminated."

Furthermore, there is some confusion about what an STR
MUST or SHOULD be responsible for.

In section 2.0 (overview): (says MUST)

"Session state (associated with a Session-Id) MUST be 
freed upon receipt of the Session-Termination-Request, 
Session-Termination-Answer, expiration of authorized 
service time in the Session-Timeout AVP, and according 
to rules established in a particular extension/application 
of Diameter."

Which contradicts section 3.6.2: (says SHOULD)

"Upon receipt of the STR, the Diameter Server SHOULD 
release all resources for the session indicated by 
the Session-Id AVP. Any intermediate server in the 
Proxy-Chain MAY also release any resources, if necessary."

In fact, I think we have already mentioned on this ML, but
resources are released on the STA, not the STR. Well, upon
the sending or receipt of a STA is more generic, since it
includes proxy servers and NAS. I would like to have it
clarified.

In conclusion, I would prefer having a clear statement 
saying that the set of messages for Session Termination 
are a MUST.

Regards,
Martin

---

From: Pat Calhoun <[email-masked]>
Date: Wed, 28 Feb 2001 16:14:47 -0800 (PST)

All fixed in -01. Thanks for your comments.

PatC