Subject: [Ace] FW: New Version Notification for draft-somaraju-ace-multicast-00.txt

From: "Kumar, Sandeep" <[email-masked]>
Date: Tue, 7 Jul 2015 10:12:19 +0000

Dear all

We uploaded a new draft with details on the authorization flow within a professional Lighting systems (which is one of the use cases in the use case draft).

Can the chairs allocate time to discuss this at the Prague meeting.

Regards
Sandeep

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, July 06, 2015 8:31 PM
To: Abhinav Somaraju; Abhinav Somaraju; Sandeep S. Kumar; Hannes Tschofenig; Hannes Tschofenig; Sandeep S. Kumar
Subject: New Version Notification for draft-somaraju-ace-multicast-00.txt

A new version of I-D, draft-somaraju-ace-multicast-00.txt
has been successfully submitted by Abhinav Somaraju and posted to the IETF repository.

Name:           draft-somaraju-ace-multicast
Revision:       00
Title:          Multicast Security for the Lighting Domain
Document date:  2015-07-06
Group:          Individual Submission
Pages:          22
URL:            https://www.ietf.org/internet-drafts/draft-somaraju-ace-multicast-00.txt
Status:         https://datatracker.ietf.org/doc/draft-somaraju-ace-multicast/
Htmlized:       https://tools.ietf.org/html/draft-somaraju-ace-multicast-00

Abstract:
   Lighting systems have strict requirements on message latency and
   synchronization (typically latency less than 200 ms and jitter less
   than 50 ms).  There are several lighting use cases that require
   securing such communication between a (group of) senders and a group
   of receivers.  This draft describes initial ideas for authorization
   and key management required for the secure group communication within
   a lighting system.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: peter van der Stok <[email-masked]>
Date: Thu, 09 Jul 2015 09:02:05 +0200

Hi Authors,

I am pleased to see that solutions to provide multicast security are 
being pursued in this draft.
Let me encourage you to continue work on multicast security.

Below are some high-level remarks to improve the readability and purpose 
of the document (at least to me)

- Can the draft make more clear how it contributes to the meeting of the 
200 ms deadline. (point 3 of the introduction)
- There is a large section on access levels, but the concept is very 
little used in the text.
- It is only in section 4 that I see the concrete contributions of this 
draft: Key Distribution center, and Authorization server (are these 
indeed the topics of this draft?)
- The example section 6 provides a lot of information on the LWM2M 
model, which I find distracting from the actual subject.

Hope this helps.

Peter

Kumar, Sandeep schreef op 2015-07-07 12:12:
> Dear all
> 
> We uploaded a new draft with details on the authorization flow within
> a professional Lighting systems (which is one of the use cases in the
> use case draft).
> 
> To: Abhinav Somaraju; Abhinav Somaraju; Sandeep S. Kumar; Hannes
> Tschofenig; Hannes Tschofenig; Sandeep S. Kumar
> URL:
> https://www.ietf.org/internet-drafts/draft-somaraju-ace-multicast-00.txt
> Status:         
> https://datatracker.ietf.org/doc/draft-somaraju-ace-multicast/
> Htmlized:       
> https://tools.ietf.org/html/draft-somaraju-ace-multicast-00
> 
> 
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> The IETF Secretariat
> 
> 
> The information contained in this message may be confidential and
> legally protected under applicable law. The message is intended solely
> for the addressee(s). If you are not the intended recipient, you are
> hereby notified that any use, forwarding, dissemination, or
> reproduction of this message is strictly prohibited and may be
> unlawful. If you are not the intended recipient, please contact the
> sender by return e-mail and destroy all copies of the original
> message.
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 09 Jul 2015 09:42:19 +0200

Hi Peter,

thanks for your quick review.

> 200 ms deadline. (point 3 of the introduction)

The requirement for the low latency motivates the use of multicast
rather than using unicast to individually control luminaries.

> - There is a large section on access levels, but the concept is very

We tried to move the authorization related aspects into one section.
From a protocol point of view the impact is (by design) minimal and only
impacts the content of the access tokens.

> indeed the topics of this draft?)

Section 4 provides the architecture and in Section 5 we offer additional
detail the access token, which is core to the entire concept.

The proposed architecture separates the key distribution part from the
authorization part into two logical entities. We believe that this
separation makes sense since the authorization server may not be present
all the time, particularly not in small enterprise environments.

> model, which I find distracting from the actual subject.

In Section 6 we tried to provide an example exchange. We re-use the
information model of IPSO for the examples, which happens to re-use the
URI encoding of OMA LWM2M.

We thought it would make sense to reference some existing work rather
than inventing a new information and data model.

Ciao
Hannes