Subject: [Ace] CWT registry for claim keys

From: Samuel Erdtman <[email-masked]>
Date: Sun, 27 Mar 2016 12:53:26 +0200

Hi,
CWT (https://tools.ietf.org/html/draft-wahlstroem-ace-cbor-web-token-00)
does a great job of mapping JWT from JSON and JOSE to CBOR and COSE.

I´m currently working on an extension for the ACE framework and need to
define new JWT claims and there CWT key values.

Key values (labels in cose) are defined for the original JWT claims. I
think a section for under IANA considerations that requests a new IANA
registry for CWT key values is needed.

Then to a more philosophical question. Should CWT have its own claims
registry or should I always first request a new JWT claim and then request
the CWT CBOR key value.
IMHO CWT should not have its own claims registry. If possible one might
want to extend the JWT claims registration parameters (template) to also
have the option to register a CBOR key value.

Best regards
//Samuel

---

From: Anthony Nadalin <[email-masked]>
Date: Mon, 28 Mar 2016 18:13:34 +0000

I would agree that CWT should not have its own claim registry, use the JWT claims registry

From: Ace [mailto:[email-masked]] On Behalf Of Samuel Erdtman
Sent: Sunday, March 27, 2016 3:53 AM
To: [email-masked]; Mike Jones <[email-masked]>; Erik Wahlström <[email-masked]>
Subject: [Ace] CWT registry for claim keys

Hi,
CWT (https://tools.ietf.org/html/draft-wahlstroem-ace-cbor-web-token-00<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-wahlstroem-ace-cbor-web-token-00&data=01%7c01%7ctonynad%40microsoft.com%7c0cdd66b51fdb4737b42208d3562e0aa6%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=g6EAnofzTN0dmJ5jU3nngWBbFG4AGWBWM54kBij6Dag%3d>) does a great job of mapping JWT from JSON and JOSE to CBOR and COSE.

I´m currently working on an extension for the ACE framework and need to define new JWT claims and there CWT key values.

Key values (labels in cose) are defined for the original JWT claims. I think a section for under IANA considerations that requests a new IANA registry for CWT key values is needed.

Then to a more philosophical question. Should CWT have its own claims registry or should I always first request a new JWT claim and then request the CWT CBOR key value.
IMHO CWT should not have its own claims registry. If possible one might want to extend the JWT claims registration parameters (template) to also have the option to register a CBOR key value.

Best regards
//Samuel

---

From: John Bradley <[email-masked]>
Date: Mon, 28 Mar 2016 15:23:38 -0300

+1
> On Mar 28, 2016, at 3:13 PM, Anthony Nadalin <[email-masked]> wrote:
> 
>   <>
> CWT (https://tools.ietf.org/html/draft-wahlstroem-ace-cbor-web-token-00 <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-wahlstroem-ace-cbor-web-token-00&data=01%7c01%7ctonynad%40microsoft.com%7c0cdd66b51fdb4737b42208d3562e0aa6%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=g6EAnofzTN0dmJ5jU3nngWBbFG4AGWBWM54kBij6Dag%3d>) does a great job of mapping JWT from JSON and JOSE to CBOR and COSE.
>  
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace

---

From: Mike Jones <[email-masked]>
Date: Mon, 28 Mar 2016 19:04:01 +0000

+1

I'll work on appropriate edits with Erik.

-- Mike
________________________________
From: John Bradley<mailto:[email-masked]>
Sent: ‎3/‎28/‎2016 11:23 AM
To: Anthony Nadalin<mailto:[email-masked]>
Cc: Samuel Erdtman<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Mike Jones<mailto:[email-masked]>; Erik Wahlström<mailto:[email-masked]>
Subject: Re: [Ace] CWT registry for claim keys

+1
On Mar 28, 2016, at 3:13 PM, Anthony Nadalin <[email-masked]<mailto:[email-masked]>> wrote:

From: Ace [mailto:[email-masked]] On Behalf Of Samuel Erdtman
Sent: Sunday, March 27, 2016 3:53 AM
To: [email-masked]<mailto:[email-masked]>; Mike Jones <[email-masked]<mailto:[email-masked]>>; Erik Wahlström <[email-masked]<mailto:[email-masked]>>
Subject: [Ace] CWT registry for claim keys

Hi,

Best regards
//Samuel
_______________________________________________
Ace mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ace

---

From: William Denniss <[email-masked]>
Date: Mon, 28 Mar 2016 19:56:09 +0000

+1
On Mon, Mar 28, 2016 at 12:04 PM Mike Jones <[email-masked]>
wrote:

> ------------------------------
> From: John Bradley <[email-masked]>
> To: Anthony Nadalin <[email-masked]>
> Cc: Samuel Erdtman <[email-masked]>; [email-masked]; Mike Jones
> <[email-masked]>; Erik Wahlström <[email-masked]>
> *From:* Ace [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Samuel Erdtman
> *Sent:* Sunday, March 27, 2016 3:53 AM
> *To:* [email-masked]; Mike Jones <[email-masked]>; Erik
> Wahlström <[email-masked]>
> *Subject:* [Ace] CWT registry for claim keys
>
> Hi,
> CWT (https://tools.ietf.org/html/draft-wahlstroem-ace-cbor-web-token-00
> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-wahlstroem-ace-cbor-web-token-00&data=01%7c01%7ctonynad%40microsoft.com%7c0cdd66b51fdb4737b42208d3562e0aa6%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=g6EAnofzTN0dmJ5jU3nngWBbFG4AGWBWM54kBij6Dag%3d>)