Subject: [Ace] Call for adoption for draft-wahlstroem-ace-cbor-web-token-00

From: "Kepeng Li" <[email-masked]>
Date: Thu, 07 Apr 2016 09:34:47 +0800

To: ACE WG
Cc: OAuth and COSE WG

Hello all,

This note begins a Call For Adoption for
draft-wahlstroem-ace-cbor-web-token-00 [1]
to be adopted as an ACE working group item, and added in the charter.
The call ends on April 22, 2016.

Keep in mind that adoption of a document does not mean the document
as-is is ready for publication. It is merely acceptance of the
document as a starting point for what will be the final product
of the ACE working group. The working group is free to make changes to
the document according to the normal consensus process.

Please reply on this thread with expressions of support or opposition,
preferably with comments, regarding accepting this as a work item.

Note that this email was also copied to OAuth and COSE WG, in order to
get input from wider audience.

Thanks,

Kind Regards
Kepeng (ACE co-chair)

[1] https://datatracker.ietf.org/doc/draft-wahlstroem-ace-cbor-web-token/

---

From: Mike Jones <[email-masked]>
Date: Thu, 7 Apr 2016 02:59:00 +0000

+1 for adoption

From: Ace [mailto:[email-masked]] On Behalf Of Kepeng Li
Sent: Wednesday, April 6, 2016 10:35 PM
To: [email-masked]
Cc: Kathleen Moriarty <[email-masked]>; Hannes Tschofenig <[email-masked]>; [email-masked]; [email-masked]; Stephen Farrell <[email-masked]>
Subject: [Ace] Call for adoption for draft-wahlstroem-ace-cbor-web-token-00

To: ACE WG
Cc: OAuth and COSE WG

Hello all,

This note begins a Call For Adoption for draft-wahlstroem-ace-cbor-web-token-00 [1]
to be adopted as an ACE working group item, and added in the charter.
The call ends on April 22, 2016.

Thanks,

Kind Regards

Kepeng (ACE co-chair)

---

From: Samuel Erdtman <[email-masked]>
Date: Thu, 7 Apr 2016 06:47:46 +0200

+1 for adoption

Sent from my iPhone

> On 7 apr. 2016, at 03:34, Kepeng Li <[email-masked]> wrote:
> 
> To: ACE WG
> Cc: OAuth and COSE WG
> 
> Hello all,
> 
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace

---

From: Ludwig Seitz <[email-masked]>
Date: Thu, 7 Apr 2016 08:42:32 +0200

> The call ends on April 22, 2016.

+1 for adoption.

/Ludwig

Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: Shahid Raza <[email-masked]>
Date: Thu, 7 Apr 2016 11:12:02 +0200

+1 for adoption.

/Shahid

----------------------------------------------------------------------
Shahid Raza
PhD, Senior Researcher
Networked Embedded Systems group
SICS Swedish ICT, Stockholm, Sweden
Mobile. No. +46 768831797
Personal Web: http://www.shahidraza.info
Company Web: https://www.sics.se

Research Interests: IoT, Security, Sensor Networks
Associate Editor: IEEE Internet of Things Journal
----------------------------------------------------------------------

> On 07 Apr 2016, at 08:42, Ludwig Seitz <[email-masked]> wrote:
>

---

From: Erik Wahlström <[email-masked]>
Date: Sun, 10 Apr 2016 13:53:23 +0200

+1

---

From: Justin Richer <[email-masked]>
Date: Sun, 10 Apr 2016 08:50:53 -0400

+1 for adoption, but please remove the "web" from the name.

One of the main features of JSON Web Tokens, from which this is 
inspired, is that it can be passed without any additional encoding in 
HTTP headers, parameters, forms, strings, etc. It's built for the "web" 
from the ground up.

The same is not true of the COSE-based token format here. It's designed 
for CoAP and other embedded systems that can speak the CBOR encoding 
natively. You could argue that this is the "web" in a sense but I think 
that it's misleading to implementors to claim such.

Therefore I strongly encourage the authors and ACE WG to drop the "web" 
from the name, leaving simply the COSE Token.

  -- Justin

On 4/10/2016 7:53 AM, Erik Wahlström wrote:
> +1
>
> On Thu, Apr 7, 2016 at 6:47 AM, Samuel Erdtman <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     +1 for adoption
>
>     Sent from my iPhone
>
>     On 7 apr. 2016, at 03:34, Kepeng Li <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>>     To: ACE WG
>>     Cc: OAuth and COSE WG
>>
>>     Hello all,
>>     This note begins a Call For Adoption fordraft-wahlstroem-ace-cbor-web-token-00 [1]
>>     [1]
>>     https://datatracker.ietf.org/doc/draft-wahlstroem-ace-cbor-web-token/
>>
>>     [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose

---

From: Ludwig Seitz <[email-masked]>
Date: Mon, 11 Apr 2016 09:13:51 +0200

> from the name, leaving simply the COSE Token.

+1 for making it just CBOR Token

/Ludwig
-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se