Subject: [Ace] draft-ietf-ace-oauth-authz

From: Peter van der Stok <[email-masked]>
Date: Thu, 30 Apr 2020 08:57:14 +0200

Hi authz authors,,

While implementing a version of AS, I noticed that there is no resource
type (rt) registered for /.well-known/core discovery.
Is this voluntary?
If not, can it still be added?

thanks,

peter 
-- 
Peter van der Stok
vanderstok consultancy
mailto: [email-masked], [email-masked]
www: www.vanderstok.org [1]
tel NL: +31(0)492474673     F: +33(0)966015248 

Links:
------
[1] http://www.vanderstok.org

---

From: Jim Schaad <[email-masked]>
Date: Thu, 30 Apr 2020 08:25:49 -0700

What do you expect to see?   By default a client needs to know that something is an AS and have a key to interact with that AS.

Jim

From: Ace <[email-masked]> On Behalf Of Peter van der Stok
Sent: Wednesday, April 29, 2020 11:57 PM
To: Ace <[email-masked]>
Subject: [Ace] draft-ietf-ace-oauth-authz

Hi authz authors,,

While implementing a version of AS, I noticed that there is no resource type (rt) registered for /.well-known/core discovery.
Is this voluntary?
If not, can it still be added?

thanks,

peter 

-- 

Peter van der Stok
vanderstok consultancy
mailto: [email-masked] <mailto:[email-masked]> , [email-masked] <mailto:[email-masked]> 
www: www.vanderstok.org <http://www.vanderstok.org> 
tel NL: +31(0)492474673     F: +33(0)966015248

---

From: Peter van der Stok <[email-masked]>
Date: Fri, 01 May 2020 08:56:20 +0200

HI Jim,

I try to answer your question,

When I want to access an OCF device I can find its IP address through
service discovery (rfc7252 section 7) using an rt-value registered at
the IANA core parameters registry.
For example, when I want to initialize the AS I have to type in the IP
address of the AS.
>From that moment on keys and certificates can be compared to continue
initialization.

Using service discovery can automate that process.

My request is that authz draft registers an rt-value in core parameters
registry for service discovery of the AS,
unless a different process has already been established for AS
initialization.

Many thanks,

peter
Jim Schaad schreef op 2020-04-30 17:25:

> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace

Links:
------