Subject: [Ace] Framework Figure 12

From: Francesca Palombini <[email-masked]>
Date: Thu, 10 Sep 2020 08:38:16 +0000

Hi,

I noticed a mistake in the current document, that escaped the several rounds of review.

Figure 12 states that the ace_profile is supposed to have for value an unsigned integer. The ACE Profile registry in Section 8.8 implies that the profile can be both positive and negative integers.

Same, in Figure 12, the error is marked as to be an unsigned integer. The OAuth Error Code CBOR Mappings Registry (column CBOR value) in section 8.4 implies that the errors can be both positive and negative.

The token_type has the same problem, looking at the OAuth Access Token Type CBOR Mappings.

I don't know if I missed anything (I only took a look at Fig 12 but the same should be done for Fig 2 and Fig 16), but it might be worth for other people to take a look as well.
I am starting to think that adding a value to those figures with a reference to the registries of values where these apply might have helped, and might still help readers.

Thanks,
Francesca

---

From: Francesca Palombini <[email-masked]>
Date: Thu, 10 Sep 2020 08:49:20 +0000

And just to use the correct CBOR terminology, I indeed meant _unsigned and negative_ seems to be allowed rather than just unsigned.

Francesca

On 10/09/2020, 10:38, "Francesca Palombini" <[email-masked]> wrote:

    Hi,

    Thanks,
    Francesca