Subject: [Acme] ACME BoF in Dallas -- call for agenda items, issues, speakers

From: "Salz, Rich" <[email-masked]>
Date: Thu, 12 Feb 2015 18:57:53 +0000

Our BoF for the Dallas IETF next month was approved. The chairs are Ted Hardie (on cc) and myself. Remote access will be available via jabber and meetecho.
As Stephen said, this is a non-WG-forming BoF, but it's quite likely that the WG will form before we have a chance to hold another BoF.

This note is to solicit agenda topics, open issues, people who want to make a presentation, and so on.  We only have an hour, so presentations will likely be short and the bulk of the time will be open mic and capturing issues.

And if anyone is in an early mood to volunteer to take notes, I'll buy you a beverage after the BoF :)

--
Principal Security Engineer, Akamai Technologies
IM: [email-masked]<mailto:[email-masked]> Twitter: RichSalz

---

From: Richard Barnes <[email-masked]>
Date: Thu, 12 Feb 2015 11:08:31 -0800

I would be happy to give an overview of draft-barnes-acme-*, and some of
the design rationales for what's in there.

It would be good to have some input form other folks who have designed and
deployed cert automation stuff, e.g., CAs and hosting/server/CDN operators.

In terms of goals for the BoF, it wouldn't be unreasonable to try to get
some agreement around scope -- what certificate management are we trying to
automate, what's missing in existing RFCs, and what solutions have people
come up with already?

On Thu, Feb 12, 2015 at 10:57 AM, Salz, Rich <[email-masked]> wrote:

>  Our BoF for the Dallas IETF next month was approved. The chairs are Ted
> Hardie (on cc) and myself. Remote access will be available via jabber and
> meetecho.
>
>  As Stephen said, this is a non-WG-forming BoF, but it’s quite likely
> that the WG will form before we have a chance to hold another BoF.
>
>
>
> This note is to solicit agenda topics, open issues, people who want to
> make a presentation, and so on.  We only have an hour, so presentations
> will likely be short and the bulk of the time will be open mic and
> capturing issues.
>
>
>
> And if anyone is in an early mood to volunteer to take notes, I’ll buy you
> a beverage after the BoF J
>
>
>
> --
>
> IM: [email-masked] Twitter: RichSalz
>
>
>
> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>
>

---

From: Ted Hardie <[email-masked]>
Date: Thu, 12 Feb 2015 11:37:39 -0800

On Thu, Feb 12, 2015 at 11:08 AM, Richard Barnes <[email-masked]> wrote:

> ​Hi Richard,

The BoF description is here:

"Discussion of work that is going on with automated certificate management.
Let's Encrypt will obviously be a primary discussion point, but we hope to
have other CAs and other stakeholders represented."

The Let's Encrypt goal is given as "The entire enrollment process for
certificates occurs painlessly during the server’s native installation or
configuration process, while renewal occurs automatically in the
background."​, so one bound to the scope is there.   Other potential work
on the topic can certainly brought forward, and I think one reason for
approving the BoF is to get the gap analysis discussed.

That said, we only have one hour, so if folks can identify missing elements
and discuss them on the list, we may be able to make some progress before
the BoF itself.

regards,

Ted

>> And if anyone is in an early mood to volunteer to take notes, I’ll buy
>> you a beverage after the BoF J
>>
>>
>>
>> --
>>