Subject: [Acme] Sharing authorization objects among multiple order objects

From: "Zhang, Ning" <[email-masked]>
Date: Sat, 14 Apr 2018 00:00:33 +0000

Does the sharing is allowed, at least for authorization objects in “pending” or “valid” status? Or does it need to be decided by the server policy?

If pre-authorization is supported, the ACME server will certainly need to check existing authorization objects, at least for the ones in “valid” status, when an order is to be created.

Thanks,
-Ning

---

From: Daniel McCarney <[email-masked]>
Date: Mon, 16 Apr 2018 09:11:20 -0400

This is up to server policy. As one concrete example Let's Encrypt's ACME
V2 server will reuse an existing pending or valid authorization for an
identifier if the same account submits additional newOrder requests
including that identifier. (The fine print also requires the authorization
be unexpired and imposes a minimum remaining authorization lifetime to
prevent reusing an authorization that expires in 10m).

- Daniel / cpu

On Fri, Apr 13, 2018 at 8:00 PM, Zhang, Ning <[email-masked]>
wrote:

> Does the sharing is allowed, at least for authorization objects in
> “pending” or “valid” status? Or does it need to be decided by the server
> policy?
>
>
>
> If pre-authorization is supported, the ACME server will certainly need to
> check existing authorization objects, at least for the ones in “valid”
> status, when an order is to be created.
>
>
>
> Thanks,
>
> -Ning
>
>
>
> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>
>