Subject: [Acme] Comments on ACME draft

From: Tim Hollebeek <[email-masked]>
Date: Wed, 11 Apr 2018 20:41:20 +0000

I think the draft is in very good shape.

Unfortunately I didn't have as much time to go through it as I would have
liked, but I did find two things that are probably worth fixing:

1. "ACME clients SHOULD send a User-Agent header"

I think there's no value in omitting it, so it should be changed to a MUST.

2. Using the same key pair for both the account key pair and the certificate
key pair is a really bad idea.

This should either be mentioned in the Operational Considerations, or banned
outright.

-Tim

---

From: Richard Barnes <[email-masked]>
Date: Wed, 11 Apr 2018 16:56:45 -0400

Here's a quick PR implementing Tim's proposed changes.

https://github.com/ietf-wg-acme/acme/pull/420

Personally, these seem fine to me.  I would be in favor of merging the PR.

On Wed, Apr 11, 2018 at 4:41 PM, Tim Hollebeek <[email-masked]>
wrote:

> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>
>

---

From: Jacob Hoffman-Andrews <[email-masked]>
Date: Wed, 11 Apr 2018 15:04:18 -0700

I agree, these seem worth merging.

On 04/11/2018 01:56 PM, Richard Barnes wrote:
> On Wed, Apr 11, 2018 at 4:41 PM, Tim Hollebeek
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/acme>
>
>
>
>

---

From: Daniel McCarney <[email-masked]>
Date: Thu, 12 Apr 2018 11:00:02 -0400

I think #420 is a good addition and is worth merging once Martin Thomson's
review feedback is addressed.

Thanks Richard, Tim.

On Wed, Apr 11, 2018 at 6:04 PM, Jacob Hoffman-Andrews <[email-masked]> wrote:

> On Wed, Apr 11, 2018 at 4:41 PM, Tim Hollebeek <[email-masked]
> > wrote:
>
>>
> Acme mailing [email-masked]://www.ietf.org/mailman/listinfo/acme
>
>
>