Subject: [Acme] ACME Operational best practices

From: Tobias Fiebig <[email-masked]>
Date: Sat, 14 Jul 2018 23:38:10 +0000

Hi all,

During the last couple of months, several papers and posts on attacking current domain validation techniques and practices were published. While some could be mitigated by DNSSEC and CAA validation, there are also several operational techniques that could be implemented to increase CA's security posture (https-validation for pre-issued certificates [0], multi-vantage-point validation [1], etc.). IIRC, Let's Encrypt is already experimenting with multi-vantage-point validation.

Back when we submitted Cloud Strife [0] to NDSS, we reached out to the list on pushing our mitigations toward a recommendation/best practices RFC. Given that with the Birge-Lee paper, there is now a second attack vector, we (Kevin Borgolte and I, but we are open to more collaborators and already talked with Prateek Mittal from the BGP MitM paper [1]) would like to author a RFC on mitigating IP-use-after-free/IP-misuse attacks. This RFC would summarize the operational recommendations as well as how various other measures can (and cannot, CAA for example has to be configured correctly to be helpful) mitigate these attacks.

However, before we dive into writing, we would like to get your feedback, hear your opinions and concerns, discuss on the list and in person (Kevin and I are in Montreal this week), and feel out whether you think that this is useful to the community to pursue. We are looking forward to your feedback and interesting discussions.

Best,
Tobias

[0] Borgolte, Kevin, et al. "Cloud Strife: Mitigating the Security Risks of Domain-validated Certificates." Proceedings of Internet Society Symposium on Network and Distributed System Security (NDSS). 2018.

[1] Birge-Lee, Henry, et al. "Bamboozling Certificate Authorities with BGP." 27th USENIX Security Symposium (USENIX Security 18). USENIX Association.

Met vriendelijke groet,
 
Dr.-Ing. Tobias Fiebig,
Assistant Professor / Universitair Docent
Department Engineering Systems and Services

Informatie- en Communicatie Technologie (ICT)
 
TU Delft / Dept. ESS
Faculty of Technology, Policy and Management (TBM)
Building 31
Jaffalaan 5 - room B3.170
2628 BX  Delft
P.O.Box 5015
2600 GA Delft, The Netherlands
T +31 (0)15 27 85700
E  [email-masked]

Present: Monday t/m Friday

---

From: Jacob Hoffman-Andrews <[email-masked]>
Date: Tue, 17 Jul 2018 15:24:29 -0700

> Back when we submitted Cloud Strife [0] to NDSS, we reached out to the list on pushing our mitigations toward a recommendation/best practices RFC. Given that with the Birge-Lee paper, there is now…
The main question here is opt-in vs not. Practical deployment experience 
with ACME has shown that people frequently lose all their private keys. 
For instance, they might need to rebuild a server, and forget to store a 
copy. If a mechanism like you propose were to be enabled by default for 
all hostnames, it would effectively lock out a large number of 
subscribers from being able to get a certificate at all.

Making this opt-in is more plausible. You could do this with 
CAA.However, it might make more sense to just apply a CAA accounturi 
parameter in that case.