Subject: [Add] New WG or new Area

From: Bret Jordan <[email-masked]>
Date: Wed, 7 Aug 2019 21:32:38 -0600

I would like to see either a consolidated WG for all DNS related work, or a new Area just for for DNS. 

Further I would move that Glenn and Barbara either by chairs of this new working group or the ADs. 

Bret 

Sent from my Commodore 128D

PGP Fingerprint: 63B4 FC53 680A 6B7D 1447  F2C0 74F8 ACAE 7415 0050

---

From: Joe Abley <[email-masked]>
Date: Thu, 8 Aug 2019 00:36:16 -0400

Hi Bret,

> I would like to see either a consolidated WG for all DNS related work, or a new Area just for for DNS. 

Can you explain why?

Joe

---

From: Bret Jordan <[email-masked]>
Date: Thu, 8 Aug 2019 09:39:17 -0600

There is a lot of moving parts in and around DNS, from the protocol design side to the operational side.  DNS is a critical aspect that really demands more focus and attention in the IETF.  I believe having its own area would encourage better communication and dialog between the various groups and various users. It would also get us out of the “we design things over here” and we leave it up to the “other side” to deal with operational aspects. We need people talking and working together. We need everyone to understand both sides of the problems. 

I think it is also critical that the leaders (chairs or ADs) be individuals that are operators, this is why I think people like Glenn and Barbara would be brilliant for this work. 

Thanks,
Bret
PGP Fingerprint: 63B4 FC53 680A 6B7D 1447  F2C0 74F8 ACAE 7415 0050
"Without cryptography vihv vivc ce xhrnrw, however, the only thing that can not be unscrambled is an egg."

> On Aug 7, 2019, at 10:36 PM, Joe Abley <[email-masked]> wrote:
> 
> Hi Bret,
>

---

From: Joe Abley <[email-masked]>
Date: Thu, 8 Aug 2019 12:31:56 -0400

Hi Bret,

> I think it is also critical that the leaders (chairs or ADs) be individuals that are operators, this is why I think people like Glenn and Barbara would be brilliant for this work.

There's a very active DNS community at the IETF. We never have a problem filling rooms, often in multiple sessions per working group. The mailing lists are active, the community is engaged and diverse, there's a long history of substantive progress and the leadership (working group chairs and ADs) is strong and effective. If I was going to point a constructive, critical finger at any part of the IETF and suggest that improvements could be made, I don't think the DNS is where I would start.

However, you seem to be suggesting that all of this is insufficient, and that more is needed. I encourage you to explain that in more detail. I would certainly hope that any proposal for change acknowledged the effectiveness of what we already had and took care to preserve and build on it rather than simply shuffling the org chart and crossing fingers, or adding additional layers of management for the sake of it.

If your conclusion is based on the difficulties evident on this mailing list to come to consensus, remember that this is a topic which almost by definition is filled with tension between different interests. Nobody needs privacy unless there's surveillance or control. Nobody cares if privacy exists unless they have a reason to circumvent it. We have seen conflict and communications problems before; we will see more in the future. Welcome to the IETF.

If there's any reasonable conclusion from this group it's to acknowledge the existence of the different communities of interest, explain why their individual hopes and dreams are reasonable and self-consistent, and point out that they are never going to agree. The technical work to follow is mitigating the conflict between the groups, not imagining that there is some grand unified solution to what is at its essence an intractable problem.

Joe