Subject: [Add] IETF 105 Highlights

From: <[email-masked]>
Date: Tue, 6 Aug 2019 15:40:31 +0000

As you'll have seen from 105-attendees, Alissa has posted https://www.ietf.org/blog/ietf-105-highlights/
which I'll repeat here as it includes this statement on the outcome of the BoF:

The ADD BoF sought to identify areas where the IETF community might be interested in working on protocol standardization or best practices related to applications doing their own DNS resolution. The wide-ranging discussion touched on a few such nascent areas, including DNS-over-HTTPS (DoH) server discovery, means of advertising DNS resolver properties, and operational best practices. The most conclusive outcome, though, was a collective realization that it may be time to reorganize DNS-related work in the IETF to ensure that broad-based participation, cross-area review, and sufficient agenda and chair time can be dedicated to what is obviously a pressing set of topics for the industry. Discussions continue on the mailing list.

Chris

---

From: Bret Jordan <[email-masked]>
Date: Tue, 6 Aug 2019 22:33:48 -0600

I think that sums things up pretty well.

Bret 

Sent from my Commodore 64

PGP Fingerprint: 63B4 FC53 680A 6B7D 1447  F2C0 74F8 ACAE 7415 0050

> On Aug 6, 2019, at 9:40 AM, <[email-masked]> <[email-masked]> wrote:
> 
> As you’ll have seen from 105-attendees, Alissa has posted https://www.ietf.org/blog/ietf-105-highlights/
> which I’ll repeat here as it includes this statement on the outcome of the BoF:
>  
> -- 
> Add mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/add

---

From: Suzanne Woolf <[email-masked]>
Date: Thu, 8 Aug 2019 12:00:59 -0400

Hi,

This reminded me of a comment at the mic in ADD about DNSOP taking on some of the work that was being discussed in the BOF. The mic line was closed but it’s worth addressing that point, given this comment from Alissa:

> On Aug 6, 2019, at 11:40 AM, <[email-masked]> <[email-masked]> wrote:
> 
> As you’ll have seen from 105-attendees, Alissa has posted https://www.ietf.org/blog/ietf-105-highlights/ <https://www.ietf.org/blog/ietf-105-highlights/>

From my personal perspective as DNSOP co-chair (not speaking for my co-chairs or the WG by any means, but based on familiarity with what we do and what seems to work well):

For some years now the DNS work in the IETF has been organized roughly along the lines that DNSOP handles documents that are intended to address operational matters and are of primary interest to DNS implementers and operators, while substantive new protocol is done in dedicated WGs. (The DNSEXT WG was closed because there didn’t seem to be a lot of protocol work to do at the time; the assumption was that new WGs would be chartered to deal with specific new work, which is more or less what happened.)

DNSOP includes operators, implementers, and protocol designers, but the work is generally driven by the need for improvements to operational practice in meeting established requirements rather than new protocol for really novel needs. We try to be a good place for protocol developers in other areas to get review, and if there’s a large enough chunk of clearly separate work to do, we help spin up a new WG.

Our charter limits us as far as protocol work, and that has seemed reasonable: substantially new protocol, which tends to require focused effort and significant cross-area participation, gets its own WGs.

The dividing line between operations and protocol is a little bit tricky, especially in the case of operators trying to document the use of a new RRtype or agree on an interoperable way to use an EDNS option, and our current charter is deliberately somewhat loose, so we rely on our AD to keep us out of the weeds.

In my personal view, a couple of the documents discussed in the ADD BoF could reasonably be discussed and eventually published through DNSOP. But there’s also work that requires substantial expertise from other areas, particularly TSV and ART, and experience suggests that for documents requiring a lot of cross-area review, it’s easier for people to contribute to them in a dedicated WG, without distraction from other activities in DNSOP.

Best,
Suzanne