Subject: [Add] IETF108 ADD Agenda

From: "Deen, Glenn" <[email-masked]>
Date: Mon, 20 Jul 2020 23:08:01 +0000

Hi ADD,

The agenda for ADD @ IETF108 has now been posted.  (https://datatracker.ietf.org/meeting/108/session/add)

The ADD Agenda for IETF108 has only 90 minutes and is very full.  It’s great that there is lots of activity and interest, but all the interest and activity meant that not every request for a time slot could be met.      We are sorry if your request isn’t on the agenda space - the chairs do hope to accommodate the additional documents at a future interim meeting.

With so much activity the chairs feel that ADD that needs an interim meeting soon after IETF108 and propose holding it in September.    Please visit the September ADD Interim Doodle Poll at: https://doodle.com/poll/zyppxqte8pcwex3p

Regards,
Glenn Deen & David Lawrence – your friendly ADD chairs.

--

ADD Agenda for IETF108
======================
---

5min   Welcome to ADD WG    [Chairs ]
Please visit the **[September Interim Poll](https://doodle.com/poll/zyppxqte8pcwex3p)** Doodle. (Already open for responses)

Agenda Bash [Chairs]
---
Discovery Topics
#1 - 10min  DNS Resolver Discovery Protocol (DRDP) [Daniel Migualt]
Draft: **[draft-mglt-add-drdp-02](https://datatracker.ietf.org/doc/draft-mglt-add-rdp)**

#2 - 10min  Adaptive DNS Resolver Discovery [Tommy Pauly]
Draft: **[draft-pauly-add-resolver-discovery-01](https://datatracker.ietf.org/doc/draft-pauly-add-resolver-discovery/)**

#3 - 10min  DoH Preference Hints for HTTP [Nick Sullivan]
Draft: **[draft-schinazi-httpbis-doh-preference-hints-02](https://datatracker.ietf.org/doc/draft-schinazi-httpbis-doh-preference-hints/)**

#4 - 10min  A Bootstrapping Procedure to Discover and Authenticate DoT/DoH servers   for IoT and BYOD Devices [Dan Wing]
Draft: **[draft-reddy-add-iot-byod-bootstrap-00](https://datatracker.ietf.org/doc/draft-reddy-add-iot-byod-bootstrap/)**

---
# Resolver Information Topics

#5 - 10min  DNS Server Selection: DNS Server Information with Assertion Token [Tirumaleswar Reddy]
Draft: **[draft-reddy-add-server-policy-selection-03](https://datatracker.ietf.org/doc/draft-reddy-add-server-policy-selection/)**

# Deployments, Considerations and Observations

---

#6 - 10min  Encrypted DNS Discovery and Deployment Considerations for Home Networks [Mohamed Boucadair]
Draft: **[draft-btw-add-home-06](https://datatracker.ietf.org/doc/draft-btw-add-home/)**

#7 -  5min   Practical Observations from Encrypted DNS Deployments by Network Operators [Andrew Campling]
Draft: **[draft-campling-operator-observations-00](https://datatracker.ietf.org/doc/draft-campling-operator-observations/)**

#8 - 10min  A Proposal for a DoH Discovery Trial [Neil Cook]
Draft: **[draft-cook-doh-discovery-trial-00](https://datatracker.ietf.org/doc/draft-cook-doh-discovery-trial/)**

Documents Not on IETF108 Agenda but relevant to WG
===================================================

Deployment Considerations for Enterprise Networks
draft-reddy-add-enterprise-00 [Tirumaleswar Reddy]
https://datatracker.ietf.org/doc/draft-reddy-add-enterprise/

Adaptive DNS Discovery Threats [Glenn Deen]
draft-deen-add-threats-00
https://datatracker.ietf.org/doc/draft-deen-add-threats/

Upgrading Communication from Stub Resolvers to DoT or DoH
draft-pp-add-stub-upgrade-02 [Paul Hoffman]
https://datatracker.ietf.org/doc/draft-pp-add-stub-upgrade/

DNS Resolver Information Self-publication
draft-pp-add-resinfo-02.txt [Paul Hoffman]
https://datatracker.ietf.org/doc/draft-pp-add-resinfo/

DoH and DoT Protocol
=================

Supporting Redirect Responses in DNS Queries over HTTPS (DoH)
draft-btw-add-rfc8484-clarification-02 [Neil Cook]
https://datatracker.ietf.org/doc/html/draft-btw-add-rfc8484-clarification/

### IKEv2 Configuration for Encrypted DNS
draft-btw-add-ipsecme-ike-00  [Valery Smyslov]
https://datatracker.ietf.org/doc/draft-btw-add-ipsecme-ike/

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 21 Jul 2020 09:45:58 +0200

On Mon, Jul 20, 2020 at 11:08:01PM +0000,
 Deen, Glenn <[email-masked]> wrote 
 a message of 71 lines which said:

> The agenda for ADD @ IETF108 has now been posted.
> (https://datatracker.ietf.org/meeting/108/session/add)

Typo: the draft for DRDP is draft-mglt-add-rdp, not
draft-mglt-add-drdp.

---

From: "Chris Box (BT)" <[email-masked]>
Date: Tue, 21 Jul 2020 18:46:25 +0100

In a similar vein, draft-btw-add-home-06 should now be -07.

The agenda looks like a high-speed tour of the drafts, which is probably
necessary, but it's unfortunate there are only 90 minutes to play with. I
imagine the time available for questions on each draft will be only a
minute or two.

When do the chairs expect discussion to take place on selecting a coherent
set of drafts to move forward with? Will this be on the list afterwards, or
is this planned for the interim meeting? I'm hoping we don't need to wait
until September for that.

Thanks,
Chris

On Tue, 21 Jul 2020 at 08:46, Stephane Bortzmeyer <[email-masked]> wrote:

> Add mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/add
>

---

From: Michael Richardson <[email-masked]>
Date: Tue, 21 Jul 2020 16:29:24 -0400

> until September for that.

It seems to me that presenting authors could adjust their slide time/content
to assume people have read the documents, and to focus on how the proposal
fits into the charter, and into other documents.

I care, when adopting a document, that it has a good problem statement/focus,
and that much less about exactly if the details are fleshed out.

I look forward to many iterations of "Hum now if you have read the document
and have strong technical objections to document X", rather than "do you like
document X"

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Chris Box (BT)" <[email-masked]>
Date: Wed, 22 Jul 2020 13:54:17 +0100

Michael,

I agree it would speed things up to take that approach, but going by
Glenn's previous reply I think he's expecting the serious review to take
place both on the list, and in the September interim.

Chris

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Wed, 22 Jul 2020 14:46:26 +0000

Hi Michael

On 7/21/20, 1:30 PM, "Add on behalf of Michael Richardson" <[email-masked] on behalf of [email-masked]> wrote:

This is very close to what has been told to the presenters at IETF108.  Assume people have read, present your changes not your entire document and if you are a new -00 document - present the important highlights.  

The agenda for 108 is very tight but hopefully focusing on highlights and updates will permit some, albeit limited,  comments during the session.   The September session will be longer which should permit more extensive discussion.

-glenn

---

From: Paul Vixie <[email-masked]>
Date: Wed, 22 Jul 2020 20:22:02 +0000

On Wednesday, 22 July 2020 12:54:17 UTC Chris Box (BT) wrote:
> ... going by

jfyi, i lack the will to either pay a fee (neither my family nor my employer 
has an interest in this topic) or request a fee waiver (i could afford to pay 
but i'm merely a concerned internet citizen) to attend a virtual IETF meeting, 
so i'll see you all on this mailing list, and at the interrim.

-- 
Paul