Subject: [Add] I-D Action: draft-ietf-add-ddr-02.txt

From: [email-masked]
Date: Thu, 08 Jul 2021 19:43:18 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Adaptive DNS Discovery WG of the IETF.

        Title           : Discovery of Designated Resolvers
        Authors         : Tommy Pauly
                          Eric Kinnear
                          Christopher A. Wood
                          Patrick McManus
                          Tommy Jensen
	Filename        : draft-ietf-add-ddr-02.txt
	Pages           : 12
	Date            : 2021-07-08

Abstract:
   This document defines Discovery of Designated Resolvers (DDR), a
   mechanism for DNS clients to use DNS records to discover a resolver's
   encrypted DNS configuration.  This mechanism can be used to move from
   unencrypted DNS to encrypted DNS when only the IP address of a
   resolver is known.  It can also be used to discover support for
   encrypted DNS protocols when the name of an encrypted resolver is
   known.  This mechanism is designed to be limited to cases where
   unencrypted resolvers and their designated resolvers are operated by
   the same entity or cooperating entities.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-add-ddr/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-add-ddr-02.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-add-ddr-02

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Tommy Jensen <[email-masked]>
Date: Fri, 9 Jul 2021 03:02:37 +0000

Hey everyone,

We have posted a -02 for DDR ahead of IETF 111 in response to feedback and potential implementation issues: https://datatracker.ietf.org/doc/draft-ietf-add-ddr/

1) There are some minor changes to verbiage in the introduction following some questions on list and GitHub (thank you Sanjay and Daniel).

2) We added some guidance referencing RFC8484 regarding name resolution deadlock during the TLS handshake. This is to ensure DDR compliant resolvers do not require clients to rely on additional unencrypted name resolutions.

3) We added some examples that demonstrate looking up the designated resolver via the SUDN. Not having them from the beginning was an oversight that made following the document somewhat confusing. The "." name informs SVCB clients to use the target name, which for SUDN queries would have client trying to build a DoH template using the SUDN.

Feedback and continued discussion are welcome and encouraged. Specifically, there is some discussion ongoing right now regarding the usefulness of the option to use a designation for a resolver on the same IP address without further validation. Please weigh in if you have not already.

Thanks,
Tommy

> -----Original Message-----
> From: Add <[email-masked]> On Behalf Of [email-masked]
> Sent: Thursday, July 8, 2021 7:43 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [EXTERNAL] [Add] I-D Action: draft-ietf-add-ddr-02.txt
> 
> 
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatra
> cker.ietf.org%2Fdoc%2Fdraft-ietf-add-
> ddr%2F&amp;data=04%7C01%7CJensen.Thomas%40microsoft.com%7C86713b
> 349e6a486843fc08d9428355a8%7C72f988bf86f141af91ab2d7cd011db47%7C
> 1%7C0%7C637613954176533718%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiM
> C4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&
> amp;sdata=GtuZ%2FmYVOieVHedi8nWoOHhbgpzxiH6O3KKa0vXR8OY%3D&am
> p;reserved=0
> 
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ie
> tf.org%2Farchive%2Fid%2Fdraft-ietf-add-ddr-
> 02.html&amp;data=04%7C01%7CJensen.Thomas%40microsoft.com%7C86713
> b349e6a486843fc08d9428355a8%7C72f988bf86f141af91ab2d7cd011db47%7
> C1%7C0%7C637613954176543713%7CUnknown%7CTWFpbGZsb3d8eyJWIjoi
> MC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000
> &amp;sdata=xk0zpsKtxktZBfWZBX838le%2FujIEpWwV9bpZPdRaLVM%3D&am
> p;reserved=0
> 
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ie
> tf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-add-ddr-
> 02&amp;data=04%7C01%7CJensen.Thomas%40microsoft.com%7C86713b349e
> 6a486843fc08d9428355a8%7C72f988bf86f141af91ab2d7cd011db47%7C1%7
> C0%7C637613954176543713%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4w
> LjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp
> ;sdata=gNIk29P6kcyZkSacXKTcaq3N2rZGp%2Bp8UDdCn%2F0VFno%3D&amp;re
> served=0
> 
> 
> https://nam06.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.or
> g%2Finternet-
> drafts%2F&amp;data=04%7C01%7CJensen.Thomas%40microsoft.com%7C8671
> 3b349e6a486843fc08d9428355a8%7C72f988bf86f141af91ab2d7cd011db47%
> 7C1%7C0%7C637613954176543713%7CUnknown%7CTWFpbGZsb3d8eyJWIjoi
> MC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000
> &amp;sdata=%2Byhw8LFWOGvaT2x58k4XXGPxXs6k9yLdxY6Lsikbv8M%3D&am
> p;reserved=0
> 
> 
> --
> Add mailing list
> [email-masked]
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ie
> tf.org%2Fmailman%2Flistinfo%2Fadd&amp;data=04%7C01%7CJensen.Thomas
> %40microsoft.com%7C86713b349e6a486843fc08d9428355a8%7C72f988bf86f
> 141af91ab2d7cd011db47%7C1%7C0%7C637613954176543713%7CUnknown
> %7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWw
> iLCJXVCI6Mn0%3D%7C1000&amp;sdata=R2jDq9tX1nZbR6HiOitu771YBjdTPOy
> GZtXEa58doTo%3D&amp;reserved=0