Subject: Re: [Add] DDR and 6to4

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 24 Jan 2022 09:29:16 +0000

Tommy,

Wearing no hat at all, isn't this 6to4 address issue completely orthogonal to DDR SVCB or even to ADD ? I.e., IMHO let's not mention anything about 6to4 addresses in our WG documents, else should we also say something about IPv6 ULA ? :-)

Regards

-éric

From: Add <[email-masked]> on behalf of Tommy Jensen <Jensen.Thomas=[email-masked]>
Date: Wednesday, 19 January 2022 at 03:27
To: ADD Mailing list <[email-masked]>
Subject: [Add] DDR and 6to4

What does everyone think about actively discouraging the use of 6to4 addresses in the DDR SVCB records? I know this is covered by RFC7526; is that sufficient for us to omit text in DDR? Should we reference it and require resolvers to not provide those addresses? It seems there are some edge cases where a client and resolver may disagree about the nature of a given IP address if these are designated.

Thanks,
Tommy

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 25 Jan 2022 08:24:18 -0800

Like Eric, I’d also lean towards not saying anything in the DDR spec about these specific address types.

Tommy (Pauly)

> On Jan 24, 2022, at 1:29 AM, Eric Vyncke (evyncke) <evyncke=[email-masked]> wrote:
> 
> Tommy,
>  
> -- 
> Add mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/add

---

From: Daniel Migault <[email-masked]>
Date: Tue, 25 Jan 2022 11:47:04 -0500

I have the impression this is also a bit orthogonal too, but depending on
the edge use case you have in mind or the scale of the issue, we may add a
note in the security consideration.
Yours,
Daniel

On Tue, Jan 25, 2022 at 11:24 AM Tommy Pauly <tpauly=
[email-masked]> wrote:

> On Jan 24, 2022, at 1:29 AM, Eric Vyncke (evyncke) <
> evyncke=[email-masked]> wrote:
>
> Tommy,
>
> Wearing no hat at all, isn't this 6to4 address issue completely orthogonal
> to DDR SVCB or even to ADD ? I.e., IMHO let's not mention anything about
> 6to4 addresses in our WG documents, else should we also say something about
> IPv6 ULA ? :-)
>
> Regards
>
> -éric
>
> *From: *Add <[email-masked]> on behalf of Tommy Jensen <
> Jensen.Thomas=[email-masked]>
> *Date: *Wednesday, 19 January 2022 at 03:27
> *To: *ADD Mailing list <[email-masked]>
> *Subject: *[Add] DDR and 6to4
>
> What does everyone think about actively discouraging the use of 6to4
> addresses in the DDR SVCB records? I know this is covered by RFC7526; is
> that sufficient for us to omit text in DDR? Should we reference it and
> require resolvers to not provide those addresses? It seems there are some
> edge cases where a client and resolver may disagree about the nature of a
> given IP address if these are designated.
>
> Thanks,
> Tommy
> --
> Add mailing list
> [email-masked]

-- 
Daniel Migault
Ericsson

---

From: "Vinny Parla (vparla)" <[email-masked]>
Date: Tue, 25 Jan 2022 16:56:10 +0000

Question.  Does consideration need to be made when dealing with translation technologies and should this be stated explicitly or can it be assumed?

For example, if an IPv4 mapped IPv6 address is used at the client, then the certificate matching logic of the implementation should look for the IPv4 address in the certificate not the mapped address that is in IPv6 format.

Thoughts?

-Vinny

From: Add <[email-masked]> On Behalf Of Daniel Migault
Sent: Tuesday, January 25, 2022 11:47 AM
To: Tommy Pauly <tpauly=[email-masked]>
Cc: Eric Vyncke (evyncke) <evyncke=[email-masked]>; ADD Mailing list <[email-masked]>; Tommy Jensen <Jensen.Thomas=[email-masked]>
Subject: Re: [Add] DDR and 6to4

I have the impression this is also a bit orthogonal too, but depending on the edge use case you have in mind or the scale of the issue, we may add a note in the security consideration.

Yours, 

Daniel  

On Tue, Jan 25, 2022 at 11:24 AM Tommy Pauly <tpauly=[email-masked] <mailto:[email-masked]> > wrote:

Tommy (Pauly)

On Jan 24, 2022, at 1:29 AM, Eric Vyncke (evyncke) <evyncke=[email-masked] <mailto:evyncke=[email-masked]> > wrote:

Tommy,

Regards

-éric

From: Add <[email-masked] <mailto:[email-masked]> > on behalf of Tommy Jensen <Jensen.Thomas=[email-masked] <mailto:Jensen.Thomas=[email-masked]> >
Date: Wednesday, 19 January 2022 at 03:27
To: ADD Mailing list <[email-masked] <mailto:[email-masked]> >
Subject: [Add] DDR and 6to4

Thanks,

Tommy

-- 
Add mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/add

-- 
Add mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/add

-- 

Daniel Migault

Ericsson