Subject: [Add] I-D Action: draft-ietf-add-ddr-05.txt

From: [email-masked]
Date: Mon, 31 Jan 2022 14:25:06 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Adaptive DNS Discovery WG of the IETF.

        Title           : Discovery of Designated Resolvers
        Authors         : Tommy Pauly
                          Eric Kinnear
                          Christopher A. Wood
                          Patrick McManus
                          Tommy Jensen
	Filename        : draft-ietf-add-ddr-05.txt
	Pages           : 15
	Date            : 2022-01-31

Abstract:
   This document defines Discovery of Designated Resolvers (DDR), a
   mechanism for DNS clients to use DNS records to discover a resolver's
   encrypted DNS configuration.  This mechanism can be used to move from
   unencrypted DNS to encrypted DNS when only the IP address of a
   resolver is known.  This mechanism is designed to be limited to cases
   where unencrypted resolvers and their designated resolvers are
   operated by the same entity or cooperating entities.  It can also be
   used to discover support for encrypted DNS protocols when the name of
   an encrypted resolver is known.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-add-ddr/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-add-ddr-05.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-add-ddr-05

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Tommy Jensen <[email-masked]>
Date: Mon, 31 Jan 2022 22:36:21 +0000

Hey everyone,

We made changes to DDR to address 112 feedback, list comments, and GitHub discussion. Namely:
-- Use of original IP address as host
-- specify use of ServiceMode SVCB records and following AliasMode records to find them
-- guidance on (not) using designations across different networks
-- minor text updates to reflect WG decisions such as relying only on the original IP address as an authenticated identifier

Based on WG list discussion, we did not make any updated to address special case IP addresses where client and server may not see the same address.

Thanks,
Tommy & Tommy

> -----Original Message-----
> From: Add <[email-masked]> On Behalf Of [email-masked]
> Sent: Monday, January 31, 2022 2:25 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [EXTERNAL] [Add] I-D Action: draft-ietf-add-ddr-05.txt
> 
> 
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatra
> cker.ietf.org%2Fdoc%2Fdraft-ietf-add-
> ddr%2F&amp;data=04%7C01%7CJensen.Thomas%40microsoft.com%7Cda2fe9
> 52d53d42655b2808d9e508a5f3%7C72f988bf86f141af91ab2d7cd011db47%7C
> 1%7C0%7C637792647681505825%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiM
> C4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&
> amp;sdata=inwrbkB42sY0IfGDgl%2B4q4lvWR2NQYBiXk8WUtLgJEo%3D&amp;r
> eserved=0
> 
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ie
> tf.org%2Farchive%2Fid%2Fdraft-ietf-add-ddr-
> 05.html&amp;data=04%7C01%7CJensen.Thomas%40microsoft.com%7Cda2fe9
> 52d53d42655b2808d9e508a5f3%7C72f988bf86f141af91ab2d7cd011db47%7C
> 1%7C0%7C637792647681505825%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiM
> C4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&
> amp;sdata=yKOm3ILFRksiYMcqQjNJ%2BDGTDsu2Pp40MUVjeXGqJEM%3D&am
> p;reserved=0
> 
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ie
> tf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-add-ddr-
> 05&amp;data=04%7C01%7CJensen.Thomas%40microsoft.com%7Cda2fe952d5
> 3d42655b2808d9e508a5f3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7
> C0%7C637792647681505825%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4w
> LjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp
> ;sdata=R7xtW3l9jU%2BSoizEmMNxq4KgQMZjcXxzzBKP72VSkt4%3D&amp;rese
> rved=0
> 
> 
> --
> Add mailing list
> [email-masked]
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ie
> tf.org%2Fmailman%2Flistinfo%2Fadd&amp;data=04%7C01%7CJensen.Thomas
> %40microsoft.com%7Cda2fe952d53d42655b2808d9e508a5f3%7C72f988bf86f
> 141af91ab2d7cd011db47%7C1%7C0%7C637792647681505825%7CUnknown
> %7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWw
> iLCJXVCI6Mn0%3D%7C3000&amp;sdata=CjNDPZI%2BQCQiV0tJL9noDSQCDasf
> Rgq73abCBEf6PXw%3D&amp;reserved=0