Subject: [Adslmib] VDSL Line Extension MIB - Modified

From: Flemisch Felix <[email-masked]>
Date: Mon, 9 Jun 2003 03:33:53 +0200

Hi all,

this email is a summary response to the comments by Bob,
Rajesh, and Randy (msg00248, msg00255, msg00256, msg00258,
msg00260/msg00261, msg00262) on my "VDSL Line Extension MIB"
proposals (msg00243, msg00254, msg00257).

It seems that the rationale of my proposals is well
understood but they can nevertheless hardly be agreed
upon for the following reasons:
- mixing up with WG charter issues
- contradictions to agreed MIB design principles
- impossibility of full traceability to standardized
  LCS extension tables as long as the names of
  these tables are not yet specified
- freedom of vendors to define whatever extensions 
  they may find appropriate, which leads to
  undocumentable relationships from the core
  configuration profile table to vendor-specific
  generic and LCS extension tables
- the index of the line-code independent configuration
  profile table can and should be used as index for LCS
  (and vendor-specific) extension tables
- the indexing structure of the core VDSL line MIB
  does not require changes to adequately support
  future modules (either standardized or vendor-
  specific) to handle LCS stuff
- danger to revive the old LCS and vendor-specific
  discussion that paralysed DSLF and WG work

Presumably it would be of little help if I moved
the proposed parameter vdslLineConfProfileLCSExt
from vdslLineEntry to vdslLineConfProfileEntry
(i.e., the line-code independent configuration profile
would include a parameter that either refers to LCS
extension parameters that are not further specified
or indicates that no LCS parameters are needed).

I therefore modify my original proposals as follows:

1. Proposal - modified

   Enhance in section 2.5 of vdsl-09 the text describing line
   configuration profiles as follows:
   ...
   o   Line Configuration Profiles - These profiles contain parameters
       for configuring VDSL lines and their channels.  They are defined
       in the line-code independent vdslLineConfProfileTable and in
       supplementary standardized line-code specific (LCS) configuration
       profile tables.  Additionally vendor-specific configuration
       profile extension tables may exist.  vdslLineConfProfileTable
       is defined in the VDSL-LINE MIB module that is specified in
       this RFC, and standardized LCS configuration profile tables are
       defined in the VDSL-LINE-EXT MIB module that is specified in
       a planned complementary RFC.  Each entry of vdslLineTable
       references a row of vdslLineConfProfileTable and uses the very
       same reference as a common index into one or more applicable LCS,
       or vendor-specific, configuration profile tables.  The referenced
       specific row(s) augment(s) the line-code independent parameter
       set by a specific parameter set (which may be empty).
   ...
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

2. Proposal - modified

   Enhance the DESCRIPTION of MODULE-IDENTITY as follows:
    ...
            Tx   -- Transmit
            Blks -- Blocks

    --  Note

    This MIB module does not contain line-code specific (LCS) elements
    for neither MCM lines nor SCM lines.  An LCS VDSL Line Extension
    MIB (VDSL-LINE-EXT-MIB) module is planned as a mandatory supplement
    to the core VDSL-LINE-MIB, since otherwise both SCM and MCM lines
    can possibly only be fully configured in a vendor-specific way.

    The VDSL line table refers not only to the line-code independent
    configuration profile table ( vdslLineConfProfileTable ), defined
    in this MIB module, but also to, for example, a set of commonly
    indexed applicable LCS configuration profile tables."
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

3. Proposal - modified

   Enhance the REVISION clauses of MODULE-IDENTITY as follows (in case
   a final draft version "draft-ietf-adslmib-vdsl-10.txt" is issued):
    --  Revision history
    ...
    REVISION "200304180000Z" -- April 18, 2003
    DESCRIPTION "Brought into conformance with DSLF TR-057.
                This means in particular that all line-code specific
                (LCS) elements have been removed for both, MCM lines
                and SCM lines."
    ...
    REVISION "200306080000Z" -- June 8, 2003
    DESCRIPTION "Enhanced in section 2.5 the description of
                line configuration profiles.

                Added note to DESCRIPTION of MODULE-IDENTITY
                regarding LCS VDSL Line MIB extensions.

                Enhanced DESCRIPTION of vdslLineConfProfile within
                vdslLineEntry regarding the common indexing of
                LCS and vendor-specific MIB extensions.

                Added vdslLineConfLineType
                to vdslLineCodeProfileEntry.

                Corrected many mechanical and editorial flaws,
                added various clarifications."
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

4. Proposal - modified

   Enhance the DESCRIPTION of vdslLineConfProfile within vdslLineEntry
   as follows:
    vdslLineConfProfile OBJECT-TYPE
        SYNTAX       SnmpAdminString (SIZE(1..32))
        MAX-ACCESS   read-write
        STATUS       current
        DESCRIPTION
            "The value of this object identifies the row
            in the VDSL Line Configuration Profile Table
            ( vdslLineConfProfileTable ), which applies for
            this VDSL line and its channels (if any).
            Since this table is indexed by vdslLineConfProfileName
            vdslLineConfProfile is a valid such name.

            The very same index MUST be used to identify the row
            in one or more standardized LCS configuration profile
            extension tables, which applies for this VDSL line
            and its channels.  These tables are defined in the
            complementary VDSL Line Extension MIB (VDSL-LINE-EXT-MIB)
            and are commonly indexed by vdslLineConfProfileName.

            The very same index SHOULD be used to identify the row
            in one or more vendor-specific, generic or LCS,
            configuration profile extension tables, which applies
            for this VDSL line and its channels."
        ::= { vdslLineEntry 3 }
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

Regards,

Felix Flemisch
Siemens AG

Information and Communication Networks
Carrier Products Systems Engineering
Hofmannstr. 51
D-81359 Munich
Germany
Phone    +49 89 722 62175
Email    [email-masked]
Internet http://www.siemens.com/
_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

---

From: Bob Ray <[email-masked]>
Date: 09 Jun 2003 09:15:55 -0500

Felix (and all):

This insistence that the hands of the IETF be bound by specific 
references to work that hasn't been chartered and by work that 
hasn't been done is not productive.

I would suggest, instead, that those who feel most strongly
about the "missing tables" do the following:

a) dredge up a copy of the -07 draft
b) write a draft vdsl-line-extension-mib using the missing
   tables
c) submit the draft as an individual contribution to the
   IETF
d) at the next meeting of the adslmib working group (perhaps
   Vienna), suggest that the charter be amended to support
   an extension MIB 
e) humbly offer the individual contribution to the working 
   group as a good starting point for such work.
f) work with (and in) the DSL Forum to achieve agreement as
   to THEIR preferred management objects.

I believe this approach would be FAR MORE PRODUCTIVE...

See: http://www.ietf.org/ietf/1id-guidelines.txt for information
on accomplishing this.

Regards,
Bob Ray