Subject: Re: [Adslmib] VDSL Line Extension MIB]

From: Bob Ray <[email-masked]>
Date: 05 Jun 2003 16:00:50 -0500

> To take this comment into account and to clarify the overall description
> I adopt the 4th Proposal of my email of 2nd June as follows:
> 4. Proposal, modified

>     Enhance the conceptual row vdslLineEntry by the new parameter
>     "vdslLineConfProfileLCSExt":
>  >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
>      ...
>      VdslLineEntry ::=
>          SEQUENCE
>              {
>              vdslLineConfProfileLCSExt              SnmpAdminString,
>              }
>      ...
>          ::= { vdslLineEntry 3 }

There is simply no need to put such an object in the VDSL Line MIB.

For example, let there be a table in a LCS extension MIB called
vdslExtMCMProfileTable.  This table would have as its index, the 
profile name from the VDSL Line MIB :

    IMPORTS   vdslLineConfProfileName FROM VDSL-LINE-MIB;
    ...
    vdslExtMCMProfileEntry OBJECT-TYPE      
        ...
        INDEX { vdslLineConfProfileName }   
        ::= { vdslExtMCMProfileTable 1 }    

Tables in any extension MIB would tie into the VDSL Line MIB profile 
structure via the profile name.  This is what I meant by the previous 
email.  

Hope this helps.

Regards,
Bob Ray
PESA Switching Systems

_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

---

From: Rajesh Abbi <[email-masked]>
Date: Thu, 05 Jun 2003 17:22:40 -0400

I concur with Bob.

Firstly, the issue of LSC extension is still under discussion.  Secondly, even if
an extension MIB was defined, it can use the index in the base MIB without
having an additional index in the base MIB.

Regards,

Rajesh