Subject: [alto] Should we require "numerical" and "ordinal" costs to be consistent?

From: Bill Roome <[email-masked]>
Date: Wed, 03 Oct 2012 12:23:04 -0400

Suppose an ALTO server supports both "numerical" and "ordinal" cost modes
for the same cost type. Should the protocol require that the values for
those two modes to be mutually consistent?

And if we do want that, how should the requirement be worded? I'm tempted
to say

   "Let num(A,B) and ord(A,B) be the numerical and ordinal costs
    for source PID A and destination PID B, respectively.
    Then for all PIDs A, B, C and D,
        num(A,B) >= num(C,D) implies ord(A,B) >= ord(C,D),
        ord(A,B) >= ord(C,D) implies num(A,B) >= num(C,D),
        num(A,B) <= num(C,D) implies ord(A,B) <= ord(C,D),
        ord(A,B) <= ord(C,D) implies num(A,B) <= num(C,D)."

Is that sufficient?

---

From: Richard Alimi <[email-masked]>
Date: Wed, 3 Oct 2012 10:07:17 -0700

I can't think of a valid reason why they should be inconsistent.  I'd
be fine with mandating it in the protocol, but I'd have to leave that
up to the chairs (and of course, feedback from the rest of the WG)
given that it has already been through WGLC and has been submitted to
IESG.

Rich

On Wed, Oct 3, 2012 at 9:23 AM, Bill Roome <[email-masked]> wrote:
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Wed, 3 Oct 2012 19:15:14 +0100

I guess it depends on whether the semantics of ordinal costs is:

A) rank according to numerical costs; or
B) rank according to something the ALTO server knows

If you consider a future case where people define additional cost types the (A) requires them to also define both an ordinal and numeric cost type (assuming both are meaningful) whereas (B) doesn't and gives the ALTO server freedom to do what it likes. 

I don't have a strong opinion either way. 

Ben

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 4 Oct 2012 14:40:07 +0530

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
Bill
> Roome
> Sent: Wednesday, October 03, 2012 9:53 PM
> To: [email-masked]
> Subject: [alto] Should we require "numerical" and "ordinal" costs to be
> consistent?
> 
[Dhruv Dhody>]  

For most cost-type (routingcost, hop-count, delay etc) assertion made by
Bill above seems correct. 
Lower the cost ~ better the rank (lower numerical value of rank that is) and
vice-versa! 

But a future cost-type say - (Residual Bandwidth) where it could be
opposite: lower the residual bandwidth ~ worse the rank!  
So I am kind of tempted to leave the protocol as it is without any assertion
for any future extensions. 

What does the WG think?

Regards,
Dhruv

---

From: Sabine Randriamasy <[email-masked]>
Date: Thu, 4 Oct 2012 11:41:51 +0200

Hi Bill, Ben, Dhody and Rich

An ALTO Server could definitely consider cases A and B,  while 
providing  rules  in case the  values  are provided in  Numerical mode.

In case A, Bill's rule can be adapted to 2 cases to be specified:
1 - If the numerical value represents a cost (e.g. routingcost) to be 
minimized then Bill's rule applies
2 - If the numerical value represents a utility (e.g. available 
bandwidth) to be maximized, then this rule becomes:

num(A,B) >= num(C,D) implies ord(A,B) <= ord(C,D),
and so on...

In case case B, the rank is typically provided according to knowledge of ALTO server only (policy or other qualitative consideration not to be unveiled to clients). 
In that case, I guess no numerical value is provided, no compaptibility rule is needed.  

Sabine

-- 

---------------------------------------------------------
Sabine RANDRIAMASY 
Alcatel-Lucent Bell Labs France 
Centre de Villarceau
Route de Villejust - 91620 NOZAY - FRANCE

E-MAIL : [email-masked]
TEL: +33 (0)1 30 77 27 45 
         (On Net) 2 103 27 45
---------------------------------------------------------