Subject: [alto] re-chartering discussion slides

From: "Songhaibin (A)" <[email-masked]>
Date: Thu, 6 Mar 2014 10:08:10 +0000

Hi,

Are there any slides on the topics that are listed under the re-chartering discussion? I prefer to read slides before the meeting.

BR,
-Haibin

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 06 Mar 2014 05:04:55 -0600

On 03/06/2014 04:08 AM, Songhaibin (A) wrote:
> Are there any slides on the topics that are listed under the
> re-chartering discussion? I prefer to read slides before the meeting.

A version (subject to change) has been posted on the meetings material
page.

Cheers,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: "Songhaibin (A)" <[email-masked]>
Date: Thu, 6 Mar 2014 11:07:15 +0000

Thank you, Vijay.

-haibin

-----Original Message-----
From: alto [mailto:[email-masked]] On Behalf Of Vijay K. Gurbani
Sent: Thursday, March 06, 2014 11:05 AM
To: [email-masked]
Subject: Re: [alto] re-chartering discussion slides

> re-chartering discussion? I prefer to read slides before the meeting.

A version (subject to change) has been posted on the meetings material page.

Cheers,

- vijay

_______________________________________________
alto mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/alto

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 6 Mar 2014 16:00:34 -0000

Hi,

Sorry that I am trying to process this during IETF week and not able to focus
properly.

> A version (subject to change) has been posted on the meetings material page.

I am trying to separate out the network layers and the use cases for the
proposals in this slideset.

For example, slide 24 has:

> Abstract graph for a given client (usually not a NMS); not full RIB data.

I am disconcerted by even the mention of RIB. Is the proposal to build a "P2P
layer RIB" or is the proposal to start to include network layer information in
ALTO?

Thanks,
Adrian

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 06 Mar 2014 16:41:57 -0600

> layer RIB" or is the proposal to start to include network layer information in

Adrian: The intent it to include some "abstract" network layer
information in ALTO, more than is now available through the network
map and cost map constructs, but most certainly not raw topology or RIB
data.

What we have to come to an understanding is the exact level of
abstraction here.

Cheers,

- vijay

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Fri, 7 Mar 2014 10:38:44 +0000

> map and cost map constructs, but most certainly not raw topology or RIB

As original author of this text, I have to back what Vijay explained: I wrote that text to explain my understanding of how ALTO differs to other IETF work, e.g., I2RS or possibly PCE.

An ALTO client needs network topology information to perform an intelligent endpoint selection, in particular if the ALTO client is an IT software application that is not tightly integrated into network operation (e.g., a CDN mgmt system, a cloud orchestrator, ...). This probably means:

- A ALTO server operator may not be interested in exposing the full routing topology, including all internal IGP/BGP configuration details, to such an IT application. Specifically, the ALTO client may not be an application operated by the network operations team of an ISP, i.e., it is not an NMS plugin or something similar. Therefore, for privacy, robustness, and other reasons (e.g., corporate policies), the ALTO server would only provide an abstract, orchestrated view of what matters for a given client.

- In many use cases, an ALTO client is developed by IT developers without a full understanding of routing protocol details. Therefore, it is up to the ALTO server to offer a representation that IT developers can understand without routing protocol expertise. In my experience, the simplicity of ALTO is a key value proposition for such developers.

- draft-ietf-alto-deployments Section 3.2.1 explains how an ALTO server can get access to network information. My current understanding is that use of BGP-LS, I2RS or other direct interfaces into network elements would possibly require that the ALTO server to understands routing protocol details (there are other alternatives). Possibly it will have to correlate such data with other data sources. But it will be up to the policies in the ALTO server to extract and create an abstract topology representation out of this. Obviously, ALTO should be flexible to enable the server to express what it wants to expose.

In summary, in my view, an ALTO server exposes a filtered network topology that removes all internal, operational network data (including RIB details) that does not matter to its clients.

Michael