Subject: [alto] bandwidth calendaring on Recharter discussion

From: Qin Wu <[email-masked]>
Date: Thu, 6 Mar 2014 18:24:14 +0000

Hi:
Somebody pointed me my clarification on bandwidth calendaring is not very clear when
Chair asked me in the meeting what the cost value array stands for in the bandwidth calendaring example slide,

Here I like to emphasize again.
the cost value array in the example represent a list of availbandwidth values in the output.
Each value is reported at specific measurement interval, The first value in the cost value array will be reported
At the "start time" defined in the description metadata of Information resource directory exchange.
The duration in the description metadata of Information resource directory exchange represent time difference
Between start time to report the first value and end time to report the last value in the cost value array.

For example, I as alto client want to know the avail bandwidth values that are applied to specific path from source endpoint to dest endpoint.
The avail bandwidth values is measured every 1 hour, the first avail bandwidth is measured at 10:20am, the last measured avail bandwidth
Will be measured at 5:20pm, then we list all the avail bandwidth values in the form of cost value array in the output.

Also I want to emphasize the clear use cases for alto cost map extension have already been clearly specified in several other working group drafts
e.g.,draft-ietf-isis-te-metric-extensions-01, draft-ietf-ospf-te-metric-extensions-01. What alto is doing is abstract these metrics gathered from routing protocol into
alto cost metric from one endpoint to another endpoint.

Regards!
-Qin

---

From: "RANDRIAMASY, SABINE (SABINE)" <[email-masked]>
Date: Fri, 7 Mar 2014 12:46:55 +0000

Dear all,

Upon Qin's explanation, I'd like to add that, the "calendar" has been integrated in the example slides to illustrate the "when to connect" in the re-chartering topic. The calendar, exposed in these slides is an application to the TE metric "available bandwidth", of an extension proposal called ALTO Cost Schedule, see references below, that allows to schedule both the non-real time application flows and the ALTO requests to the ALTO Server.

The extension proposes to expose applicable cost values as an array and defines a new Cost Mode to specify, in the IRD, the attributes that allow to interpret this array.

-          To interpret the array values: we need the interval length in terms of time units ("interval-unit"), the number of these units ("nb-int-units") and the number of these intervals ("nb-interval"), and the date at which the first value of the array is applicable, and the applicable time zone.

-          To evaluate the information freshness and schedule the next ALTO Request for Cost values, we also need the date of next and previous update.

The example attribute names we provided in the slides are a starting point and still to be completed and discussed on the ALTO WG list. The same applies of course to the ALTO Cost Schedule.

To illustrate the example in the discussion slides: if an ALTO server exposes ALTO Cost values applicable during a day, and detailed per intervals of 2 hours, starting today at midnight and applicable at London Time: the array will have 12 values and description attributes will be: (modulo bracket errors).

(in Slides)
"description": {"interval-unit": hh, "nb-int-units": 2, "start": 00/00/07/03/2014, "nb-interval":12}

(in Schedule draft)
"description": {"unit" : [hour, 2], "size" : 12, "begin" : 0, "time zone": "UTC+0", "lastupdate": 00/00/03/03/2014, "nextupdate": 00/00/03/03/2014}}

In the "Schedule" proposal, attributes "lastupdate" and "nextupdate", correspond to Monday and Friday and illustrate that daily traffic patterns may be different during week-ends. Again, discussion on the naming, format and usage of these attributes is more than welcome.

Thanks a lot,
Sabine

References,
latest slides in http://tools.ietf.org/agenda/85/slides/slides-85-alto-4.pdf,
and latest draft update (February 2014) http://tools.ietf.org/html/draft-randriamasy-alto-cost-schedule-03 and

De : alto [mailto:[email-masked]] De la part de Qin Wu
Envoyé : jeudi 6 mars 2014 19:24
À : [email-masked]<mailto:[email-masked]>
Objet : [alto] bandwidth calendaring on Recharter discussion

Hi:

Regards!
-Qin