Subject: [alto] Background on IANA registry for ALTO Endpoint Property Type?

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Thu, 26 Mar 2015 23:50:52 +0000

Hi,

Does somebody with a memory better than mine recall why RFC 7285 mandates that endpoint properties are assigned by IETF review (other than "priv:")? This results in a rather high bar and possibly in a large number of RFCs as new use cases of ALTO emerge.
 
Why does RFC 7285 not use some simpler registration procedure, such as expert review?

At first sight, we could perhaps have avoided some of today's discussion if ALTO would not need IETF review for each endpoint type that could possibly be useful in some ALTO deployments.

Thanks

Michael

---

From: Wendy Roome <[email-masked]>
Date: Thu, 26 Mar 2015 21:34:14 -0500

Apparently that's because "The IETF has always done that." Eg, formally reviewed anything added to an IANA registry. See rfc 5226. As a guess, it's a reaction to the early days of the net, when folks went crazy defining their own http & email headers. Or Netscape creating a slew of proprietary HTML tags. Remember the browser wars of the 1990's?

I suspect that is so engrained that it's impossible to change. The only way to avoid it would be to drop the "Must register with IANA" requirement.

     - Wendy Roome

> On Mar 26, 2015, at 18:50, "Scharf, Michael (Michael)" <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto