Subject: [alto] ALTO implementation interoperability

From: Hans Seidel <[email-masked]>
Date: Tue, 17 Mar 2015 10:03:03 +0100

Hi All,

we are currently working on an ALTO server implementation and want to 
test the current state regarding compatibility with the RFC 7285.

I took a look at the draft of the last Interop, which is 
"draft-gurbani-alto-interop-cases-02" if I am not mistaken, but it seems 
to me that some test cases are not compatible with the RFC. Please 
correct me if I am wrong.

Is there is another interop planned in the future based on the RFC?

Or maybe somebody else is working on an implementation and wants to test 
it as well. If so, feel free to contact me.

Cheers
Hans

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 17 Mar 2015 07:33:01 -0500

> correct me if I am wrong.

Hans: You are correct.  The I-D draft-gurbani-...-cases-02 does not
correspond to RFC 7285.

> Is there is another interop planned in the future based on the RFC?

I did not get the time to organize an interoperability event in Dallas,
but I will talk to my co-chairs to determine if we can put one together
for the summer IETF.

Cheers,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: Wendy Roome <[email-masked]>
Date: Tue, 17 Mar 2015 09:17:16 -0400

If anyone wants to try an informal test, I will be in Dallas (with my alto server & client) from Monday thru Friday.

If you want to test your client, we maintain a simple public alto server at
      http://alto.alcatel-lucent.com:8000/directory
If you have a public alto server, we also have a validator at
      http://alto.alcatel-lucent.com:8000/validate-server.php

Disclaimer: These are based on my interpretation of RFC 7285; they are not the official word of the IETF. Please let me know if you find any mistakes.

        - Wendy Roome

> On Mar 17, 2015, at 5:03, Hans Seidel <[email-masked]> wrote:
> 
> Hi All,
> 
> we are currently working on an ALTO server implementation and want to test the current state regarding compatibility with the RFC 7285.
> 
> I took a look at the draft of the last Interop, which is "draft-gurbani-alto-interop-cases-02" if I am not mistaken, but it seems to me that some test cases are not compatible with the RFC. Please correct me if I am wrong.
> 
> Or maybe somebody else is working on an implementation and wants to test it as well. If so, feel free to contact me.
> 
> Cheers
> Hans
> 
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto

---

From: "Y. Richard Yang" <[email-masked]>
Date: Tue, 17 Mar 2015 17:05:28 -0400

> but I will talk to my co-chairs to determine if we can put one together
It will be cool to have an interop for the summer IETF. For those who are
interested, some of us are working on having an open-source ALTO server
running in ODL. We are slightly behind schedule, but should be able to
catch up in Apr., after IETF. If there is anyone who is interested in
collaboration, you are more than welcome.

Richard

> Web: https://urldefense.proofpoint.com/v2/url?u=http-3A__ect.
> bell-2Dlabs.com_who_vkg_&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=
> 4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=
> IFXVSS1Ngo0C7z51Gunp5gTAVG7hdQAOfiXLLRkPLi4&s=RUjSP5rpFsp8V2Y0xuG9_
> 3pFcAAsDEjzi2YQNNaMKfY&e=   | Calendar: https://urldefense.proofpoint.
> com/v2/url?u=http-3A__goo.gl_x3Ogq&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=
> 4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=
> IFXVSS1Ngo0C7z51Gunp5gTAVG7hdQAOfiXLLRkPLi4&s=
> wY56fXByx0Kd3boQqPHpBjX7uzem5fDJHZAW1FIv_Mc&e=
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_alto&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=
> 4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=
> IFXVSS1Ngo0C7z51Gunp5gTAVG7hdQAOfiXLLRkPLi4&s=
> JAiHH7palOiAkB3m6zdiENhShLMINWuIhPrijAeT0iQ&e=

---

From: Hans Seidel <[email-masked]>
Date: Thu, 19 Mar 2015 11:49:58 +0100

Thank you for your responses.

On 17.03.2015 22:05, Y. Richard Yang wrote:
>
>
> On Tue, Mar 17, 2015 at 8:33 AM, Vijay K. Gurbani <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
> It will be cool to have an interop for the summer IETF. For those who 
> are interested, some of us are working on having an open-source ALTO 
> server running in ODL. We are slightly behind schedule, but should be 
> able to catch up in Apr., after IETF. If there is anyone who is 
> interested in collaboration, you are more than welcome.

I also like the idea of an interop for the summer IETF in Prague. Since 
I am rather new to the IETF community, I am not very familiar with the 
procedures but if I can be of any help, let me know.

Hans

>     Email: vkg@{bell-labs.com <http://bell-labs.com>,acm.org
>     <http://acm.org>} / [email-masked]
>     <mailto:[email-masked]>
>     Web:
>     https://urldefense.proofpoint.com/v2/url?u=http-3A__ect.bell-2Dlabs.com_who_vkg_&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=IFXVSS1Ngo0C7z51Gunp5gTAVG7hdQAOfiXLLRkPLi4&s=RUjSP5rpFsp8V2Y0xuG9_3pFcAAsDEjzi2YQNNaMKfY&e=
>      | Calendar:
>     https://urldefense.proofpoint.com/v2/url?u=http-3A__goo.gl_x3Ogq&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=IFXVSS1Ngo0C7z51Gunp5gTAVG7hdQAOfiXLLRkPLi4&s=wY56fXByx0Kd3boQqPHpBjX7uzem5fDJHZAW1FIv_Mc&e=
>
>     [email-masked] <mailto:[email-masked]>
>     https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=IFXVSS1Ngo0C7z51Gunp5gTAVG7hdQAOfiXLLRkPLi4&s=JAiHH7palOiAkB3m6zdiENhShLMINWuIhPrijAeT0iQ&e=
>
>
>

-- 
BENOCS GmbH
Dipl.-Ing. Hans Seidel
Winterfeldtstr. 21
10781 Berlin
Germany
Phone: +49 - 30 / 577 0004-0
Email: [email-masked]
www.benocs.com

Board of Management:
   Michael Wolz, Dr.-Ing. Oliver Holschke, Dr.-Ing. Ingmar Poese
Commercial Register: Amtsgericht Bonn HRB 19378

---

From: "Y. Richard Yang" <[email-masked]>
Date: Thu, 19 Mar 2015 17:25:32 -0400

Hi Hans,

On Thu, Mar 19, 2015 at 6:49 AM, Hans Seidel <[email-masked]> wrote:
> I also like the idea of an interop for the summer IETF in Prague. Since I
> am rather new to the IETF community, I am not very familiar with the
Wonderful! Some of us here will want to engage in the development of an
interop in Prague as well. It will be nice to coordinate and get started
soon, say after this IETF.

Thanks!

Richard

>> Email: vkg@{bell-labs.com
>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__bell-2Dlabs.com&d=AwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=R4xkdnXhg_k_vtyBiV9EpnC5-YbvlN0SXPP85vb1GGw&s=cgQbku2DjmNfzRg-2XNQd5IUUnl-5vzyEaRHnPAopcw&e=>
>> ,acm.org
>> <https://urldefense.proofpoint.com/v2/url?u=http-3A__acm.org&d=AwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=R4xkdnXhg_k_vtyBiV9EpnC5-YbvlN0SXPP85vb1GGw&s=eX6E5I95y8t27qk4Ww6PFoq8e_2IRg0zL_zlSGMlpP8&e=>}
>> / [email-masked]
>> Web:
> Email: [email-masked] <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.benocs.com&d=AwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=R4xkdnXhg_k_vtyBiV9EpnC5-YbvlN0SXPP85vb1GGw&s=UwI1cKJv4mJuNH6v4DWFB5wK_QM9pl59SliBxc-gtzo&e=>
>
> Board of Management:

---

From: Jan Seedorf <[email-masked]>
Date: Fri, 20 Mar 2015 14:41:12 +0000

We have also put this topic on the chair slides for the session in Dallas to get feedback from the room, but please also continue raising your opinion on this here on the ML.

-          Jan

From: alto [mailto:[email-masked]] On Behalf Of Y. Richard Yang
Sent: Donnerstag, 19. März 2015 22:26
To: Hans Seidel
Cc: IETF ALTO
Subject: Re: [alto] ALTO implementation interoperability

Hi Hans,

On Thu, Mar 19, 2015 at 6:49 AM, Hans Seidel <[email-masked]<mailto:[email-masked]>> wrote:
It will be cool to have an interop for the summer IETF. For those who are interested, some of us are working on having an open-source ALTO server running in ODL. We are slightly behind schedule, but should be able to catch up in Apr., after IETF. If there is anyone who is interested in collaboration, you are more than welcome.

I also like the idea of an interop for the summer IETF in Prague. Since I am rather new to the IETF community, I am not very familiar with the procedures but if I can be of any help, let me know.

Wonderful! Some of us here will want to engage in the development of an interop in Prague as well. It will be nice to coordinate and get started soon, say after this IETF.

Thanks!

Richard

Hans

Richard

Cheers,

- vijay
--
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com<https://urldefense.proofpoint.com/v2/url?u=http-3A__bell-2Dlabs.com&d=AwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=R4xkdnXhg_k_vtyBiV9EpnC5-YbvlN0SXPP85vb1GGw&s=cgQbku2DjmNfzRg-2XNQd5IUUnl-5vzyEaRHnPAopcw&e=>,acm.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__acm.org&d=AwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=R4xkdnXhg_k_vtyBiV9EpnC5-YbvlN0SXPP85vb1GGw&s=eX6E5I95y8t27qk4Ww6PFoq8e_2IRg0zL_zlSGMlpP8&e=>} / [email-masked]<mailto:[email-masked]>
Web: https://urldefense.proofpoint.com/v2/url?u=http-3A__ect.bell-2Dlabs.com_who_vkg_&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=IFXVSS1Ngo0C7z51Gunp5gTAVG7hdQAOfiXLLRkPLi4&s=RUjSP5rpFsp8V2Y0xuG9_3pFcAAsDEjzi2YQNNaMKfY&e=   | Calendar: https://urldefense.proofpoint.com/v2/url?u=http-3A__goo.gl_x3Ogq&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=IFXVSS1Ngo0C7z51Gunp5gTAVG7hdQAOfiXLLRkPLi4&s=wY56fXByx0Kd3boQqPHpBjX7uzem5fDJHZAW1FIv_Mc&e=
_______________________________________________
alto mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=IFXVSS1Ngo0C7z51Gunp5gTAVG7hdQAOfiXLLRkPLi4&s=JAiHH7palOiAkB3m6zdiENhShLMINWuIhPrijAeT0iQ&e=

--

BENOCS GmbH

Dipl.-Ing. Hans Seidel

Winterfeldtstr. 21

10781 Berlin

Germany

Email: [email-masked]<mailto:[email-masked]>

www.benocs.com<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.benocs.com&d=AwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=R4xkdnXhg_k_vtyBiV9EpnC5-YbvlN0SXPP85vb1GGw&s=UwI1cKJv4mJuNH6v4DWFB5wK_QM9pl59SliBxc-gtzo&e=>

Board of Management: