Subject: Re: [alto] ALTO implementation interoperability

From: Hans Seidel <[email-masked]>
Date: Thu, 07 May 2015 18:22:25 +0200

Hi all,

I just read the minutes from the last IETF meeting but unfortunately 
there is little about a possible interop at the upcoming meeting in Prague.

I am still very interested in an interop and willing to help making it 
happen. Any news on that?

Cheers,
Hans

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 07 May 2015 16:25:34 -0500

> happen. Any news on that?

Right.  So, what sort of cycles do you (or for that matter any WG
member) have to contribute to the interoperability?

The interoperability test case document [1] has long expired, but
more importantly, is not updated to reflect the RFC (it is based
on an older point version of the protocol).  It is on my list of
things to do to update the document, but I will appreciate any help
in the form of an editor who can update the test cases to
correspond to the RFC, and perhaps add new test cases.

We will need a document to drive the interoperability test, so
it is rather important to get the document in order to have a
meaningful interoperability event.

Let me know if there are any contributors.

The chairs will like to have an interoperability event in the
summer IETF, and based on hallway discussions and list dicussions
during the Dallas IETF, so would the ALTO community in general.
Let's make it happen!

[1] https://tools.ietf.org/html/draft-gurbani-alto-interop-cases-02

Cheers,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: "Y. Richard Yang" <[email-masked]>
Date: Fri, 8 May 2015 16:47:06 -0400

Dear Vijay, Hans,

It is great to get this started. I know a couple good programmers who can
contribute as well. How to coordinate? Can those of us who are interested
send you (as the chair) to get the preparation started?

Thanks!
Richard

On Thu, May 7, 2015 at 5:25 PM, Vijay K. Gurbani <[email-masked]> wrote:

> [1]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dgurbani-2Dalto-2Dinterop-2Dcases-2D02&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=4OjzNgTj5WLQo2Iezq4S2VBYsLfMHaftUqfhhKoYK1I&s=DAjpz_7Is_-o08CuSovcXSQWSJvNY3EJkHf-YAbEgMI&e=
> Cheers,
>
> - vijay
> --
> Web:
> https://urldefense.proofpoint.com/v2/url?u=http-3A__ect.bell-2Dlabs.com_who_vkg_&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=4OjzNgTj5WLQo2Iezq4S2VBYsLfMHaftUqfhhKoYK1I&s=40lLI67SZJRE4LPxGmdgxKDBchcnomMAcLTepH_KwNQ&e=
>  | Calendar:
> https://urldefense.proofpoint.com/v2/url?u=http-3A__goo.gl_x3Ogq&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=4OjzNgTj5WLQo2Iezq4S2VBYsLfMHaftUqfhhKoYK1I&s=w5sbZoNxUu0rPIVw7SMYhhx72u-Ei-xlSsa7WnZu1Co&e=
> _______________________________________________
> alto mailing list
> [email-masked]
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=4OjzNgTj5WLQo2Iezq4S2VBYsLfMHaftUqfhhKoYK1I&s=PzRce5hdROjwtyWnPdcQdzw4UIP91ESY8WgXZ1IQoH0&e=

-- 
-- 
 =====================================
| Y. Richard Yang <[email-masked]>   |
| Professor of Computer Science       |
| http://www.cs.yale.edu/~yry/        |
 =====================================

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 11 May 2015 08:17:41 -0500

On 05/08/2015 03:47 PM, Y. Richard Yang wrote:
> Dear Vijay, Hans,
>
> It is great to get this started. I know a couple good programmers who
> can contribute as well. How to coordinate? Can those of us who are
> interested send you (as the chair) to get the preparation started?

Richard: Yes, that will be a good way to move ahead.

If someone else is interested in assuming the editor role for the
interoperability document [1], then that is always good.  If no one
else does, I will continue to edit it with the input I receive from
the WG.

So, yes, please go ahead and send me the test cases you think reflect
the current use of the protocol with an eye towards the normative
language in the ALTO RFC that we are interoperating on.

Cheers,

- vijay

---

From: 郭华明 <[email-masked]>
Date: Tue, 12 May 2015 08:41:19 +0800 (GMT+08:00)

Dear Vijay, Richard,

I am interested in this work. I will bring the test cases soon.

> -----原始邮件-----
> 发件人: "Vijay K. Gurbani" <[email-masked]>
> 发送时间: 2015-05-11 21:17:41 (星期一)
> 收件人: "Y. Richard Yang" <[email-masked]>
> 抄送: "IETF ALTO" <[email-masked]>
> 主题: Re: [alto] ALTO implementation interoperability
> 
> https://www.ietf.org/mailman/listinfo/alto

--
----------------
Best!

Huaming Guo

China Academy of Information and Communications Technology (CAICT)

No.36 A Nanlishi Road, Xicheng District, Beijing 100037, China

---

From: Hans Seidel <[email-masked]>
Date: Tue, 12 May 2015 08:46:20 +0200

Dear Vijay, Richard,

> else does, I will continue to edit it with the input I receive from

I can help you with that. However, I need to familiarize myself with the 
procedures. Some guidance/links how to start writing an IETF document is 
highly appreciated.

Cheers
Hans

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 12 May 2015 11:00:02 -0500

> procedures. Some guidance/links how to start writing an IETF document is

Hans: Excellent.  I have also reached out to Wendy Roome
<[email-masked]>, and she is willing to edit the document.
It is not uncommon for documents to have more than one editor, so if
you have the cycles and can contribute to the document, you can assume
the editor role in addition to Wendy.

The XML document for the draft is available at the IETF tools site,
so y'all can start off with that.

Let me know how I (and Jan) can help.

Cheers,

- vijay

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 12 May 2015 11:01:35 -0500

> I am interested in this work. I will bring the test cases soon.

Excellent.  Please coordinate with the editors of the document with
regard to bringing new test cases.

Thanks for your time on this!

Cheers,

- vijay

---

From: Huaming Guo郭华明 <[email-masked]>
Date: Wed, 13 May 2015 04:49:42 +0800 (GMT+08:00)

Hi Wendy, all,

I think we can first go through a list of all test cases, then we complete all details. 
I post the list below. The cases with * are added or updated by me. I also like to  
serve an editor, if possible.

1. Information Resource Directory
 1.1 Test-IRD-1:  The Information Resource Directory (IRD) enumerates URIs
      at which an ALTO server offers Information Resources.      
 *1.2 Test-IRD-2 ALTO server delegate IRD to a subdomain.

2. Map Service
 2.1 Test-MAPS-1:   An ALTO client retrieves a complete network map.
 2.2 Test-MAPS-2:   An ALTO client retrieves a complete cost map for the
      numerical cost mode.
 2.3 Test-MAPS-3:   An ALTO client retrieves a complete cost map for the
      ordinal cost mode.
 2.4 Test-MAPS-4:   This test is designed to detect a change in the
      network map.

3. Map-Filtering Service
 *3.1 Test-FILTER-1:   An ALTO client sends a request to get a filtered network map
      of PID mypid2.
 *3.2 Test-FILTER-2:   An ALTO client sends a request to get a filtered cost map
      from a source PID to a set of destination PIDs.
 *3.3 Test-FILTER-3:   An ALTO client requests the cost map subject to
      certain constraints.

4. Endpoint Property Service
 4.1 Test-EPS-1:   An ALTO client retrieves a PID for IPv4 address
      192.168.1.23.
 4.2 Test-EPS-2:   An ALTO client retrieves a PID for IPv4 address
      192.168.10.23.
 4.3 Test-EPS-3:   An ALTO client retrieves a PID for IPv4 address
      201.1.13.12.
 4.4 Test-EPS-4:   An ALTO client retrieves a PID for an IPv4 and IPv6
      address.
 *4.5 Test-EPS-5: An ALTO client retrieves a Private Endpoint Property for an IPv4
      address.
 
5. Endpoint Cost Service
 5.1 Test-ECS-1:   An ALTO client requests cost information between
      individual endpoints.
 5.2 Test-ECS-2:   An ALTO client requests the ranking service for a
      source host to a set of destination hosts.
 5.3 Test-ECS-3:   An ALTO client requests the cost service subject to
      certain constraints.

6. Protocol Errors
 *6.1 Test-ERR-1:   An ALTO client sends a malformed JSON body in the
      request --- a missing closing brace ('}'). (E_SYNTAX)
 *6.2 Test-ERR-2:   An ALTO client sends a malformed request --- the
      "dsts" member for the endpoint cost service is missing. (E_MISSING_FIELD)
 *6.3 Test-ERR-3:   An ALTO client sends a request with an unexpected
      type for a JSON value. (E_INVAILD_FIELD_TYPE)
 *6.4 Test-ERR-4:   An ALTO client sends a request with a wrong value for
      a correct field. (E_INVAILD_FIELD_VALUE)
 *6.5 Test-ERR-5:   An ALTO client sends a request with multiple
      errors.  

> 发送时间: 2015-05-13 00:01:35 (星期三)
> 收件人: "郭华明" <[email-masked]>
> 抄送: "Y. Richard Yang" <[email-masked]>, "IETF ALTO" <[email-masked]>

--
----------------
Best!

Huaming Guo

---

From: "Y. Richard Yang" <[email-masked]>
Date: Thu, 14 May 2015 16:29:12 -0400

A good starting point. I added the alto-dev mailing list on opendaylight.
The team there has test cases to test the correctness of their alto server
in ODL.

Richard

On Tuesday, May 12, 2015, Huaming Guo郭华明 <[email-masked]> wrote:

> > 发件人: "Vijay K. Gurbani" <[email-masked] <javascript:;>>
>
> > 收件人: "郭华明" <[email-masked] <javascript:;>>
>
> > 抄送: "Y. Richard Yang" <[email-masked] <javascript:;>>, "IETF ALTO" <
> [email-masked] <javascript:;>>
>
> <javascript:;>
> https://urldefense.proofpoint.com/v2/url?u=http-3A__ect.bell-2Dlabs.com_who_vkg_&d=AwIGaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=6h5yxyhxHTpCCwoZgmUqgGPoEl0VjBvG-QUM7wa8LTc&s=DkqHFvN8f463jbMtPlk51Ik2KCYpj3GA5ijiYZrxPXk&e=
>  | Calendar:
> https://urldefense.proofpoint.com/v2/url?u=http-3A__goo.gl_x3Ogq&d=AwIGaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=6h5yxyhxHTpCCwoZgmUqgGPoEl0VjBvG-QUM7wa8LTc&s=w302JfJ6Hg8_t-g1qcHO9XrAdCmuiD00QoI_kIn3M-M&e=
>
>
>
>
>
> --
>
> ----------------
>
> Best!
>
>
>
>
>
>
>
>
>
> Huaming Guo
>
>
>
>
>

-- 
Richard