Subject: Re: [alto] FW: I-D Action: draft-ietf-alto-cost-calendar-01.txt

From: Qin Wu <[email-masked]>
Date: Thu, 30 Mar 2017 02:17:41 +0000

Hi, Sabine:
Availbandwidth cost metric described in draft-ietf-alto-cost-calendar-01 is defined in ALTO performance metric draft as link specific metric, if you want to use it as aggregated metric,
peformance measurement draft needs to updated to support this path bandwidth metric.

Secondly delay cost metric described in draft-ietf-alto-cost-calendar is defined in ALTO performance metric draft and has been separated into one way delay and round trip delay.Therefore
two drafts need to better aligned about these attributes.

-Qin____________________________________
发件人: alto [[email-masked]] 代表 Randriamasy, Sabine (Nokia - FR) [[email-masked]]
发送时间: 2017年2月14日 2:45
收件人: IETF ALTO
主题: [alto] FW:  I-D Action: draft-ietf-alto-cost-calendar-01.txt

Hello,

"draft-ietf-ALTO-cost-calendar-01", that updates the "ALTO Cost Calendar presented in Berlin has just been posted. The updates include:
- clean-up,
- corrections on the multi-cost example for RFC7285 compatibility,
- updates in the text according to the simplified IRD format in the version of last July 2016

No modifications were done on the design posted at IETF96-Berlin.
No updates were done on sections 1 and 5 and some sections like 4.3 may be removed.

The WG feedback is more than welcome on this draft.

Best regards,
Sabine

>>-----Original Message-----
>>From: alto [mailto:[email-masked]] On Behalf Of internet-
>>[email-masked]
>>Sent: lundi 13 février 2017 19:34
>>To: [email-masked]
>>Cc: [email-masked]
>>Subject: [alto] I-D Action: draft-ietf-alto-cost-calendar-01.txt
>>
>>
>>A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>This draft is a work item of the Application-Layer Traffic Optimization of the
>>IETF.
>>
>>        Title           : ALTO Cost Calendar
>>        Authors         : Sabine Randriamasy
>>                          Richard Yang
>>                          Qin Wu
>>                          Lingli Deng
>>                          Nico Schwan
>>      Filename        : draft-ietf-alto-cost-calendar-01.txt
>>      Pages           : 29
>>      Date            : 2017-02-13
>>
>>Abstract:
>>   The goal of Application-Layer Traffic Optimization (ALTO) is to
>>   bridge the gap between network and applications by provisioning
>>   network related information in order to allow applications to make
>>   network informed decisions.  The present draft extends the ALTO cost
>>   information so as to broaden the decision possibilities of
>>   applications to not only decide 'where' to connect to, but also
>>   'when'.  This is useful to applications that need to schedule their
>>   data transfers and connections and have a degree of freedom to do so.
>>   ALTO guidance to schedule application traffic can also efficiently
>>   help for load balancing and resources efficiency.  Besides, the ALTO
>>   Cost Calendar allows to schedule the ALTO requests themselves and
>>   thus to save a number of ALTO transactions.
>>
>>   This draft proposes new capabilities and attributes on filtered cost
>>   maps and endpoint costs enabling an ALTO Server to provide "Cost
>>   Calendars".  These capabilities are applicable to time-sensitive ALTO
>>   metrics.  With ALTO Cost Calendars, an ALTO Server exposes ALTO Cost
>>   Values in JSON arrays where each value corresponds to a given time
>>   interval.  The time intervals as well as other Calendar attributes
>>   are specified in the IRD and ALTO Server responses.
>>
>>
>>
>>The IETF datatracker status page for this draft is:
>>https://datatracker.ietf.org/doc/draft-ietf-alto-cost-calendar/
>>
>>There's also a htmlized version available at:
>>https://tools.ietf.org/html/draft-ietf-alto-cost-calendar-01
>>
>>A diff from the previous version is available at:
>>https://www.ietf.org/rfcdiff?url2=draft-ietf-alto-cost-calendar-01
>>
>>
>>Please note that it may take a couple of minutes from the time of submission
>>until the htmlized version and diff are available at tools.ietf.org.
>>
>>Internet-Drafts are also available by anonymous FTP at:
>>ftp://ftp.ietf.org/internet-drafts/
>>
>>_______________________________________________
>>alto mailing list
>>[email-masked]
>>https://www.ietf.org/mailman/listinfo/alto

_______________________________________________
alto mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/alto

---

From: "Randriamasy, Sabine (Nokia - FR/Nozay)" <[email-masked]>
Date: Thu, 30 Mar 2017 15:35:20 +0000

Hi Qin,

Thanks for this comment. Indeed, the metrics need to be aligned. For the moment, the Calendar draft refers to path metrics. We will see how to extend it to link metrics in the next version. 
Thanks,
Sabine

>>From: alto [mailto:[email-masked]] On Behalf Of Qin Wu
>>Sent: 30 March 2017 04:18
>>To: Randriamasy, Sabine (Nokia - FR/Nozay) <sabine.randriamasy@nokia-
>>bell-labs.com>; IETF ALTO <[email-masked]>
>>Subject: Re: [alto] FW: I-D Action: draft-ietf-alto-cost-calendar-01.txt
>>
>>Hi, Sabine:
>>Availbandwidth cost metric described in draft-ietf-alto-cost-calendar-01 is
>>defined in ALTO performance metric draft as link specific metric, if you want
>>to use it as aggregated metric, peformance measurement draft needs to
>>updated to support this path bandwidth metric.
>>
>>Secondly delay cost metric described in draft-ietf-alto-cost-calendar is
>>defined in ALTO performance metric draft and has been separated into one
>>way delay and round trip delay.Therefore two drafts need to better aligned
>>about these attributes.
>>
>>"draft-ietf-ALTO-cost-calendar-01", that updates the "ALTO Cost Calendar
>>presented in Berlin has just been posted. The updates include:
>>- clean-up,
>>>>This draft is a work item of the Application-Layer Traffic
>>>>Optimization of the IETF.
>>>>
>>>>Please note that it may take a couple of minutes from the time of
>>>>submission until the htmlized version and diff are available at
>>tools.ietf.org.
>>>>