Subject: [alto] Introducing costs for wireless networks

From: "Randriamasy, Sabine (Nokia - FR)" <[email-masked]>
Date: Fri, 10 Mar 2017 13:30:07 +0000

Hi all,

Any thoughts in the WG on the following?
Thanks,
Sabine

Pursuant to previous ALTO work on wireless networks and relating to the WG item on ALTO metrics, there are a number of abstracted metrics reporting on cellular and wireless networks worth considering. For instance, applications on UEs may like to know about the connection costs associated to the cells it is likely to connect to. These costs may for instance be impacted by the cell load, see section 2.1 of [draft-randriamasy-alto-cost-context].

Using cellular costs requires introducing a new address type and a new identifier namespace for cells. Based on 3GPP standards, we may opt for the name space "ECGI" and the related address format as suggested in section 4 of [draft-rauschenbach-alto-wireless-access] that also proposes that to map cells to PIDs covering cell IDs.

Cellular connection costs (CCC for short) can be conveyed by for instance the (Filtered) Cost Map (FCM) service or an extension of the Endpoint Property (EPS) that could be added to [draft-roome-alto-unified-props].

A PID in a Network Map can cover a cell with an address from the address space "ECGI". A PID thus hides the underlying technical aspects. The CCC in a F/CM between a UE and a cell/PID can be encoded in the bi-directional, uplink and downlink directions, within or across PIDs.  A UE can retrieve its "serving PID" via the Endpoint Property "PID" applied to its service cell ID.

---

From: Yichen Qian <[email-masked]>
Date: Mon, 13 Mar 2017 02:40:53 +0800

Hi Sabine,

It is interesting to have such extensions to wireless network. I think wireless network is not so stable as wired network. Many factors can influence the cost between a UE and a connection node (such as channels). So it may be difficult to get the accurate cost. Also a UE may have a lot of moments in wireless network which makes it more difficult to get the accurate cost. Is there some ways to solve the problem?

Thanks,
Yichen

> On Mar 10, 2017, at 9:30 PM, Randriamasy, Sabine (Nokia - FR) <[email-masked]> wrote:
> 
> Hi all,
>  
> A PID in a Network Map can cover a cell with an address from the address space "ECGI". A PID thus hides the underlying technical aspects. The CCC in a F/CM between a UE and a cell/PID can be encoded in the bi-directional, uplink and downlink directions, within or across PIDs.  A UE can retrieve its “serving PID” via the Endpoint Property "PID" applied to its service cell ID.  
>  
> _______________________________________________
> alto mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/alto <https://www.ietf.org/mailman/listinfo/alto>

---

From: "Y. Richard Yang" <[email-masked]>
Date: Sun, 12 Mar 2017 23:25:47 -0400

Sabine,

Very interesting direction. As wireless is already a main and future
direction of settings of networking access, it makes sense to better
support the settings.

Adding support, for example, a new address space, makes sense.

One issue to elaborate more is use cases. A first use case coming to mind
is access network selection. Do we do the design in an existing network
setting (LTE), or target a more emerging network (e.g., in the context of
5G)?

We have quite some wireless expertise from some members in the group, at
least from the past. It will be interesting to hear their feedback.

Richard

On Sun, Mar 12, 2017 at 2:40 PM, Yichen Qian <[email-masked]>
wrote:

> Hi Sabine,
>
> It is interesting to have such extensions to wireless network. I think
> wireless network is not so stable as wired network. Many factors can
> influence the cost between a UE and a connection node (such as channels).
> So it may be difficult to get the accurate cost. Also a UE may have a lot
> of moments in wireless network which makes it more difficult to get the
> accurate cost. Is there some ways to solve the problem?
>
> Thanks,
> Yichen
>
>
> On Mar 10, 2017, at 9:30 PM, Randriamasy, Sabine (Nokia - FR) <
> [email-masked]> wrote:
>
> Hi all,
>
> Pursuant to previous ALTO work on wireless networks and relating to the WG
> item on ALTO metrics, there are a number of abstracted metrics reporting on
> cellular and wireless networks worth considering. For instance,
> applications on UEs may like to know about the connection costs associated
> to the cells it is likely to connect to. These costs may for instance be
> impacted by the cell load, see section 2.1 of [draft-randriamasy-alto-cost-
> context].
>
> Using cellular costs requires introducing a new address type and a new
> identifier namespace for cells. Based on 3GPP standards, we may opt for the
> name space "ECGI" and the related address format as suggested in section 4
> of [draft-rauschenbach-alto-wireless-access] that also proposes that to
> map cells to PIDs covering cell IDs.
>
> Cellular connection costs (CCC for short) can be conveyed by for instance
> the (Filtered) Cost Map (FCM) service or an extension of the Endpoint
> Property (EPS) that could be added to [draft-roome-alto-unified-props].
>
> A PID in a Network Map can cover a cell with an address from the address
> space "ECGI". A PID thus hides the underlying technical aspects. The CCC in
> a F/CM between a UE and a cell/PID can be encoded in the bi-directional,
> uplink and downlink directions, within or across PIDs.  A UE can retrieve
> its “serving PID” via the Endpoint Property "PID" applied to its service
> cell ID.
>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>
>
>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>
>

-- 
-- 
 =====================================
| Y. Richard Yang <[email-masked]>   |
| Professor of Computer Science       |
| http://www.cs.yale.edu/~yry/        |
 =====================================

---

From: Qin Wu <[email-masked]>
Date: Mon, 13 Mar 2017 07:06:32 +0000

Hi, Sabine:
Interesting topic, I think if this Cellular connection cost is needed? It should go to ALTO performance metric draft, right?
I also believe Cost value context is very valuable since it allows expose several value for a single metric. But this cost value context is technology specific?
Or you want to have a generic schme for cost value context?
In addition, I want to know whether Celluar costs is used to measure cell congestion or cell load? How do you measure it in the wireless networks? Is there any 3GPP specification we can reference?

-Qin
发件人: alto [mailto:[email-masked]] 代表 Randriamasy, Sabine (Nokia - FR)
发送时间: 2017年3月10日 21:30
收件人: IETF ALTO
主题: [alto] Introducing costs for wireless networks

Hi all,

---

From: "Randriamasy, Sabine (Nokia - FR)" <[email-masked]>
Date: Mon, 13 Mar 2017 14:53:33 +0000

Hi Yichen, Richard and Geng,

Thanks a lot for your responses. Please see my answer to your respective e-mails inline,

Thanks,
Sabine

From: Li, Geng [mailto:[email-masked]]
Sent: lundi 13 mars 2017 07:33
To: Y. Richard Yang <[email-masked]>
Cc: Randriamasy, Sabine (Nokia - FR) [email-masked]<mailto:[email-masked]>
Subject: Re: [alto] Introducing costs for wireless networks

Hi Sabine,

[SR     ] Hi Geng,

I'm a new postdoc working with Prof. Yang, and I was majored in wireless communication, LTE mostly, during my PhD career. I quite like your idea, and it happens to be related to my last research interest - user association problem, which needs jointly considering both the radio link quality and load balancing among different stations, especially in the heterogeneous network, where different cells are overlapping and have different capacity.

Your idea of the connection cost is even better for reasons.

1) The value of cost can not only reflect the load condition, and it can be a combination of many other issues, like backhaul, number of hops...

[SR     ] Indeed, ALTO Cost metrics for cellular networks may abstract several and composite considerations

2) Corresponding to "cost", a UE can have the connection "payoff", which is a good abstraction for QoS-related stuff or the term of fairness for users.

[SR     ] Agree,

3) Many fancy tools can help about the optimization, like game theory, economics theory...

The main concern from me is about the quantization of this cost. It should be about both the absolute and relative cost of the connection. The coordination between cells to calculate a uniform value of cost is quite a challenge. Of course, the X2 interface can be used, but we still need to explain what information is needed and how to carry the information properly between cells.

[SR     ] ALTO metrics are meant to convey performances or costs derived from various measurements and they may possibly involve non-measured quantities related to e.g. QoS policy as you mentioned. The important point is to specify what cost and/or performance they report on and how the ALTO Client should interpret and use these values. Information on how ALTO metrics values are inferred should be provided whenever possible.

Defining and incrementing the set of supported  ALTO wireless metrics will be a next step upon WG proposals

But anyway, your idea totally makes sense to me.

[SR     ] looking forward to your ideas.

Best, Geng

[SR     ] best regards,

Sabine

________________________________
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>> on behalf of Y. Richard Yang <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, March 12, 2017 8:25:47 PM
To: Yichen Qian; Li, Geng
Cc: Randriamasy, Sabine (Nokia - FR); IETF ALTO
Subject: Re: [alto] Introducing costs for wireless networks

Sabine,
[SR     ] Hi Richard,

Very interesting direction. As wireless is already a main and future direction of settings of networking access, it makes sense to better support the settings.

One issue to elaborate more is use cases. A first use case coming to mind is access network selection. Do we do the design in an existing network setting (LTE), or target a more emerging network (e.g., in the context of 5G)?
[SR     ] I'd say both. They are already useful for LTE network and definitely, 5G networks will require additional work.  As for use cases, two are proposed in draft-randriamasy-alto-cost-context for which I will post an update in the next hours.

We have quite some wireless expertise from some members in the group, at least from the past. It will be interesting to hear their feedback.
[SR     ] I am definitely looking forward to having their feedback.

Richard
[SR     ] thanks,
Sabine

On Sun, Mar 12, 2017 at 2:40 PM, Yichen Qian <[email-masked]<mailto:[email-masked]>> wrote:
Hi Sabine,
[SR     ] Hi Yichen,

It is interesting to have such extensions to wireless network. I think wireless network is not so stable as wired network. Many factors can influence the cost between a UE and a connection node (such as channels). So it may be difficult to get the accurate cost. Also a UE may have a lot of moments in wireless network which makes it more difficult to get the accurate cost. Is there some ways to solve the problem?
[SR     ] I make a very good point here. Cost and user dynamics are much higher in wireless networks. The cellular ALTO metrics are not meant to convey real time information but will cover periods of, say couple of minutes or couple of tens of seconds.  They are meant to guide applications that either make delay tolerant decisions or involve non real time information in their decisions. Besides ALTO thus avoids causing traffic oscillations. To cope with frequent updates, an ALTO Server may either cover a very local network area and/or provide in one response a Calendar of different time-dependent cost values.

Thanks,
Yichen
[SR     ] thanks, Sabine

On Mar 10, 2017, at 9:30 PM, Randriamasy, Sabine (Nokia - FR) <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

_______________________________________________
alto mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/alto<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=DwMFaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=ZKBxqyaKJSFY02EayfSIJqlr2JdBP9wTGW2rF4ftCFM&m=7LZiFJkWcpA8f9wAESQFdF5_f7dnVFBieZW8tzPIJgY&s=SDy9anNl9PT84kKjIgp3-s3r7-sx8VhbTcL00h4kmRg&e=>

_______________________________________________
alto mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/alto<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=DwMFaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=ZKBxqyaKJSFY02EayfSIJqlr2JdBP9wTGW2rF4ftCFM&m=7LZiFJkWcpA8f9wAESQFdF5_f7dnVFBieZW8tzPIJgY&s=SDy9anNl9PT84kKjIgp3-s3r7-sx8VhbTcL00h4kmRg&e=>

--
--
 =====================================
| Y. Richard Yang <[email-masked]<mailto:[email-masked]>>   |
| Professor of Computer Science       |
| http://www.cs.yale.edu/~yry/        |
 =====================================

---

From: "Randriamasy, Sabine (Nokia - FR)" <[email-masked]>
Date: Mon, 13 Mar 2017 15:11:34 +0000

Hi Qin,

Thanks for your answer, please see inline,
Sabine

From: Qin Wu [mailto:[email-masked]]
Sent: lundi 13 mars 2017 08:07
To: Randriamasy, Sabine (Nokia - FR) <[email-masked]>; IETF ALTO <[email-masked]>
Subject: RE: Introducing costs for wireless networks

Hi, Sabine:
Interesting topic, I think if this Cellular connection cost is needed? It should go to ALTO performance metric draft, right?
[SR     ] Yes, this would be a preferred placeholder.
I also believe Cost value context is very valuable since it allows expose several value for a single metric. But this cost value context is technology specific?
[SR     ] Indeed, the utilized cost value context parameter is specific to the context in which the cost value is used. For instance:  “uda”, “udna” is specific to LTE networks; “uplink”, “downlink” may apply to different technologies such as cellular, wifi and fixed.
Or you want to have a generic schme for cost value context?
[SR     ] yes, a generic scheme is specified in [draft-randriamasy-alto-cost-context] to use context parameters in conjunction with costs. This scheme applies to any technology that would need it. The current draft proposes use cases for wireless networks but is not restricted to.  Other use cases are more than welcome.
In addition, I want to know whether Celluar costs is used to measure cell congestion or cell load?
[SR     ] there can be several metrics for cellular networks, including cell congestion, cell load and others. Again any proposal is welcome.
How do you measure it in the wireless networks? Is there any 3GPP specification we can reference?
[SR     ] it depends on the metrics. The metric values may be inferred from aggregated measurements but not only. They may also involve non-measured ingredients reflecting e.g. policy, may be unitless or not.

-Qin

Hi all,