Subject: [alto] PANRG Lightning Talk at IETF100 on ALTO

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Mon, 4 Dec 2017 15:32:35 +0000

Hello ALTO WG,

At the last IETF, there was a PANRG session during which, as they have shown interest in the ALTO work, I gave a lightning talk on ALTO and its relevant extensions, see slides at https://datatracker.ietf.org/meeting/100/materials/slides-100-panrg-04-the-ietf-alto-protocol-and-its-extensions/

The goal of PANRG is to extend path awareness from the control plane to the edge with mechanisms allowing: Endpoint discovery of paths, explicit association of properties to paths by endpoints, explicit endpoint selection of paths. The identified underlying hard problems are mainly: conflict of interest between hosts and networks, path property exposition by the network to third parties considering network confidentiality and information aggregation level, diversity of timescale for configuration, discovery, selection and dissemination. The PANRG would like to leverage its work on existing IETF protocols and their potential extensions.

The last presentation was upon a draft by Brian Trammel, one of the RG chairs, to open the discussions.
See the slides at https://datatracker.ietf.org/meeting/100/materials/slides-100-panrg-06-open-questions/
Regarding question "how do endpoints discover trustworthy path properties?", the slides mention that SCION (a path-aware Internet architecture presented at IETF99) and ALTO represent points in this design space.

The other presentations are on https://datatracker.ietf.org/meeting/100/session/panrg

I think it is worth getting in touch with this RG to see how ALTO can serve their goals. As they focus on the mechanisms leveraging on protocols rather than on protocols themselves, they may expose use cases motivating existing and future protocol extensions and defining needs for particular features.

Cheers,
Sabine

---

From: Jensen Zhang <[email-masked]>
Date: Mon, 04 Dec 2017 16:40:08 +0000

Hi Sabine,

I also agree that we need to get in touch with PANRG. And really thanks for
your effort in introducing ALTO to PANRG and introducing PANRG to our WG!

I just talk about some of my thinking. "how do endpoints discover
trustworthy path properties?" can also be a basic question for ALTO. In my
opinion, this question should cover three pieces:

- Representation (which is like "How to connect" in your lightning talk
slides)
- Storage (which includes "When to connect" in your slides. Currently,
alto-calendar is about it)
- Requirements (rsa, fcs and incr-update-sse are related to it)

I think a lot of previous efforts of ALTO WG focused on the first topic.
But for the goal of PANRG and the future potential use cases, I think
providing the on-demand network information will be more helpful. So maybe
"how to define application requirements" is more important. The legacy ALTO
approach can only support the simple cross-product filter requirement. To
satisfy more requirements, we still need to make more efforts.

btw. Shall we involve some people from PANRG into our coming interim
meeting?

Best,
Jensen

On Mon, Dec 4, 2017 at 11:32 PM Randriamasy, Sabine (Nokia -
FR/Paris-Saclay) <[email-masked]> wrote:

> Hello ALTO WG,
>
>
>
> At the last IETF, there was a PANRG session during which, as they have
> shown interest in the ALTO work, I gave a lightning talk on ALTO and its
> relevant extensions, see slides at
> https://datatracker.ietf.org/meeting/100/materials/slides-100-panrg-04-the-ietf-alto-protocol-and-its-extensions/
>
>
>
> The goal of PANRG is to extend path awareness from the control plane to
> the edge with mechanisms allowing: Endpoint discovery of paths, explicit
> association of properties to paths by endpoints, explicit endpoint
> selection of paths. The identified underlying hard problems are mainly:
> conflict of interest between hosts and networks, path property exposition
> by the network to third parties considering network confidentiality and
> information aggregation level, diversity of timescale for configuration,
> discovery, selection and dissemination. The PANRG would like to leverage
> its work on existing IETF protocols and their potential extensions.
>
>
>
> See the slides at
> https://datatracker.ietf.org/meeting/100/materials/slides-100-panrg-06-open-questions/
>
>
> Regarding question "how do endpoints discover trustworthy path
> properties?", the slides mention that SCION (a path-aware Internet
> architecture presented at IETF99) and ALTO represent points in this design
> space.
>
>
>
> The other presentations are on
> https://datatracker.ietf.org/meeting/100/session/panrg
>
>
>
> I think it is worth getting in touch with this RG to see how ALTO can
> serve their goals. As they focus on the mechanisms leveraging on protocols
> rather than on protocols themselves, they may expose use cases motivating
> existing and future protocol extensions and defining needs for particular
> features.
>
>
>
> Cheers,
>
> Sabine
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>