Subject: Re: [alto] Review of draft-randriamasy-alto-cellular-adresses-00

From: "Li, Geng" <[email-masked]>
Date: Tue, 5 Dec 2017 21:19:18 +0000

Hi Yichen, Sabine and ALTO working group,

With regard to the review from Yichen, I have the following comments.

First, the leading zeros issue is fine. Even in the LTE standard, leading zeros are allowed. MNC, assigned by National Authority can be either 2 or 3 digits. If the 2-digit MNC is used, then the PLMN will be like: 262-20; for 3-digit MNC, PLMN is like: 262-020. The example in 3.2 is not clear, because the contries can not be identified only by MNC.

Second, 7-digit eCI is mandatory, including 20-bit eNB and 8-bit CI. There must be some typos in the examples with 6-digit eCI.

Third, 1234800/18 definitely matches anything starts with 12348, so the example in 3.4 isn’t quite right.

At last, I suggest authors to revise the expression of ecgi, which is likely to be confused with the standard ECGI. A-ECGI may be an option denoting ALTO-ECGI.

Best, Geng

________________________________
From: alto <[email-masked]> on behalf of Yichen Qian <[email-masked]>
Sent: Thursday, November 30, 2017 9:33 PM
To: Sabine Randriamasy; IETF ALTO
Subject: [alto] Review of draft-randriamasy-alto-cellular-adresses-00

Hi Sabine and ALTO working group,

I just reviewed draft-randriamasy-alto-cellular-adresses-00 and below are my comments. Most of them are about the examples given in the draft.

At the begin of section 3, 'The predent draft proposed …' -> 'The present draft proposed …'.

In section 3.2, MNC is defined as a 2-3 digits decimal number without leading zeros. It’s not consistent with the example below 'MNC value 020 stands for Network N2 …'.

Section 3.2 also mentions that ECI is a 7 digits lower-case hex number. While in the third example of section 3.4, 'ecgi:311.481:123480' and 'ecgi:311.481:12348d' only have 6 digits for ECI.

Another confusion in the third example of section 3.4 is that I think 'ecgi:311.481:12348d' also matches the ECI that starts with the 18 bits 0x12348.

Your feedback is highly appreciated.

Best regards,
Yichen
_______________________________________________
alto mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=DwIGaQ&c=cjytLXgP8ixuoHflwc-poQ&r=3ppf8OzwgH8IB2n9Mbvv-tBNOn3nDVEXFDz9Os8K_hU&m=P1m4HESvDP9kwgBTX4_zIKAKEFPnelp79GuPLRG1dJY&s=kIes3TABsgnUM0AyBeiJNxyn0Nc25fi9C0GUEBIXk4M&e=

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Fri, 15 Dec 2017 19:49:09 +0000

Hi Yichen and Geng,

Thanks a lot for your feedback on ALTO cellular address formats. Indeed some corrections and clarifications are needed for the next version. Please see inline.
Thanks,

Sabine

From: Li, Geng [mailto:[email-masked]]
Sent: Tuesday, December 05, 2017 10:19 PM
To: Yichen Qian <[email-masked]>; Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]>; IETF ALTO <[email-masked]>
Subject: Re: [alto] Review of draft-randriamasy-alto-cellular-adresses-00

First, the leading zeros issue is fine. Even in the LTE standard, leading zeros are allowed. MNC, assigned by National Authority can be either 2 or 3 digits. If the 2-digit MNC is used, then the PLMN will be like: 262-20; for 3-digit MNC, PLMN is like: 262-020.

[[SR]]  Then I suggest: MCC will be without leading zeros and MNC with or without, for example if padding zeros are needed for one digit MNCs.

If we adopt "AECGI" as suggested below, we may force 3 digits for an MNC with padding zeros if it makes parsing easier. Any thoughts?

The example in 3.2 is not clear, because the contries can not be identified only by MNC.

[[SR]]  the examples do not mean that and are indeed confusing, so will be changed.

[[SR]] yes it is a typo

Third, 1234800/18 definitely matches anything starts with 12348, so the example in 3.4 isn't quite right.

[[SR]] indeed, the example values  will be corrected

[[SR]] yes, why not ? Any thoughts on the list ?

Best, Geng

From: alto <[email-masked]<mailto:[email-masked]>> on behalf of Yichen Qian <[email-masked]<mailto:[email-masked]>>

At the begin of section 3, 'The predent draft proposed ...' -> 'The present draft proposed ...'.

In section 3.2, MNC is defined as a 2-3 digits decimal number without leading zeros. It's not consistent with the example below 'MNC value 020 stands for Network N2 ...'.

Best regards,
Yichen
_______________________________________________
alto mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=DwIGaQ&c=cjytLXgP8ixuoHflwc-poQ&r=3ppf8OzwgH8IB2n9Mbvv-tBNOn3nDVEXFDz9Os8K_hU&m=P1m4HESvDP9kwgBTX4_zIKAKEFPnelp79GuPLRG1dJY&s=kIes3TABsgnUM0AyBeiJNxyn0Nc25fi9C0GUEBIXk4M&e=

---

From: "Li, Geng" <[email-masked]>
Date: Sat, 16 Dec 2017 22:25:04 +0000

Hi Sabine,

Thanks for the reply.

Just checked the new version. I think that 3 digits can be forced for an MNC with padding zeros in the ALTO address, clear and standard. Also, AECGI is a good idea, but keeping ecgi is fine as well.

Best, Geng

________________________________
From: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]>
Sent: Friday, December 15, 2017 2:49:09 PM
To: Li, Geng; Yichen Qian; IETF ALTO
Subject: RE: [alto] Review of draft-randriamasy-alto-cellular-adresses-00

Hi Yichen and Geng,

Thanks,

Sabine

If we adopt “AECGI” as suggested below, we may force 3 digits for an MNC with padding zeros if it makes parsing easier. Any thoughts?

[[SR]] yes it is a typo

Best, Geng

Best regards,
Yichen