Subject: [alto] I-D Action: draft-ietf-alto-unified-props-new-03.txt

From: [email-masked]
Date: Mon, 05 Mar 2018 09:36:10 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Application-Layer Traffic Optimization WG of the IETF.

        Title           : Unified Properties for the ALTO Protocol
        Authors         : Wendy Roome
                          Shiwei Dawn Chen
                          Sabine Randriamasy
                          Y. Richard Yang
                          Jingxuan Jensen Zhang
	Filename        : draft-ietf-alto-unified-props-new-03.txt
	Pages           : 27
	Date            : 2018-03-05

Abstract:
   This document extends the Application-Layer Traffic Optimization
   (ALTO) Protocol [RFC7285] by generalizing the concept of "endpoint
   properties" to other entity domains, and by presenting those
   properties as maps, similar to the network and cost maps in ALTO.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-alto-unified-props-new/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-alto-unified-props-new-03
https://datatracker.ietf.org/doc/html/draft-ietf-alto-unified-props-new-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-alto-unified-props-new-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Jan Seedorf <[email-masked]>
Date: Thu, 15 Mar 2018 23:27:31 +0100

Authors,

can you please update the WG regarding the following:

> I am taking a look again at the possibility of integrating cellular 
> into UP quickly. An alternative is that we get it done shortly, in the 
> next couple days.
>
> If this is the approach, Sabine is a great person to work together. 
> Make sense, Sabine?
So, has this been done for UP-03, or are we moving UP and path vector 
ahead and will add cellular addresses later on?

  - Jan

On 05.03.18 18:36, [email-masked] wrote:
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Fri, 16 Mar 2018 14:12:12 +0000

Hi Jan,

The current option is to keep the cellular addresses in a separate draft. Upon discussion among its authors, the UP draft focuses on the introduction of a new service information resource which is the (Filtered) Property Map service, applied to "entities" that extend from Endpoints to PIDs, ANEs, Cells and other potential entities. So the UP draft would provide the framework to convey Property Maps and introduce new Entities.
 
The definition of specific entities such as cells and ANEs are respectively located in the "ALTO Cellular Addresses" and "Path Vector" drafts. 
The impact of cellular addresses and the UP draft is that cells are both entities and endpoints, and this has raised the need to further harmonize the usage of ALTO Address Type and ALTO Domain Type registries. Specifications in this direction have been added in section if the UP draft section on IANA considerations.

Hope this answers your question,
Sabine

-----Original Message-----
From: alto [mailto:[email-masked]] On Behalf Of Jan Seedorf
Sent: Thursday, March 15, 2018 11:28 PM
To: [email-masked]
Subject: Re: [alto] I-D Action: draft-ietf-alto-unified-props-new-03.txt

Authors,

> If this is the approach, Sabine is a great person to work together. 
So, has this been done for UP-03, or are we moving UP and path vector ahead and will add cellular addresses later on?

  - Jan

On 05.03.18 18:36, [email-masked] wrote:
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
>

---

From: Jan Seedorf <[email-masked]>
Date: Fri, 16 Mar 2018 20:08:55 +0100

Hi Sabine,

thanks for your answer; yes, that answers my question. That means that 
we can move UP ahead and your cellular address draft may add such 
endpoints at a later point in time.

  - Jan