Subject: [ANCP] We need to add Partition ID back into ANCP spec

From: Bill Welch <[email-masked]>
Date: Thu, 5 Nov 2009 23:06:29 -0500

To all,

I have been monitoring the discussion from a far but I want to make two points on this topic.

There are implementations that include the use of Partition ID.

What is the underlying technical reason for it's removal?

If there is no overwelming reason for it's removal it should remain until it's proven completely unnecessary.  I don't think it really causes issue with implementations to keep partition ID.

There have been several people who have easily made the case to keep it at this time.

And what is going on with the procedural issue here?  There was a noted agreement in the meeting minutes but this agreement has been ignored.

Best regards,
Bill Welch
Juniper Networks

---

From: Maglione Roberta <[email-masked]>
Date: Fri, 6 Nov 2009 14:16:03 +0100

Hello Bill and All,
http://tools.ietf.org/html/draft-ietf-ancp-protocol-07

Partition ID has NOT been removed from the ancp protocol draft, if you check the draft it is there on page 18.

"Partition ID:

      This field is a 8 bit number which signifies a partition on the

      AN."

The only thing removed compare to version -06 are the two options that could be used to select the partition ID, because my interpretation  (but I may have miss understood the discussion) of the meeting minutes "keep as-is" was keep original text for Partition ID thus without including a clarification on the different ways to select it.

Again Partition ID is still part of the version -07 of the ancp draft and the two options to select it will be put back in version 08.

Regards,
Roberta

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bill Welch
Sent: Friday, November 06, 2009 5:06 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [ANCP] We need to add Partition ID back into ANCP spec

To all,

Best regards,
Bill Welch
Juniper Networks

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

Rispetta l'ambiente. Non stampare questa mail se non ? necessario.

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Mon, 9 Nov 2009 10:47:06 +0100

Hi Bill,
 
let me add a few comments to articulate the direction and address your questions on procedure:
- Following a recent ANCP WG decision, the ANCP protocol version that will be covered in the RFC is v3.2. This version change is a significant event, which for better or for worse allows "existing" v3.1 fields to be obsolete or re-defined, as well as new ones defined.
- A use-case which would call for a partition-id has not been articulated and by and large it appears as a GSMP derived candidate for being deprecated, also considering its current level of specification. The reason for it not being deprecated was to follow a "do no harm" approach to any pre-standard implementations. A more recent use-case proposal has however been put forward and a discussion on whether the partition-id is a suitable solution for it is on-going (and expected)
- IETF Meeting minutes, perhaps unlike some other SDOs, although being significant by themselves do not constitute formal consensus. Following IETF tradition and process a mailer discussion is used by the chairs as an indicator of consensus which is called by the chairs. In the case of the partition-id discussion, aside from "leaving things as they are", there has not been another consensus call, or a rough one, yet.
 
Regards,
Woj.

	From: Bill Welch [mailto:[email-masked]] 
	Sent: 06 November 2009 15:16
	To: Maglione Roberta; [email-masked]; [email-masked]; Wojciech Dec (wdec)
	Cc: [email-masked]; [email-masked]
	Subject: RE: We need to add Partition ID back into ANCP spec

	Roberta,

	Thanks for clarifying this and the quick response.   I thought this might be a misunderstand but if it wasn't the discussion was heading toward the wrong direction.

	Enjoy IETF and I will see you at BBF.

	Best regards,

	Bill Welch

	Juniper Networks

	From: Maglione Roberta [mailto:[email-masked]] 
	Sent: Friday, November 06, 2009 8:16 AM
	To: Bill Welch; [email-masked]; [email-masked]; [email-masked]
	Cc: [email-masked]; [email-masked]
	Subject: RE: We need to add Partition ID back into ANCP spec

	Hello Bill and All,

	"Partition ID:

	Regards,

	Roberta

	

	To all,

	Best regards,

	Bill Welch

	Juniper Networks

	 

 Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: Bill Welch <[email-masked]>
Date: Fri, 6 Nov 2009 09:16:20 -0500

Roberta,

Best regards,
Bill Welch
Juniper Networks

Hello Bill and All,

"Partition ID:

      AN."

Regards,
Roberta

To all,

Best regards,
Bill Welch
Juniper Networks