Subject: [Anima] voucher question re: pinned-domain-cert

From: Michael Richardson <[email-masked]>
Date: Wed, 21 Jun 2017 14:07:42 -0400

In voucher-03 (the latest I have on my laptop, while offline), we have:

        +--ro pinned-domain-cert*              binary

But then in 5.2 we show as an example:

   {
     "ietf-voucher:voucher": {
       "created-on": "2016-10-07T19:31:42Z",
       "assertion": "logged",
       "serial-number": "JADA123456789",
       "serial-number-issuer": "some binary identifier",
       "domain-cert-trusted-ca": "base64-encoded X.509 DER",

I am currently implementing the pinned-domain-cert, which we did not include
in the example.  I am guessing that we would write "base4-encoded X509 DER"

The question is, would this be in any way different than writing "X509 PEM"?
One would want to omit the "BEGIN FOO", lines, and all newlines, but I think
it would be essentially the same in a JSON (or JWT) format where we have
to base64.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Kent Watsen <[email-masked]>
Date: Wed, 21 Jun 2017 20:55:43 +0000

Yes, a base64-encoded DER and a PEM are different, in that the
latter has header/footers missing in the former.

Kent

-----ORIGINAL MESSAGE-----

   {