Subject: [Anima] Result of WGLC on draft-ietf-anima-voucher-03 - Respond by June 23, 2017

From: Sheng Jiang <[email-masked]>
Date: Tue, 27 Jun 2017 02:33:26 +0000

Hi, all

Given there is no negative response to the WGLC on draft-ietf-anima-voucher-03 and we did receive good reviews through the WG document stage and considering the past history of this work, the ANIMA chairs feel it is has passed the WGLC and should advance. This conclusion is made with the condition that the authors would solve the comments received during the WGLC and these modifications were not substantial changes from 03 version. If there are big changes, a shorter second WGLC may be needed.

Once the update is published and it meets the above condition, for which the second WGLC is not needed, as shepherd, Sheng Jiang will finalize the shepherd document and send the document on.

Best regards,

Toerless & Sheng

---

From: "Max Pritikin (pritikin)" <[email-masked]>
Date: Tue, 27 Jun 2017 21:03:17 +0000

Toerless (the other working group chair) has been involved in conversations concerning the open issues listed on the github repository for the voucher document.
The issues should be resolved now as per the current status in github. See here for details of three open issues remaining:
https://github.com/anima-wg/voucher/issues
The other issues have been resolved and the ‘top of the tree’ is here:
https://github.com/anima-wg/voucher/blob/master/draft-ietf-anima-voucher.txt

If you are curious about what this resolves so far please look at these diffs (here summarized via the commit comments):

[some minor editorial work]
typo in "hangTex" instead of "hangText" 2f0d64c
updated hangtext for artifact definition 4f6c710
Updated the proximity description with minor editorial edits. … b742c5a
Merge branch 'master' into voucher_sync_061417 6cc9d72
manual merge of a generated txt file sucks. committing built version … …
[substantive issues]
additional enum for ‘proximity’ assertions:
https://github.com/anima-wg/voucher/commit/b8ec4919242bc26c9082f633099656e4851097ea

addition of prior-signed-voucher to provide history in northbound BRSKI exchanges:
https://github.com/anima-wg/voucher/commit/b742c5a63e05f1341b37f96009d6bfcd5f5be0e1

We believe this provides enough to proceed with LC and to allow BRSKI to be finalized toward LC as well asap.

- max

On Jun 26, 2017, at 8:33 PM, Sheng Jiang <[email-masked]<mailto:[email-masked]>> wrote:

Hi, all

Best regards,

Toerless & Sheng

_______________________________________________
Anima mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/anima

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 1 Jul 2017 02:53:19 +0200

Which WG chair ? i am purely a co-author here on this thread ;-)

Hope i just resolved to the approval of my co-authors two more, leaving just one open
item which is how we best compromise between some fairly recent improvements to
bootstrap (using voucher format also to request vouchers) and expediency in finishing
last call for voucher.

Issues resolved:

https://github.com/anima-wg/voucher/issues/8  - how to use grouping in yang for extensibility
via followup documents. Hope i didn't make mistakes in what i wrote, but the issue tracker
URL now has a longer explanation from me how such extensibility can be done in the future and the
necessary stub was added into the voucher draft (Kent had proposed this in the past already,
i also verified this with some Yang knowledgable colleagues, so i hope we're good here).

https://github.com/anima-wg/voucher/issues/6 - describing how vouchers could be used with
eg: JWS instead of PKCS#7 (via appropriate specs in other docs).

Cheers
    Toerless

On Tue, Jun 27, 2017 at 09:03:17PM +0000, Max Pritikin (pritikin) wrote:
> The other issues have been resolved and the ???top of the tree??? is here:
> Updated the proximity description with minor editorial edits. ??? b742c5a
> manual merge of a generated txt file sucks. committing built version ??? ???
> [substantive issues]
> additional enum for ???proximity??? assertions:

-- 
---
[email-masked]