Subject: [Anima] "professionally managed" and the reference model

From: Brian E Carpenter <[email-masked]>
Date: Tue, 27 Feb 2018 10:21:35 +1300

While looking at Pascal's ACP review, I noticed that although ANIMA
scope is limited by charter to "professionally managed" networks,
we do not mention that scope in draft-ietf-anima-reference-model.
It seems like something to be added to the Introduction.

Comments?

Regards
   Brian Carpenter

---

From: "Natale, Bob" <[email-masked]>
Date: Mon, 26 Feb 2018 22:14:20 +0000

Lurker question (and a predictable one at that): What does it mean to be "professionally managed"? I am sure we can all think of multiple reasonable definitions, but it seems we need to have an explicit statement of the one we're using to constrain the scope of ANIMA.

More important perhaps (and don't forget the lurker status!), one value of technologies like ANIMA might well be to better manage networks that do not have a sufficient level of professional resources supporting them in the first place...?

Avanti,
BobN

-----Original Message-----
From: Anima [mailto:[email-masked]] On Behalf Of Brian E Carpenter
Sent: Monday, February 26, 2018 4:22 PM
To: Anima WG <[email-masked]>
Subject: [Anima] "professionally managed" and the reference model

While looking at Pascal's ACP review, I noticed that although ANIMA scope is limited by charter to "professionally managed" networks, we do not mention that scope in draft-ietf-anima-reference-model.
It seems like something to be added to the Introduction.

Comments?

Regards
   Brian Carpenter

_______________________________________________
Anima mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/anima

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 27 Feb 2018 11:35:27 +1300

> Lurker question (and a predictable one at that): What does it mean to be "professionally managed"? I am sure we can all think of multiple reasonable definitions, but it seems we need to have an exp…

Yes, we probably need to add a few words. The discussion in https://tools.ietf.org/html/rfc7575#section-3.2 applies, I think, even though it doesn't use the word "professional". The idea is that there is a NOC, there are skilled human operators, and we have to co-exist with traditional management tools.
 
> More important perhaps (and don't forget the lurker status!), one value of technologies like ANIMA might well be to better manage networks that do not have a sufficient level of professional resour…

Oh, I think we agree on that as the long-term goal. But we were specifically chartered to avoid clashing with the HOMENET WG, where clearly pure plug-and-play is the goal.

    Brian

---

From: "Michael H. Behringer" <[email-masked]>
Date: Tue, 27 Feb 2018 17:34:02 +0100

In principle I'm happy with that, and I agree that it would be a good 
idea. However, I hope we can avoid another WGLC with this change? (Sheng?)

Looking...

Actually, the intro has this paragraph, which I think pretty much covers 
this case:

    As discussed in [RFC7575], the goal of this work is not to focus
    exclusively on fully autonomic nodes or networks.  In reality, most
    networks will run with some autonomic functions, while the rest of
    the network is traditionally managed.  This reference model allows
    for this hybrid approach.

Isn't that even a better description than "professionally managed", 
which has itself raised a lot of questions?

My vote for now: We're good! No changes needed.

Michael

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 27 Feb 2018 19:34:56 +0100

As co-author:

+1,

I would also trying to avoid bringing in more text re "professionally managed"
into the ANI docs, but rather stick to technical wordings which (as michael
pointed out) we have. As i said in recent mails, in my memory, this charter
statement ("professionally managed") was primarily an IETF  definition to 
separate ANIMA from homenet, but its really hard to translate into technical
terms:

IMHO, after we have ANI docs out, a technical comparison could easily be another
document, maybe something nice to work on:

Does a home network need BRSKI ? 
  "No, Mrs. Jones will always directly touch the devices in a pre-staging
   network consisting of a notebook cable and the new device".
  "Actually, Mr. Eckert does remotely install devices in other family member homes,
   and especially with a lot of untrusted equipment in the home, BRKI would be
   on the top of my list to ask for adoption into home networks..."

Does a home network need GRASP ?
  "Well.. Homenet already had enough of fights about what protocols to use for
    what purpose."
   "IMHO we first need strong use-cases for GRASP that makes it easier to use
    GRASP than the whatever ad-hoc protocol pre-exists! DNS-SD via GRASP
    could be one such use-case"
  "How about we define how to use Babel as a transport and security layer for
   GRASP ?" 

Does a home network or other constrained networks need ACP ?
  "Well... i think there are various degress of variations of ACP to make
   it more lightweight. We specifically did focus on high security first,
   there is definitely easy options for more lightweight approaches, most
   of them just suggested by current ACP draft in appendix".

Cheers
   Toerless

On Tue, Feb 27, 2018 at 05:34:02PM +0100, Michael H. Behringer wrote:
> In principle I'm happy with that, and I agree that it would be a
> good idea. However, I hope we can avoid another WGLC with this
> change? (Sheng?)
> 
> Looking...
> 
> Actually, the intro has this paragraph, which I think pretty much
> covers this case:
> 

-- 
---
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 28 Feb 2018 10:40:55 +1300

> My vote for now: We're good! No changes needed.

(a) Undoubtedly we will have changes to make after IETF Last Call,
so we can put this on ice until then.
(b) Yes, I think the text here and in RFC7575 is fine. Maybe it's
the WG charter which is wrong :-). As you know, the point was to
avoid any clash with HOMENET. But "traditionally managed" is a better
phrase than "professionally managed", I think.

   Brian

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 28 Feb 2018 16:51:57 +0100

> phrase than "professionally managed", I think.

Interesting aside!

Is a network with an SDN controller traditionally managed ?
If the SDN controller uses the ACP, does this change the result ?

Long term NMS'ler would say controller/orchestrator are just fancy new
words for mostly the provisioning part of NMS, but:

Good controllers/orchestrator would also be intent based
only that the rendering of the intent would not necessarily be
autonomic. But then we have never IMHO well described what criteria
are required to call a particular method of intent rendering autonomic.

Some for example would make distribution the key criteria while i
would just look at the observable resilience of a function.

To use a militaristic explanation: When doing PIM-SM, defense customers
asked us what happens when the enemy shoots down the RP. And then shoot
down its replacement. An so on. Now replace RP with SDN controller.

Aka: resilient = able to automatically restart in one of enough places to 
make the solution survive all covered incidents.

The "ability to shoot down anything" was btw. the original 1st requirement
by DoD against Arpanet, so i would be careful to call autonomic networks
non-traditional (managed). I would not know what would be more traditional
than meeting this expectation for an IP network.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 1 Mar 2018 13:53:20 +1300

in line (all IMHO):

> Is a network with an SDN controller traditionally managed ?

If the SDN controller is configured by a NOC or an NMS database managed
by the NOC, yes. I think we are talking about configured by a human in
the NOC when we say "traditional" or "professional". 

> If the SDN controller uses the ACP, does this change the result ?

No. But if the SDN controller is configured by an ASA, not by a
human, it's autonomic.

> are required to call a particular method of intent rendering autonomic.

One reason why "intent" is still a buzzword left for future study.

> than meeting this expectation for an IP network.

Right. That's why the GRASP draft used to contain a riff about how
routing algorithms were the original autonomic mechanisms. If you
remember, we had to remove that to satisfy the Routing Area people.

If ANIMA succeeds, we will have simply extended that original DARPA
requirement.

   Brian