Subject: Re: [Anima] New Version Notification for draft-ietf-anima-bootstrapping-keyinfra-10.txt

From: Michael Richardson <[email-masked]>
Date: Tue, 13 Feb 2018 16:36:55 -0500

WG chairs, after our design team meeting this morning, Max and I believe that
-10 is ready for WGLC.

(Perhaps we could even complete that before IETF101 and make our outgoing AD happy...)

We see the language review from William Atwood, and we'll incorporate that
into the document along with any other LC comments.  I'm sure that the IESG
review will involve two more revisions, but I think we are ready for that
step.

[email-masked] wrote:
    > A new version of I-D, draft-ietf-anima-bootstrapping-keyinfra-10.txt
    > has been successfully submitted by Michael Richardson and posted to the
    > IETF repository.

    > Name:		draft-ietf-anima-bootstrapping-keyinfra
    > Revision:	10
    > Title:		Bootstrapping Remote Secure Key Infrastructures (BRSKI)
    > Document date:	2018-02-13
    > Group:		anima
    > Pages:		82
    > URL:            https://www.ietf.org/internet-drafts/draft-ietf-anima-bootstrapping-keyinfra-10.txt
    > Status:         https://datatracker.ietf.org/doc/draft-ietf-anima-bootstrapping-keyinfra/
    > Htmlized:       https://tools.ietf.org/html/draft-ietf-anima-bootstrapping-keyinfra-10
    > Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-anima-bootstrapping-keyinfra-10
    > Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-anima-bootstrapping-keyinfra-10

    > Abstract:
    > This document specifies automated bootstrapping of a remote secure
    > key infrastructure (BRSKI) using vendor installed X.509 certificate,
    > in combination with a vendor's authorizing service, both online and
    > offline.  Bootstrapping a new device can occur using a routable
    > address and a cloud service, or using only link-local connectivity,
    > or on limited/disconnected networks.  Support for lower security
    > models, including devices with minimal identity, is described for
    > legacy reasons but not encouraged.  Bootstrapping is complete when
    > the cryptographic identity of the new key infrastructure is
    > successfully deployed to the device but the established secure
    > connection can be used to deploy a locally issued certificate to the
    > device as well.

    > Please note that it may take a couple of minutes from the time of submission
    > until the htmlized version and diff are available at tools.ietf.org.

    > The IETF Secretariat

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Benoit Claise <[email-masked]>
Date: Wed, 14 Feb 2018 11:30:47 +0100

Hi Michael,

The tooling can't extract the YANG modules.

This issue comes from:

You should remove "yang/"

Also, complete the CODE BEGINS here under:

    <CODE BEGINS>
    module ietf-mud-brski-masa {
      yang-version 1.1;
      namespace "urn:ietf:params:xml:ns:yang:ietf-mud-brski-masa";
      prefix ietf-mud-brski-masa;
      import ietf-mud {
        prefix ietf-mud;
      }
      import ietf-inet-types {
        prefix inet;
      }

Regards, Benoit
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

---

From: Michael Richardson <[email-masked]>
Date: Wed, 14 Feb 2018 13:24:38 -0500

> *

    > You should remove "yang/"

I'll fix that! We moved files around in our repo and didn't realize it would
impact here.

    > prefix ietf-mud-brski-masa;

Ah... fixing to insert file name and make it consistent with our other
yang data.