Subject: Re: [Anima] draft-richardson-anima-ace-constrained-voucher

From: peter van der Stok <[email-masked]>
Date: Tue, 01 May 2018 19:05:45 +0200

> There are a couple of questions that I would put here that I think 
> guides
> things.
> 
> *  Is there any expectation that the path components would ever change 
> for
> some implementation or are they always going to be the same?  Would a
> request voucher always be posted to /rv or could an implementation 
> change it
> to be /rvr?

No path components are immutable.

> *  Is there a reason for an endpoint to want to get what services are
> supported as a general rule rather than just assuming that if the root
> exists then all of the services are also going to exist.
> 
> If the answer to the first question is no, then I don't know that they 
> even
> need to have resource types.  You get the root and go from there.

Agree.

I will change the example and return the rt= with the first line
and no rt= for the following lines.
The text will mention that the first line MUST be returned,
and the 4 following lines MAY be returned to show the ct= values that 
are supported.

Greetings and thanks,

Peter

---

From: peter van der Stok <[email-masked]>
Date: Tue, 01 May 2018 19:07:22 +0200

sorry, ambiguous answer.

> No! The path components are immutable.

Peter