Subject: [Anima] Handling of endpoint path names (from BRSKI-AE discussion today)

From: "Fries, Steffen" <[email-masked]>
Date: Thu, 30 Jul 2020 15:46:09 +0000

Hi,

Based on the discussion of splitting up the voucher handling endpoint naming issues from BRSKI-AE today, I just wanted to ensure I got the way forward right. 
>From the Etherpad discussion I understood Michael that he would not be too happy with having a BRSKI update right after BRSKI publication as RFC. I think finalizing the discussion on the list was advised.

What we discussed in the WG meeting was to have a separate short document, basically defining a renaming or alternatively an alias for the current endpoints, which allows to keep the current implementations as is. 
Hence, the draft would relate to all of the endpoints defined in section 5 of BRSKI for the domain registrar facing the pledge (and potentially also the MASA), which are: 
/.well-known/est/requestvoucher	used by pledge to registrar but also from registrar to MASA
/.well-known/est/voucher_status	used by pledge to registrar
/.well-known/est/requestauditlog	used by registrar to MASA
/.well-known/est/enrollstatus		used by pledge to registrar

>From Toerless I understood that he would like to not change the current draft as it is already in the final state and rather provide an update as separate document.
>From Michael I understood he would not be keen on having a fast update for the BRSKI document. At least not for a renaming of the defined endpoints. Also the IESG may view this as too fast. 
Eliot stated that there are already implementations out there that utilize the /est approach. So having aliases could be one way of dealing with it, but this would double the endpoints at least for the four stated ones above. 

Both approaches have there merits. Having the endpoints distinct from the beginning allows a clearer separation of the functionalities, for the pledge and for server side handling. Specifically if we later on allow for alternative enrollment protocols in BRSKI-AE and define the discovery approach, it will lead to less confusion to align the naming with the corresponding functionality. From that perspective, my gut feeling would be that an integration into base BRSKI may be more appropriate. On the contrary, it will slow down the process, but somebody stated that there are examples that these changes have been also done in the past and could be done fast. 

What do you suggest as way forward? 

Best regards
Steffen

--
Steffen Fries
Siemens AG, Corporate Technology
mailto:[email-masked]

---

From: Eliot Lear <[email-masked]>
Date: Thu, 30 Jul 2020 18:06:09 +0200

Steffen

I enjoyed today’s discussion.  My suggestion is a short document that does not CHANGE endpoints but simply creates new ones that have the same functionality as the old ones.  That doesn’t require an “Updates” header, and based on that I think you might even keep these in the same document.  Would people be ok with that?

Eliot

> On 30 Jul 2020, at 17:46, Fries, Steffen <[email-masked]> wrote:
> 
> Hi,
>

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 30 Jul 2020 18:11:42 +0200

Thanks Steffen

Maybe here is a good logic:

The short document would not need to be an Update as long as we do not want to eliminate
the old /est URLs. 

Aliasing should be easy enough. The main goal of the small document would the be to be
what Michael called an Extension as the bassis for for that does not expect to to demand
EST. Like BRSKI-AE. And the reason for not doing this solely in BRSKI-AE might be
that such other document migth not want to reference all of BRSKI-AE.

I am just making this up as i go as proposals of waht would give us the smoothest rides
hrough the process with the only difference to the likely position of BRSKI-AE authors
being that i would also like to think about the smooth ride for other BRSKI extension documents.

Lets hope others will have even better opinions on the thread.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 30 Jul 2020 18:32:11 +0200

On Thu, Jul 30, 2020 at 06:06:09PM +0200, Eliot Lear wrote:
> Steffen
> 
> I enjoyed today???s discussion.  My suggestion is a short document that does not CHANGE endpoints but simply creates new ones that have the same functionality as the old ones.  That doesn???t require an ???Updates??? header, and based on that I think you might even keep these in the same document.  Would people be ok with that?

Right. So the question is keep it in the document or put it into a separate
small one. The small one would allow other derivative work not to have to
have BRSKI-AE as a normative reference, which may be better if its got nothing
to do with BRSKI-AE.

I guess we can delay the decision up to the point when we do see such other
derivative work coming up, and then decide whether to separate out the
new /brski naming from the doc. As long as there is no such additional doc,
we keep things in BRSKI-AE as they are right now.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Thu, 30 Jul 2020 17:14:07 +0000

Toerless

I have one question to better make up my mind.
How long do you thing would the change to the BRSKI document delay the approval process? 
Finally this change is quite easy to explain. And from my point of view, doing this change to BRSKI before approval, would be, from a standardization point of view, the clearest solution.

Hendrik

> -----Ursprüngliche Nachricht-----
> Von: Toerless Eckert <[email-masked]>
> Gesendet: Donnerstag, 30. Juli 2020 18:32
> An: Eliot Lear <[email-masked]>
> Cc: Fries, Steffen (CT RDA CST) <[email-masked]>; Michael
> Richardson <[email-masked]>; Brockhaus, Hendrik (CT RDA CST SEA-DE)
> <[email-masked]>; [email-masked]
> Betreff: Re: Handling of endpoint path names (from BRSKI-AE discussion today)
> 
> > I enjoyed today???s discussion.  My suggestion is a short document that does
> not CHANGE endpoints but simply creates new ones that have the same
> functionality as the old ones.  That doesn???t require an ???Updates??? header,
> and based on that I think you might even keep these in the same document.
> Would people be ok with that?
> 
> Right. So the question is keep it in the document or put it into a separate small
> one. The small one would allow other derivative work not to have to have
> BRSKI-AE as a normative reference, which may be better if its got nothing to do
> with BRSKI-AE.
> 
> derivative work coming up, and then decide whether to separate out the new
> /brski naming from the doc. As long as there is no such additional doc, we keep
> things in BRSKI-AE as they are right now.
> 
> Cheers
>     Toerless
> 
> > Eliot
> >
> > > Based on the discussion of splitting up the voucher handling endpoint
> naming issues from BRSKI-AE today, I just wanted to ensure I got the way
> forward right.
> > > From the Etherpad discussion I understood Michael that he would not be
> too happy with having a BRSKI update right after BRSKI publication as RFC. I
> think finalizing the discussion on the list was advised.
> > >
> > > What we discussed in the WG meeting was to have a separate short
> document, basically defining a renaming or alternatively an alias for the
> current endpoints, which allows to keep the current implementations as is.
> > > Hence, the draft would relate to all of the endpoints defined in section 5 of
> BRSKI for the domain registrar facing the pledge (and potentially also the
> MASA), which are:
> > > From Toerless I understood that he would like to not change the current
> draft as it is already in the final state and rather provide an update as separate
> document.
> > > From Michael I understood he would not be keen on having a fast update
> for the BRSKI document. At least not for a renaming of the defined endpoints.
> Also the IESG may view this as too fast.
> > > Eliot stated that there are already implementations out there that utilize
> the /est approach. So having aliases could be one way of dealing with it, but
> this would double the endpoints at least for the four stated ones above.
> > >
> > > Both approaches have there merits. Having the endpoints distinct from the
> beginning allows a clearer separation of the functionalities, for the pledge and
> for server side handling. Specifically if we later on allow for alternative
> enrollment protocols in BRSKI-AE and define the discovery approach, it will lead
> to less confusion to align the naming with the corresponding functionality. From
> that perspective, my gut feeling would be that an integration into base BRSKI
> may be more appropriate. On the contrary, it will slow down the process, but
> somebody stated that there are examples that these changes have been also
> done in the past and could be done fast.
> > >

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 31 Jul 2020 08:59:05 +1200

> How long do you thing would the change to the BRSKI document delay the approval process? 

That is utterly unpredictable. Since this is a real technical change, we'd need the chairs
to formally establish WG consensus and then, as far as I can tell, we have invalidated the
IETF Last Call and so we're back to that and a Security Area review etc. After recent
experience, I have no idea whatever how long that would take.

So I *strongly* believe that we should make a separate document. It's an extension, not
a change, so it really doesn't need an Updates: tag.

   Brian

>> too happy with having a BRSKI update right after BRSKI publication as RFC.. I
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>