Subject: [Anima] Adoption call for draft-friel-anima-brski-cloud-04, ends April 20th 2021

From: Sheng Jiang <[email-masked]>
Date: Wed, 7 Apr 2021 10:00:30 +0000

Hi, dear ANIMAer,

This message starts a two-week adoption call on draft-friel-anima-brski-cloud-04, it ends on April 20th, 2021.

draft-friel-anima-brski-cloud has been presented to the WG since September 2019 and the WG showed good interest and had discussions. It was presented several times and had no opposition. The draft is clearly in scope of ANIMA charter and milestones. Giving the dependent BRSKI has passed the IESG evaluation, the chairs feel that it may be the right time to call the adoption.

We therefore are asking the ANIMA working group for adoption of the following work:

Title:    BRSKI Cloud Registrar

Name:     draft-friel-anima-brski-cloud-04

Authors:  O. Friel, R. Shekh-Yusef and M. Richardson

URL:      https://datatracker.ietf.org/doc/draft-friel-anima-brski-cloud/

IPR:      No IPR disclosures have been submitted directly on draft-richardson-anima-voucher-delegation

This document is intended to become a standards track ANIMA WG document.

Please express your support or rejection. If you think this document should _not_ be adopted, please also explicitly indicate the reasons.

Regards,

Sheng

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 8 Apr 2021 11:32:02 +1200

Hi everybody,

I think adoption is appropriate. I do have a few comments towards the next version.

1) This model is rather different from the basic ANIMA model, which was designed for nodes that start out with nothing but an IPv6 address. As the draft says:

>> The assumption is that the pledge already has network connectivity prior to connecting to the cloud registrar. The pledge must have an IP address, must be able to make DNS queries, and must be able to send HTTP requests to the cloud registrar.

I think there should be some discussion right at the beginning of the Introduction about this fundamental difference. The reason that ACP and BRSKI use GRASP flooding for discovery is to avoid any dependency on DNS or the wider Internet. You could use the BRSKI and ACP mechanisms in a disconnected network fragment and build up connectivity from there. (For example, if the pledge hears no RA messages that give it DNS or Internet connectivity, one could invent a GRASP objective like "Connectivity" that could be used to find a router or RADIUS server willing to help.)

2) 

>>  1.2. Target Use Cases
>> 
>> Two high level use cases are documented here. There are more details provided in sections Section 4.1 and Section 4.2.

This is not easy to read. It really needs to summarise the two cases in a few words. Otherwise, most readers will immediately jump to the two sections, as I did. Proposal:

Two high level use cases are documented here (voucher request redirected to local registrar, or handled directly by cloud registrar). There are more details provided in sections Section 4.1 and Section 4.2.

3) Security Considerations is a very big [[ TODO ]]. I would prefer to see some content  in the WG draft as soon as possible.

Regards
   Brian Carpenter

On 07-Apr-21 22:00, Sheng Jiang wrote:
> Hi, dear ANIMAer,
> 
>  
> 
> This message starts a two-week adoption call on draft-friel-anima-brski-cloud-04, it ends on April 20^th , 2021.
> 
>  
> 
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>

---

From: "Fries, Steffen" <[email-masked]>
Date: Mon, 12 Apr 2021 06:05:24 +0000

Hi,

I'm in favor of adoption. Introducing a cloud registrar also addresses domains with no local registrar to allow pledges to onboard to  specific domain.

Best regards
Steffen

From: Anima <[email-masked]> On Behalf Of Sheng Jiang
Sent: Mittwoch, 7. April 2021 12:01
To: [email-masked]
Cc: [email-masked]; Rob Wilton (rwilton) <[email-masked]>; [email-masked]; [email-masked]
Subject: [Anima] Adoption call for draft-friel-anima-brski-cloud-04, ends April 20th 2021

Hi, dear ANIMAer,

Regards,

Sheng