Subject: [Anima] [Technical Errata Reported] RFC8995 (6716)

From: RFC Errata System <[email-masked]>
Date: Tue, 19 Oct 2021 15:46:04 -0700 (PDT)

The following errata report has been submitted for RFC8995,
"Bootstrapping Remote Secure Key Infrastructure (BRSKI)".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6716

--------------------------------------
Type: Technical
Reported by: Max Pritikin <[email-masked]>

Section: 5.8.3

Original Text
-------------
A registrar MAY be configured to ignore (i.e., override
the above policy) the history of the device, but it is RECOMMENDED
that this only be configured if hardware-assisted (i.e., Transport
Performance Metrics (TPM) anchored) Network Endpoint Assessment (NEA)
[RFC5209] is supported.

Corrected Text
--------------
A registrar MAY be configured to ignore (i.e., override
the above policy) the history of the device, but it is RECOMMENDED
that this only be configured if hardware-assisted (i.e., Trusted 
Platform Module (TPM) anchored) Network Endpoint Assessment (NEA)
 [RFC5209] is supported.

Notes
-----
The logical expansion of 'TPM' in this parenthetical example is the Trusted Platform Module.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8995 (draft-ietf-anima-bootstrapping-keyinfra-45)
--------------------------------------
Title               : Bootstrapping Remote Secure Key Infrastructure (BRSKI)
Publication Date    : May 2021
Author(s)           : M. Pritikin, M. Richardson, T. Eckert, M. Behringer, K. Watsen
Category            : PROPOSED STANDARD
Source              : Autonomic Networking Integrated Model and Approach
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Michael Richardson <[email-masked]>
Date: Tue, 19 Oct 2021 23:29:26 -0400

please mark as verified, wait for revision.

    > Type: Technical Reported by: Max Pritikin <[email-masked]>

    > Original Text
    > -------------
    > A registrar MAY be configured to ignore (i.e., override the above
    > policy) the history of the device, but it is RECOMMENDED that this only
    > be configured if hardware-assisted (i.e., Transport Performance Metrics
    > (TPM) anchored) Network Endpoint Assessment (NEA) [RFC5209] is
    > supported.

    > Corrected Text
    > --------------
    > A registrar MAY be configured to ignore (i.e., override the above
    > policy) the history of the device, but it is RECOMMENDED that this only
    > be configured if hardware-assisted (i.e., Trusted Platform Module (TPM)
    > anchored) Network Endpoint Assessment (NEA) [RFC5209] is supported.

    > The logical expansion of 'TPM' in this parenthetical example is the

As co-author, I totally agree.
I can't understand why/how that happened.
Did the rfc-editor expand our TLA?

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 20 Oct 2021 16:46:32 +1300

The RFC Editor clearly used their own glossary: https://www.rfc-editor.org/materials/abbrev.expansion.txt

A miss at AUTH48, I fear.

Regards
   Brian Carpenter

On 20-Oct-21 16:29, Michael Richardson wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 20 Oct 2021 14:09:02 +0000

The RFC editor has verified this errata.

I presume that we would also like to ask the RFC editor to also add TPM as, Trusted Platform Module, to the glossary.

Thanks,
Rob

> -----Original Message-----
> From: Michael Richardson <[email-masked]>
> Sent: 20 October 2021 04:29
> To: RFC Errata System <[email-masked]>; Max Pritikin (pritikin)
> <[email-masked]>; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; Rob Wilton (rwilton)
> <[email-masked]>; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [Technical Errata Reported] RFC8995 (6716)
> 
>

---

From: Sandy Ginoza <[email-masked]>
Date: Wed, 20 Oct 2021 07:25:35 -0700

Hi all,

> On Oct 20, 2021, at 7:09 AM, Rob Wilton (rwilton) <[email-masked]> wrote:
> 

Good point!  We have added this to the abbreviations list [1]:

   TPM          Trusted Platform Module (TPM)

[1] https://www.rfc-editor.org/materials/abbrev.expansion.txt

Thanks,
Sandy

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 20 Oct 2021 14:27:36 +0000

Great.  Thanks Sandy.

Rob

-----Original Message-----
From: Sandy Ginoza <[email-masked]> 
Sent: 20 October 2021 15:26
To: Rob Wilton (rwilton) <[email-masked]>
Cc: Michael Richardson <[email-masked]>; RFC Editor <[email-masked]>; Max Pritikin (pritikin) <[email-masked]>; [email-masked]; [email-masked]; Warren Kumari <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Technical Errata Reported] RFC8995 (6716)

Hi all,

Thanks,
Sandy