Subject: Re: [Anima] WGLC for draft-ietf-anima-asa-guidelines-02 Nov. 1st 2021

From: Toerless Eckert <[email-masked]>
Date: Sat, 16 Oct 2021 04:53:43 +0200

Dear ANIMA WG

This message starts the two-week ANIMA Working Group Last Call to advance

  Guidelines for Autonomic Service Agents
   draft-ietf-anima-asa-guidelines

This document's intended status is Informational.
At present, there is no IPR file against this document (*).

This document has been discussed by the author with the WG since Sep 2016 and
as a WG document only since Nov 2020 because of the authors and the WGs charter round 1
document backlog and because this document could only be adopted with charter round 2.

The document has seen good WG member reviews since 2016.  The authors have
addressed all known comments and think the document is ready for WGLC.

Please send your comments by Nov 1st, 2021 (any time zone). (**)
If you do not feel this document should advance, please state your reasons why.

Toerless Eckert is the assigned document shepherd.

Thanks a lot for the work to the authors!

Toerless for the WG chairs.

(*) If you are an author, now is also a good time to reconsider if you are
aware of any IPR because if this WGLC passes i will need to get
answer as to whether or not you are aware of IPR against it.

(**) I choose this deadline because it is exactly one week after IETF112 draft
deadline, so hopefully a good week to take a look at the document and comment
if you are now busy with meeting that IETF112 deadline ;-)

> Brian Carpenter so said:
> 
> Hi,
> 
> Sorry this version took a long time. There is one small change, a note about the maximum size of a GRASP objective.
> 
> I believe this is ready for WG Last Call.
> 
> Regards
>    Brian
> 
> On 13-Sep-21 17:02, [email-masked] wrote:
> > 
> > A New Internet-Draft is available from the on-line Internet-Drafts directories.
> > This draft is a work item of the Autonomic Networking Integrated Model and Approach WG of the IETF.
> > 
> >         Title           : Guidelines for Autonomic Service Agents
> >         Authors         : Brian Carpenter
> >                           Laurent Ciavaglia
> >                           Sheng Jiang
> >                           Pierre Peloso
> > 	Filename        : draft-ietf-anima-asa-guidelines-02.txt
> > 	Pages           : 27
> > 	Date            : 2021-09-12
> > 
> > Abstract:
> >    This document proposes guidelines for the design of Autonomic Service
> >    Agents for autonomic networks.  Autonomic Service Agents, together
> >    with the Autonomic Network Infrastructure, the Autonomic Control
> >    Plane and the Generic Autonomic Signaling Protocol constitute base
> >    elements of a so-called autonomic networks ecosystem.
> > 
> > 
> > The IETF datatracker status page for this draft is:
> > https://datatracker.ietf.org/doc/draft-ietf-anima-asa-guidelines/
> > 
> > There is also an HTML version available at:
> > https://www.ietf.org/archive/id/draft-ietf-anima-asa-guidelines-02.html
> > 
> > A diff from the previous version is available at:
> > https://www.ietf.org/rfcdiff?url2=draft-ietf-anima-asa-guidelines-02
> > 
> > 
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 16 Oct 2021 16:48:46 +1300

I am not aware of any IPR relevant to this draft.

(Co-authors, we should all reply on this point.)

There is no real implementation report for this draft,
but I did work on a very simple version of the ASA
life cycle aspect earlier this year:
https://mailarchive.ietf.org/arch/msg/anima/u1TCJQ0PpOJSVs9bdqr5akwA25w/ 

Regards
   Brian Carpenter

On 16-Oct-21 15:53, Toerless Eckert wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 16 Oct 2021 16:53:04 +1300

[Repeat with address correction.]

Regards
   Brian Carpenter

---

From: Sheng Jiang <[email-masked]>
Date: Mon, 18 Oct 2021 02:33:03 +0000

I am a co-author, I am not aware of any IPR relevant to this draft. I think this document is helpful for ASAs that would be developed either in WG or by themselves in a limited domain. It has good review and in good sharp, I believe. I don't think this informational document needs any implementations.

Cheers,

Sheng

> -----Original Message-----
> From: Anima <[email-masked]> On Behalf Of Brian E Carpenter
> Sent: Saturday, October 16, 2021 11:49 AM
> To: Toerless Eckert <[email-masked]>; Anima WG <[email-masked]>;
> [email-masked]; [email-masked]
> Subject: Re: [Anima] WGLC for draft-ietf-anima-asa-guidelines-02 Nov. 1st 2021
> 
> There is no real implementation report for this draft, but I did work on a very
> simple version of the ASA life cycle aspect earlier this year:
> > This document has been discussed by the author with the WG since Sep
> > 2016 and as a WG document only since Nov 2020 because of the authors
> > and the WGs charter round 1 document backlog and because this document
> could only be adopted with charter round 2.
> >
> > The document has seen good WG member reviews since 2016.  The authors
> > have addressed all known comments and think the document is ready for
> WGLC.
> >
> > Please send your comments by Nov 1st, 2021 (any time zone). (**) If
> > you do not feel this document should advance, please state your reasons
> why.
> >
> > (*) If you are an author, now is also a good time to reconsider if you
> > are aware of any IPR because if this WGLC passes i will need to get
> > (**) I choose this deadline because it is exactly one week after
> > IETF112 draft deadline, so hopefully a good week to take a look at the
> > document and comment if you are now busy with meeting that IETF112
> > deadline ;-)
> >
> >> Brian Carpenter so said:
> >>
> >> Hi,
> >>