Subject: Re: [Apn] Question List for APN: Q#8

From: Sørensen, Frode <[email-masked]>
Date: Thu, 1 Oct 2020 07:16:47 +0000

Dear Shuping, dear all,

Many thanks for elaborating the different questions regarding APN. I would like to share some food for thought regarding question 8.

Net neutrality comes in different flavours, and while some understands net neutrality as all traffic being treated equally within one single traffic class (usually labelled “best effort”), it is also a reasonable approach to consider a scenario with multiple traffic classes with different performance levels under certain conditions.

This approach does not suggest that  multiple traffic classes necessarily should be provided over the internet. The approach is rather an explanation that net neutrality should not stifle technology development, and could under certain conditions be compatible with multiple QoS levels in case that should be provided by some ISPs.

E.g. regarding the European net neutrality regulation it is commonly understood that multiple traffic classes/QoS classes with different performance levels could be accepted – as long as the traffic classes are application-agnostic, which means that any application may populate any traffic class as selected by the end-user.

In this regard it is essential that the end-user controls the selection of QoS level, and that this is not controlled by the ISP, nor indirectly controlled by the application provider. The ISP offers the different QoS levels, and the end-user requests the QoS level for the application’s traffic over the internet access service.

In this scenario the ISP does not need to know which application that runs in the endpoint, only which QoS level the application’s traffic runs on. Such an architecture would not be application-aware, it would be application-agnostic. One could however say it would be QoS-aware.

Furthermore, the European net neutrality regulation concerns the open internet access service, not the closed internal services running on the ISPs infrastructure. The latter is often referred to as “specialised services” were the ISP may run specific applications, as opposed to the general internet access service over which any application must be able to run.

And there are limitations regarding the provision of specialised services to avoid circumvention of the regulation. Specialised services are only allowed under two main conditions; (a) that the services have quality requirements which cannot be provided via the internet access service, and (b) that the network capacity is sufficient to provide them in addition to any internet access services provided.

Best,
Frode

Fra: Network-tokens <[email-masked]> På vegne av Pengshuping (Peng Shuping)
Sendt: tirsdag 29. september 2020 02:54
Til: [email-masked]
Kopi: [email-masked]; [email-masked]
Emne: [Network-tokens] Question List for APN: Q#8

Dear all,

#8. Does APN violate network neutrality?

Answers: It’s important to realize that under the open Internet regulations there is still the possibility to do the differentiation. An easy example to understand is that in the FBB scenario, you can have different speeds on the access.

Moreover, any application can run on any QoS level. It is not necessary that all applications have to run on the same level, but any application can choose which QoS level it will run on, in the case where you have multiple QoS levels available.

APN offers application-aware network services open to all the applications, and it lets applications to decide themselves whether to go on board or not and which SLA levels they would like their traffic to be entitled.

Best regards,
Shuping

From: Lizhenbin
Sent: Monday, September 14, 2020 10:35 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>
Subject: Question List for APN

Hi Folks,
Thanks very much for your attention to APN work. After much preparation work, we summarized the key questions to be clarified for APN which also were always asked. In fact in the past discussion and the APN side meeting of IETF108, many of these questions were discussed and clarified. Here we propose these questions together for your convenience.

The questions to be clarified are as follows:
#1. Which layer is for APN to do the application-aware work?
#2. Does APN provide services within a limited-domain or Internet?
#3. Which area in IETF would the APN work fit better?
#4. What is the relationship between APN and other attempts in IETF’s history?
#5. What are the valuable use cases/usage scenarios of APN?
#6. Is the fine-granularity operations needed/desired in the network?
#7. Why not just use DSCP?
#8. Does APN violate network neutrality?
#9. Will APN raise security issues since application-aware information is carried in the APN packets?
#10. Will APN raise privacy issues since application-aware information is carried in the APN packets?

Shuping Peng will send the detailed answers for these questions in the mailing list in the following one or two weeks. The questions and answers may be not only be sent in the APN mailing list, but also be copied to the architecture discussion mailing list and the network token mailing list for more cross-area feedback if necessary.

If you have any comments on these questions and answers, we can go on to discuss through the mailing list.

Best Regards,
Zhenbin (Robin)

From: Apn [mailto:[email-masked]] On Behalf Of Lizhenbin
Sent: Tuesday, August 18, 2020 7:22 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Apn] Welcome to APN Mailing List

Hi Folks,

Welcome to join the APN mailing list. We are glad to have more discussion through the mailing list as the follow-up of the IETF108 APN side meeting.
In the process of APN work, many historic work items such as SPUD, PLUS, etc. have been proposed. It has been tried to be clarified that APN focuses
on the network layer and limited domains. Concerns on the security and privacy issues also have been proposed many times about the work. It also
has been tried to be clarified that in the trustable limited domains the security and privacy issues can be under control. These are the reasons why APN
work is based in the RTG area instead of ART/TSV areas.

But because of too much historic work to be clarified and its proposing the cross-area discussion for which RTG/APP/TSV/INT/SEC/IRTF are involved, it is
necessary to have more discussion to clarify the scope and work items for APN. We wish the mailing list would be helpful to the work and promoting the
cross-area communication to understand each other better.

You can get yourself up to speed with our discussions so far by seeing the materials at < https://github.com/APN-Community/>, especially the materials
From the virtual IETF 108  APN side meeting at < https://github.com/APN-Community/IETF108-Side-Meeting-APN>. This link also gives you pointers to
some of the relevant Internet-Drafts.

Over the next few weeks we will try to guide discussion by introducing some questions for debate. But please also raise your own issues and concerns
and contribute to the exchanges on this list.

Look forwarding to have more fun discussion in the mailing list.

Best Regards,
Dan & Zhenbin

---

From: Vittorio Bertola <[email-masked]>
Date: Thu, 1 Oct 2020 10:13:42 +0200 (CEST)

>     Il 01/10/2020 09:16 Sørensen, Frode <[email-masked]> ha scritto:
> 
> 
ISPs can also differentiate QoS on their own, as long as this is done "only on the basis of objectively different technical quality of service requirements (for example, in terms of latency, jitter, packet loss, and bandwidth) of the specific categories of traffic, and not on the basis of commercial considerations" (Recital 9 of the regulation). If an ISP wants to prioritize video streaming over other traffic they can do so, as long as they do so for all video streaming providers in the same way and they don't get paid for this.

Moreover, these European guidelines are then applied at the national level, so there are considerable differences across countries; and several ISPs just pretend they don't exist, e.g. with regard to "zero rating" offers.

-- 

Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked] mailto:[email-masked] 
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Eliot Lear <[email-masked]>
Date: Thu, 1 Oct 2020 10:22:01 +0200

Hi Shuping

I would suggest that this question not be given much time, since if you have two people in a room, they will have at least three definitions of “net neutrality”, and it just gets worse when you add more people.  I would you rather focus on what APN means for end-to-end security and privacy, and what information elements are available to intermediaries to make decisions (e.g., Questions 9 and 10 from below).

Eliot

> On 29 Sep 2020, at 02:54, Pengshuping (Peng Shuping) <[email-masked]> wrote:
> 
> Dear all,
>  
> To: [email-masked] <mailto:[email-masked]>
> Cc: Pengshuping (Peng Shuping) <[email-masked] <mailto:[email-masked]>>
>  <> 
> From: Apn [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Lizhenbin
> To: [email-masked] <mailto:[email-masked]>
> You can get yourself up to speed with our discussions so far by seeing the materials at < https://github.com/APN-Community/ <https://github.com/APN-Community/>>, especially the materials
> From the virtual IETF 108  APN side meeting at < https://github.com/APN-Community/IETF108-Side-Meeting-APN <https://github.com/APN-Community/IETF108-Side-Meeting-APN>>. This link also gives you pointers to
> _______________________________________________
> Architecture-discuss mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/architecture-discuss <https://www.ietf.org/mailman/listinfo/architecture-discuss>

---

From: Sørensen, Frode <[email-masked]>
Date: Thu, 1 Oct 2020 09:23:40 +0000

Thanks Vittorio,

That’s correct, if one does a full discussion of the European net neutrality regulation, there are two parallel ways of differentiating QoS for the internet access service: “level of QoS” under Article 3(2) and “categories of traffic” under Article 3(3), as elaborated in paragraphs 34b-34d in BEREC Open Internet guidelines.

However, in my former email, I wanted to share some general thoughts about the architecture that is discussed in the APN mailing list, and that under the net neutrality considerations, when discussing the concept of application-agnosticism, one should also take into account user-control.

Regarding the “categories of traffic” that you describe, it is still a QoS-oriented approach and not a purely application-oriented approach, since a “category of traffic” is based on the QoS requirements, which means any application with similar QoS requirements would have to be treated the same way, not limited to video streaming.

I don’t suggest to have the full solution, of course, and I do not intend to make a long discussion about this topic. I just think one should realize that it is a complex question, due to different understandings of the principle of net neutrality, as well as due to different jurisdictions.

Best,
Frode

Fra: Vittorio Bertola <[email-masked]>
Sendt: torsdag 1. oktober 2020 10:14
Til: Sørensen, Frode <[email-masked]>; Pengshuping (Peng Shuping) <[email-masked]>; [email-masked]
Kopi: [email-masked]; [email-masked]
Emne: Re: [arch-d] Question List for APN: Q#8

Il 01/10/2020 09:16 Sørensen, Frode <[email-masked]<mailto:[email-masked]>> ha scritto:

--

Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked]<mailto:[email-masked]>
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Tue, 13 Oct 2020 07:48:08 +0000

Hi Eliot,

Thank you for your suggestion.

For the considerations of security and privacy, we have also posted this draft below.

https://tools.ietf.org/html/draft-peng-apn-security-privacy-consideration-00

Best regards,
Shuping

From: Eliot Lear [mailto:[email-masked]]
Sent: Thursday, October 1, 2020 4:22 PM
To: Pengshuping (Peng Shuping) <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [arch-d] Question List for APN: Q#8

Hi Shuping

Eliot

On 29 Sep 2020, at 02:54, Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>> wrote:

Dear all,

Best regards,
Shuping

From: Lizhenbin

Hi Folks,

Best Regards,
Zhenbin (Robin)

Hi Folks,

Best Regards,
Dan & Zhenbin

_______________________________________________
Architecture-discuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/architecture-discuss