Subject: Re: [Apn] [Network-tokens] [arch-d] Questions for APN: Q#6 and Q#7

From: Lizhong Jin <[email-masked]>
Date: Fri, 2 Oct 2020 19:36:09 -0700

I believe this is a very initial draft for the authors of
*draft-li-6man-app-aware-ipv6-*network-02. Additional 256Bytes for only one
option would be a disaster for current various hardware design.

Lizhong

---------- Forwarded message ----------
From: [email-masked]
To: "Pengshuping (Peng Shuping)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <
[email-masked]>, "[email-masked]" <
[email-masked]>
Bcc:
Date: Tue, 29 Sep 2020 14:31:38 -0700
Subject: Re: [Network-tokens] [arch-d] Questions for APN: Q#6 and Q#7

>
> Hi Shuping,
>
> https://tools.ietf.org/html/draft-li-6man-app-aware-ipv6-network-02
>
> *Basically, the information carried in the IP layer is used for traffic
> steering policy selection within a limited APN network domain in order to
> guarantee the SLA requirements.*
>
>
>
> *I’m a little unclear on what I’m reading, so please pardon some
> clarifying questions.*
>
> *In this document, I’m seeing two options defined for use in IPv6
> extension headers.*
>
> *The application aware ID option appears to be up to 255 bytes long,
> variable length, and consists of three different structures.*
>
> *How does the forwarding engine determine which structure is in use? Can
> this option appear multiple times in the header? *
> *Within each structure, the fields are variable length, but there appears
> to be no way to determine how long the fields are.*
>
> *The service-para option appears to be a bit more structured.  Again, this
> appears to be variable length, up to 255 bytes.*
> *Within the option, we have numerous subTLVs. What is the purpose of the
> RESERVED fields? If you’re trying to retain alignment,*
> *didn’t that go out the window with a two byte option header?*
>
> *Does the delay sub-TLV indicate the overall path delay? Or the per-hop
> delay?  If the full path delay, how does a router know*
> *whether this has been satisfied?  Do systems along the path decrease this
> value as the packet is forwarded? How does a router*
> *know how much to decrement?*
>
> *Is 24 bits really necessary for the Delay Variation?  Is a jitter of 16s
> even meaningful?*
>
> *The packet loss ratio is a 24 bit (presumably unsigned) value.  Is this
> an integer? Normally ratios are expressed as a relation between multiple*
> *integers. What are the semantics here?*
>
> *Have you computed the amount of overhead that you will be introducing? It
> appears to me that you could easily have 1000 bytes of overhead per
> packet.  What does *
> *this do to service provider bandwidth consumption? What does this do to
> the ‘low-latency’ service that you want to provide?*
>
> *Tony*
>
>
>
>
>
>

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Tue, 13 Oct 2020 09:12:05 +0000

Hi Tony, Lizhong,

This goes into the details of implementations. Now it is still at the early design stage in IETF and waits for future work.

We also agree that 256B would be too long. The identifier is used for mapping into policies, so only a reasonable length is enough.

Best regards,
Shuping

From: Network-tokens [mailto:[email-masked]] On Behalf Of Lizhong Jin
Sent: Saturday, October 3, 2020 10:36 AM
To: [email-masked]
Cc: [email-masked]; Pengshuping (Peng Shuping) <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Network-tokens] [arch-d] Questions for APN: Q#6 and Q#7

I believe this is a very initial draft for the authors of draft-li-6man-app-aware-ipv6-network-02. Additional 256Bytes for only one option would be a disaster for current various hardware design.

Lizhong

---------- Forwarded message ----------
From: [email-masked]<mailto:[email-masked]>
To: "Pengshuping (Peng Shuping)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Bcc:
Date: Tue, 29 Sep 2020 14:31:38 -0700
Subject: Re: [Network-tokens] [arch-d] Questions for APN: Q#6 and Q#7

Hi Shuping,

Basically, the information carried in the IP layer is used for traffic steering policy selection within a limited APN network domain in order to guarantee the SLA requirements.

I’m a little unclear on what I’m reading, so please pardon some clarifying questions.

In this document, I’m seeing two options defined for use in IPv6 extension headers.

The application aware ID option appears to be up to 255 bytes long, variable length, and consists of three different structures.

How does the forwarding engine determine which structure is in use? Can this option appear multiple times in the header?
Within each structure, the fields are variable length, but there appears to be no way to determine how long the fields are.

The service-para option appears to be a bit more structured.  Again, this appears to be variable length, up to 255 bytes.
Within the option, we have numerous subTLVs. What is the purpose of the RESERVED fields? If you’re trying to retain alignment,
didn’t that go out the window with a two byte option header?

Does the delay sub-TLV indicate the overall path delay? Or the per-hop delay?  If the full path delay, how does a router know
whether this has been satisfied?  Do systems along the path decrease this value as the packet is forwarded? How does a router
know how much to decrement?

Is 24 bits really necessary for the Delay Variation?  Is a jitter of 16s even meaningful?

The packet loss ratio is a 24 bit (presumably unsigned) value.  Is this an integer? Normally ratios are expressed as a relation between multiple
integers. What are the semantics here?

Have you computed the amount of overhead that you will be introducing? It appears to me that you could easily have 1000 bytes of overhead per packet.  What does
this do to service provider bandwidth consumption? What does this do to the ‘low-latency’ service that you want to provide?

Tony