Subject: Extension Relation Type Comparison - LC Comment on draft-nottingham-http-plink-header-07

From: Eran Hammer-Lahav <[email-masked]>
Date: Mon, 25 Jan 2010 10:03:17 -0700

The current text about comparing extension relation types is unclear:

   When extension relation types are compared, they MUST be compared as
   URIs in a case-insensitive fashion, character-by-character.  Because
   of this, all-lowercase URIs SHOULD be used for extension relations.

What does it mean "compared as URIs"?

It is clear that these two URIs would be deemed equivalent:

http://example.com/rel/type
HTTP://example.COM/rel/TYPE

But are they also equivalent to:

http://example.com:80/rel/type

I would argue that normalizing URIs in this context is non-obvious and counter-intuitive. We are not using URIs for the purpose of resolving them, but only as a way to construct unique strings, using the URI format to define authority and minting rules.

I think we would be better off comparing extension relation types "as strings in a case-insensitive fashion, character-by-character".

EHL

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 28 Jan 2010 15:27:32 +1100

> http://example.com:80/rel/type

None of those are equivalent; it specifies case-insensitive, character-by-character. "As URIs" alludes to the fact that an extension type might be serialised in a non-URI form; e.g., as a CURIE, if that's your cup of tea. 

I'll try to clarify this in the next draft.

Cheers,

--
Mark Nottingham     http://www.mnot.net/

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Wed, 27 Jan 2010 21:50:03 -0700

> -----Original Message-----
> From: Mark Nottingham [mailto:[email-masked]]
> Sent: Wednesday, January 27, 2010 8:28 PM
> To: Eran Hammer-Lahav
> Cc: [email-masked]
> Subject: Re: Extension Relation Type Comparison - LC Comment on draft-
> nottingham-http-plink-header-07
> 
> 
> None of those are equivalent; it specifies case-insensitive, character-by-
> character. "As URIs" alludes to the fact that an extension type might be
> serialised in a non-URI form; e.g., as a CURIE, if that's your cup of tea.

I have talked to a few folks about this and they all assumed 'as URI' means that outside the lower-case exception, normal URI comparison rules apply. I agree with your intention though that these should be compared as case-insensitive strings.

EHL