Subject: Re: [apps-review] apps-team review of draft-ietf-speechsc-mrcpv2-24

From: SM <[email-masked]>
Date: Wed, 27 Apr 2011 10:28:44 -0700

Hi Larry,

I read your recommendation in the draft review of 
draft-ietf-speechsc-mrcpv2-24 as "do not publish".  I sent an email 
to Eric Burger who is the document shepherd.  I haven't received any reply yet.

I don't know what the Apps ADs' stance will be on this document.  I 
can only ask them to read the review and take it into consideration 
when the document goes through IESG Evaluation.  I hope that you will 
not be discouraged as documents do get published as RFCs even if they 
get bad reviews.  In my opinion, your expertise is put to waste as 
there are people on the apps-discuss mailing list who will read your 
review and learn something from it.

The following is what I found about draft-ietf-speechsc-mrcpv2:

Document shepherd write-up - June 2009
http://www.ietf.org/mail-archive/web/speechsc/current/msg02386.html

RAI review - June 2009
http://www.ietf.org/mail-archive/web/speechsc/current/msg02396.html

Sec-dir review - July 2010
http://www.ietf.org/mail-archive/web/secdir/current/msg01853.html

In general, I leave it to the author of an Internet-Draft to 
determine whether a review should be taken as constructive criticism 
and feedback on how to improve a document or whether it is merely a 
hurdle to overcome to get that magic RFC number.

Best regards,
-sm

---

From: Larry Masinter <[email-masked]>
Date: Wed, 27 Apr 2011 13:30:27 -0700

I'm willing to put more time into reviewing and working with the authors if I get feedback that my review comments will be considered.

Given that the protocol is already widely implemented interoperabily, the goal of getting a "RFC number" shouldn't override completely the goal of having a standard of quality for RFCs which rises to the level that a RFC can be understood by reading the RFC.

I think substantial editorial improvemenet could be made with, oh, a week's worth of work on the part of the editors fixing introductory material, clearing up references.

However, the most important thing for moving this document forward would be to insure that the normative requirements (MUST, MAY, SHOULD) are actually testable or at least determinable, in the path of moving the document to Draft Standard.... where each "feature" needs evaluation as to mulitple independent interoperable implementations of every feature.

Larry
--
http://larry.masinter.net

-----Original Message-----
From: SM [mailto:[email-masked]] 
Sent: Wednesday, April 27, 2011 10:29 AM
To: Larry Masinter
Cc: [email-masked]
Subject: RE: apps-team review of draft-ietf-speechsc-mrcpv2-24

Hi Larry,

RAI review - June 2009

Best regards,
-sm

---

From: SM <[email-masked]>
Date: Wed, 27 Apr 2011 15:21:43 -0700

Hi Larry,
At 13:30 27-04-2011, Larry Masinter wrote:
>I'm willing to put more time into reviewing and working with the 
>authors if I get feedback that my review comments will be considered.

The document contains 221 pages.  I am aware that you have already 
spent eight hours on this assignment.  I could say "thanks for 
putting in more time in the review" as it gets the work 
done.  Instead, I'll say that you have done more work than expected 
and it is good to consider whether the authors and working group will 
make good use of your expertise.

>Given that the protocol is already widely implemented 
>interoperabily, the goal of getting a "RFC number" shouldn't 
>override completely the goal of having a standard of quality for 
>RFCs which rises to the level that a RFC can be understood by reading the RFC.

Yes, but that's often ignored for the sake of expediency.

>I think substantial editorial improvemenet could be made with, oh, a 
>week's worth of work on the part of the editors fixing introductory 
>material, clearing up references.

Ok.

>However, the most important thing for moving this document forward 
>would be to insure that the normative requirements (MUST, MAY, 
>SHOULD) are actually testable or at least determinable, in the path 
>of moving the document to Draft Standard.... where each "feature" 
>needs evaluation as to mulitple independent interoperable 
>implementations of every feature.

There aren't a lot of RFCs that move from "Proposed" to 
"Draft".  Most working groups do not get their documents beyond 
"Proposed".  Convincing the IESG that it is worth the effort is not 
worth the effort. :-)

Please go ahead and post the review.

Best regards,
-sm

---

From: Eric Burger <[email-masked]>
Date: Wed, 27 Apr 2011 20:36:12 -0400

I would offer that after this long and our third editor, the only hope for editorial cleanup would be to have professionals do the cleaning, i.e., the RFC Editor.

The normative requirements issue is potentially a substantial issue that we will look into.

As SM says, Larry has already gone beyond the call of duty given the length and detail of this document.

On Apr 27, 2011, at 6:21 PM, SM wrote:

> The document contains 221 pages.  I am aware that you have already spent eight hours on this assignment.  I could say "thanks for putting in more time in the review" as it gets the work done.  Instead, I'll say that you have done more work than expected and it is good to consider whether the authors and working group will make good use of your expertise.
> 
> There aren't a lot of RFCs that move from "Proposed" to "Draft".  Most working groups do not get their documents beyond "Proposed".  Convincing the IESG that it is worth the effort is not worth the effort. :-)
> 
> _______________________________________________
> apps-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-review