Subject: [aqm] DOCSIS 3.1 support for AQM

From: Greg White <[email-masked]>
Date: Wed, 30 Oct 2013 20:13:23 +0000

FYI, the DOCSIS 3.1 specifications were released yesterday.   New in D3.1 is mandatory support for AQM (with default = on).

Cable modems are required to implement a variant of PIE (detailed in Annex M of MAC and Upper Layer Protocols Interface Specification<http://www.cablelabs.com/specifications/CM-SP-MULPIv3.1-101-131029.pdf>) as the default AQM.  Modem vendors are free to implement additional algorithms if they so choose.  CMTSs are required to implement an AQM meeting certain high-level criteria, but the choice of algorithm is left to the implementer.

-Greg

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Thu, 31 Oct 2013 09:25:25 +0100

Hi Greg,

Am 30.10.2013 21:13, schrieb Greg White:
> Cable modems are required to implement a variant of PIE (detailed in
> Annex M of MAC and Upper Layer Protocols Interface Specification
> <http://www.cablelabs.com/specifications/CM-SP-MULPIv3.1-101-131029.pdf>) as
> the default AQM.  Modem vendors are free to implement additional
> algorithms if they so choose.  CMTSs are required to implement an AQM
> meeting certain high-level criteria, but the choice of algorithm is left
> to the implementer.

Thanks for the information. I'd be interested in why you have chosen
PIE, e.g., instead of sfq-CoDel. Any pointers to evaluation
reports/results? Last time I saw a presentation on this it seemed
that CoDel was performing quite well.

Regards,
 Roland