Subject: [aqm] Fwd: draft-ksubram-lmap-router-buffer-sizes

From: "Fred Baker (fred)" <[email-masked]>
Date: Sat, 1 Nov 2014 23:39:06 +0000

Forwarded comments from AQM.

Begin forwarded message:

> From: David Collier-Brown <[email-masked]>
> Subject: Re: [aqm] draft-ksubram-lmap-router-buffer-sizes
> Date: October 31, 2014 at 11:03:39 AM PDT
> To: <[email-masked]>
> Reply-To: <[email-masked]>
> 
> It's OK, we just need to write it up as informational material and cite it a lot. Maybe as an appendix to a congestion-related rfc, maybe as a little bitty one on it's own.
> 
> Having said that, I guess I've just volunteered to write it.
> 
> Therefor: If someone says where it should go, so people will find it when looking for the expected behaviour, I'll compose a draft and help make it fit.
> 
> --dave
> 
> On 10/31/2014 10:58 AM, Daniel Havey wrote:
>> Yeah, I have encountered this type of problem in many forms.  It seems that there are fundamental misunderstandings of the problem.  This seems prevalent in expert networking communities from people who have the knowledge, but, perhaps have not thought the problem through thoroughly.
>> 
>> I guess we are just working at cross-purposes with other communities.  Perhaps there is no cure for this problem and maybe we just have to accept and embrace it.
>> 
>> 
>> ...Daniel
>> 
>> On Thursday, October 30, 2014 7:00 PM, David Collier-Brown <[email-masked]> wrote:
>> 
>> 
>> 
>> Yup: author makes a classic, and I fear common, wrong assumption about tradeoffs in queuing systems.
>> 
>> Latency is minimized throughout the operating range if a queue is not allowed to form. TCP consciously sees a queue as congestion and avoids having it.
>> 
>> Bufferboat causes queuing, and degrades both (low) latency and
>>       throughput, trying to  drive the link toward congestive collapse.
>>       The worst of all possible worlds!
>> 
>> In this case it also tries to drive Dave Taht's circulation system
>>       into collapse, which is doubly ungood.
>> 
>> --dave
>> 
>> 
>> 
>> On 10/30/2014 09:49 AM, Dave Taht wrote:
>> 
>> I didn't get past the first sentence. "The question boils down to quantify buffer sizes and yet achieve 100%
>> utilization on links with maximum throughput at a feasible cost. " My goal has always been to have minimal induced latency and reasonable
>> utilization, and also to keep my blood pressure low. Reading further
>> strikes me as damaging to both goals. On Thu, Oct 30, 2014 at 5:12 AM, Fred Baker (fred) <[email-masked]> wrote:

>>> Folks from AQM may be interested to comment on draft-ksubram-lmap-router-buffer-sizes on the lmap list. _______________________________________________
>> aqm mailing list [email-masked] https://www.ietf.org/mailman/listinfo/aqm
>> 
>> 
> 
> 
> -- 
> David Collier-Brown,         | Always do right. This will gratify
> System Programmer and Author | some people and astonish the rest
> [email-masked]           |                      -- Mark Twain
> 
> _______________________________________________
> aqm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aqm

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Sat, 1 Nov 2014 23:43:13 +0000

> It's OK, we just need to write it up as informational material and cite it a lot. Maybe as an appendix to a congestion-related rfc, maybe as a little bitty one on it's own.

One could argue that it is, or should be, in RFC 2309 and draft-ietf-aqm-recommendation. I think that has been waiting for the chairs to forward it to the IESG far too long already, so I’m not in a hurry to add to it. But if there is specific language that isn’t there and should be, and you want to propose text and placement, so be it.

---

From: Andrew Mcgregor <[email-masked]>
Date: Mon, 10 Nov 2014 13:04:57 -1000

Seems like the authors really need to read and understand
http://www.ikr.uni-stuttgart.de/Content/Publications/Archive/Bo_IP00_32462.pdf,
especially the implications of equations 25 and 26.  They're relevant here
too.

On 1 November 2014 13:43, Fred Baker (fred) <[email-masked]> wrote:

> > It's OK, we just need to write it up as informational material and cite
> it a lot. Maybe as an appendix to a congestion-related rfc, maybe as a
> little bitty one on it's own.
>
> One could argue that it is, or should be, in RFC 2309 and
> draft-ietf-aqm-recommendation. I think that has been waiting for the chairs
> to forward it to the IESG far too long already, so I’m not in a hurry to
> add to it. But if there is specific language that isn’t there and should
> be, and you want to propose text and placement, so be it.
>

-- 
Andrew McGregor | SRE | [email-masked] | +61 4 1071 2221