Subject: [aqm] ECN benefits ...

From: [email-masked]
Date: Mon, 10 Nov 2014 23:20:37 -0000

While I agree that the ECN benefits draft does not motivate any mechanism
for ECN. I think the draft, should simply echo the BCP AQM Recommendation
on ECN deployment:

 "Deployed AQM algorithms SHOULD support Explicit Congestion Notification
(ECN) as well as loss to signal congestion to endpoints." and refer to
that BCP.

Gorry

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 11 Nov 2014 00:08:14 +0000

> (ECN) as well as loss to signal congestion to endpoints." and refer to

Dumb question for you.

Where I was a little concerned, and raised a question from the mike, was the statement that "AQM algorithms MAY describe their use with ECN”. My concern is for interoperability.

My sense with any AQM algorithm is the it should take signals (marks or drops) coming at a certain rate to manage a given TCP session or combination of TCP sessions to maximize throughput while minimizing latency. There is some question of the distribution of the signals; CUBIC will respond differently to having three successive packets dropped than having three packets dropped an RTT or two apart. I wonder whether what we really want is some kind of draft that describes the pattern and rate we want to achieve, including observations like Bob’s desire to have the mark threshold differ from the drop threshold. What is of value in the algorithm descriptions is how the algorithm should be parameterized to achieve that common goal, not different goals.

Am I making sense?

---

From: Michael Welzl <[email-masked]>
Date: Mon, 10 Nov 2014 14:15:07 -1000

> On 10. nov. 2014, at 14.08, Fred Baker (fred) <[email-masked]> wrote:
> 
> 

I think that’s a mix-up: you spoke up for the ECN part of draft-ietf-aqm-eval-guidelines while Gorry’s comment was about draft-ietf-aqm-ecn-benefits - right?

Cheers,
Michael

> _______________________________________________
> aqm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aqm

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 11 Nov 2014 00:22:27 +0000

>> My sense with any AQM algorithm is the it should take signals (marks or drops) coming at a certain rate to manage a given TCP session or combination of TCP sessions to maximize throughput while mi…

Sorry. Yes, I commented in the wrong thread. That said, I think my question stands. It seems like it would be better for there to be some description of the intended result of ANY AQM algorithm in terms of rate and distribution, and the algorithm documents say how they are achieving that.