Subject: Re: [aqm] adoption of draft-white-aqm-docsis-pie-01

From: "Scheffenegger, Richard" <[email-masked]>
Date: Fri, 27 Mar 2015 21:52:46 +0000

Hi group,

as there haven't been any objections, but some indications of support on the list, and based on the responses in the IETF92 meeting in Dallas, we chairs think this document can be adopted as WG-item at this time.

Greg, can you please upload the most recent version as draft-ietf-aqm-docsis-pie-00?

Also, as mentioned in the meeting, and to make true of my promise, I would like to invite the following individuals to review this draft, once the updated version becomes available.

Mikael Abrahamsson
Dave Dolson
Szilveszter Nádas

Mostly everybody else who has commented during the meeting is already assigned to other documents (Nobody will be left out :)

Thanks,
  Richard (co-chair)

> -----Original Message-----
> From: aqm [mailto:[email-masked]] On Behalf Of Scheffenegger,
> Richard
> Sent: Donnerstag, 26. Februar 2015 08:45
> To: Greg White; [email-masked]'
> Cc: Rong Pan (ropan); [email-masked]
> Subject: Re: [aqm] adoption of draft-white-aqm-docsis-pie-01
> 
> Hi Greg, group,
> 
> 
> 
> Regarding the adoption call, this is something we can actually (and
> should) start on the list.
> 
> We can confirm that during the Dallas meeting in the room, but even before
> that, we'd like to get responses on the list now...
> 
> Perhaps we have some volunteers to review this new version as well...
> 
> 
> Best regards,
>   Richard
> 
> 
> 
> > -----Original Message-----
> > From: Greg White [mailto:[email-masked]]
> > Sent: Donnerstag, 26. Februar 2015 01:13
> > To: [email-masked]
> > Cc: Rong Pan (ropan)
> > Subject: Re: [aqm] agenda for IETF 92 / Dallas
> >
> > Wes & Richard,
> >
> > Unfortunately I will not be at IETF92 in person, but will attend
> remotely.
> >  For draft-white-aqm-docsis-pie, Rong & I updated it in January and
> > included a new appendix to give a change log, which reads:
> >
> > ===============
> > Appendix B.  Change Log
> > B.1.  Since draft-white-aqm-docsis-pie-01
> >
> >    Added Change Log.
> >
> >    Removed discussion of Packet drop de-randomization, Enhanced burst
> >    protection, and 16ms update interval, as these are now included in
> >    [I-D.ietf-aqm-pie].
> >
> > ===============
> >
> >
> > Regarding WG adoption, I saw some support from Lars (and no objections)
> to
> > adopting it on an Informational track.   Will you do an official
> adoption
> > call at the Dallas meeting?
> >
> > -Greg
> >
> >
> > On 2/23/15, 8:40 PM, "Wesley Eddy" <[email-masked]> wrote:
> >
> > >Greetings AQMers!  We requested a short AQM meeting slot at the
> > >upcoming IETF 92 meeting in Dallas, and we received a 1-hour slot on
> Tuesday:
> > >https://datatracker.ietf.org/meeting/92/agenda.html
> > >
> > >Since this is not a lot of time, we'll need to prioritize the work
> > >that is discussed to what requires the face-to-face time in order to
> > >make progress on.
> > >
> > >For active draft editors, please let us know via this list or
> > >[email-masked] what you think your meeting time needs are,
> > >so we can put together an agenda.  If you don't need meeting time
> > >now, or would like to use an interim telecon to assist in gathering
> > >feedback, please also let us know.
> > >
> > >For others, please read the drafts, comment on this mailing list, and
> > >help us to review and complete them:
> > >https://datatracker.ietf.org/wg/aqm/documents/
> > >
> > >Thanks in advance!
> > >
> > >--
> > >Wes Eddy
> > >MTI Systems
> > >
> > >_______________________________________________
> > >aqm mailing list
> > >[email-masked]
> > >https://www.ietf.org/mailman/listinfo/aqm
> 
> _______________________________________________
> aqm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aqm

---

From: Greg White <[email-masked]>
Date: Fri, 27 Mar 2015 22:46:39 +0000

Thanks all.  

I've submitted the draft.  Pending approval of the WG chairs, it will be
available for review.

-Greg

On 3/27/15, 3:52 PM, "Scheffenegger, Richard" <[email-masked]> wrote:

>Hi group,
>
>as there haven't been any objections, but some indications of support on
>the list, and based on the responses in the IETF92 meeting in Dallas, we
>chairs think this document can be adopted as WG-item at this time.
>
>
>Also, as mentioned in the meeting, and to make true of my promise, I
>would like to invite the following individuals to review this draft, once
>the updated version becomes available.
>
>Mikael Abrahamsson
>Dave Dolson
>Szilveszter Nádas
>
>Mostly everybody else who has commented during the meeting is already
>assigned to other documents (Nobody will be left out :)
>
>Thanks,
>  Richard (co-chair)
>
>
>

---

From: Fred Baker <[email-masked]>
Date: Fri, 27 Mar 2015 19:29:17 -0500

> On Mar 27, 2015, at 4:52 PM, Scheffenegger, Richard <[email-masked]> wrote:
> 

I agree.

---

From: Szilveszter Nadas <[email-masked]>
Date: Sun, 29 Mar 2015 09:16:35 +0000

Hi,

You have an interesting process to encourage mic comments. ;)

Reviewed version: "draft-ietf-aqm-docsis-pie-00".

I did read the document, looks good from clarity perspective. The changes compared to PIE also look reasonable.

I cannot judge however how well the algorithm estimates PIE behavior or how good is it in general. I did not read the references.

Questions:
-" 3.2. Departure rate estimation" Pie implements a rate estimator because it might be used with Fair Queueing schedulers. You write " Third, in the significant majority of cases, the departure rate, while variable, is controlled by the modem itself via the pair of
token bucket rate shaping equations described". I assume that Fair Queueing is either not implemented then in the modem or it is rarely used together with PIE. Is it so, or do I misunderstand this? Please clarify this for me and also in the document, if you think that is applicable! 

I propose the following updates (all optional in my view but it would definitely help the reader):
-State that the "[DOCSIS*" documents do contain simulation results. It was not clear for me from just reading the draft.
-Write a short (<0.5 page) summary of the simulation results in the appendix.

Cheers,
Szilveszter

-----Original Message-----
From: Scheffenegger, Richard [mailto:[email-masked]] 
Sent: Friday, March 27, 2015 16:53
To: Greg White; Mikael Abrahamsson; Dave Dolson; Szilveszter Nadas
Cc: [email-masked]; [email-masked]'
Subject: RE: [aqm] adoption of draft-white-aqm-docsis-pie-01

Hi group,

Mikael Abrahamsson
Dave Dolson
Szilveszter Nádas

Thanks,
  Richard (co-chair)

> We can confirm that during the Dallas meeting in the room, but even 
> before that, we'd like to get responses on the list now...
> 
> > >that is discussed to what requires the face-to-face time in order 
> > >to make progress on.
> > >
> > >[email-masked] what you think your meeting time needs 
> > >are, so we can put together an agenda.  If you don't need meeting 
> > >time now, or would like to use an interim telecon to assist in 
> > >gathering feedback, please also let us know.
> > >
> > >For others, please read the drafts, comment on this mailing list, 
> > >and help us to review and complete them:

---

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 30 Mar 2015 09:30:01 +0200 (CEST)

> Reviewed version: "draft-ietf-aqm-docsis-pie-00".

Me too.

Some suggestions and comments:

Abstract:

...
    "They are commonly positioned at the
    head of the bottleneck link for traffic in the upstream direction
    (from the customer),"

I find this sentence hard to read. I would suggest changes to the abstract 
along these lines (I will include _ around the changed parts)

"DOCSIS cable modems provide broadband Internet access to over one hundred 
million users worldwide.  They are commonly positioned _so that they 
handle the lowering speed adaptation in the upstream direction_ (from the 
customer) towards the Internet, and as a result, the impact of buffering 
and bufferbloat in the cable modem can have a significant effect on user 
experience.  The CableLabs DOCSIS specification _(introduced in)_ 3.1 
includes requirements for cable modems to support an Active Queue 
Management (AQM) algorithm that is intended to alleviate the impact that 
buffering has on latency sensitive traffic, while preserving bulk 
throughput performance.  In addition, the CableLabs DOCSIS 3.0 
specifications have also been amended to contain similar requirements."

I just feel that this makes it easier for a non-expert read by changing 
the second sentence to not talk about "head", and clarify that later that 
the AQM sections were introduced in 3.1 specification.

Section 1.

Here it says "CableLabs'" and in abstract it says "CableLabs" (without '). 
Is that correct?
I would recommend to add "upstream from the customer" in the second 
paragraph.

Section 3.

The list in 3 doesn't match the 3.1-3.4 headers, so my suggestion would be 
to get rid of the list in 3 and just keep the 3.1-3.4 headers.

Conclusion:

Then I read A, and that seems mostly to list changes to PIE for the 
DOCSIS-PIE implementation?

What is the aim of this document? To describe in an IETF environment what 
the DOCSIS-PIE implementation does? This is not stated in the abstract or 
introduction. I think it would be worthwhile to put in a few lines in 
either place to describe exactly what the aim of the document is, and 
potentially, what it isn't. Perhaps bump the overview from section 1 to 2 
and insert an introduction there?

It's my opinion that this is a document that is valuable to publish as an 
informational draft in IETF-AQM.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Greg White <[email-masked]>
Date: Mon, 30 Mar 2015 14:46:45 +0000

Szilveszter,

Thank you for the review and comments.  I will update the draft with your
suggestions. 

On your question, DOCSIS-PIE does not utilize fair queuing.  DOCSIS modems
do support multiple queues, but each queue is (generally) an independent
MAC layer service, with independent QoS configuration and scheduling.

The general-purpose PIE algorithm does rate estimation so that it can work
in systems where the egress rate is not otherwise known.  We did
experiment with an FQ-PIE implementation, as described in:

http://www.cablelabs.com/wp-content/uploads/2014/06/DOCSIS-AQM_May2014.pdf

Even in this case, we chose to not utilize egress rate estimation.

-Greg

On 3/29/15, 3:16 AM, "Szilveszter Nadas" <[email-masked]>
wrote:

>I cannot judge however how well the algorithm estimates PIE behavior or
>how good is it in general. I did not read the references.
>
>Questions:
>-" 3.2. Departure rate estimation" Pie implements a rate estimator
>because it might be used with Fair Queueing schedulers. You write "
>Third, in the significant majority of cases, the departure rate, while
>variable, is controlled by the modem itself via the pair of
>token bucket rate shaping equations described". I assume that Fair
>Queueing is either not implemented then in the modem or it is rarely used
>together with PIE. Is it so, or do I misunderstand this? Please clarify
>this for me and also in the document, if you think that is applicable!
>
>-State that the "[DOCSIS*" documents do contain simulation results. It
>was not clear for me from just reading the draft.

---

From: Greg White <[email-masked]>
Date: Mon, 30 Mar 2015 14:55:09 +0000

Mikael,

Thanks for the review and suggestions.  I will take them into account in
the next revision.

-Greg

---

From: Szilveszter Nadas <[email-masked]>
Date: Mon, 30 Mar 2015 16:01:36 +0000

Hi,

Thanks.

I suppose to add this information to the draft " DOCSIS modems do support multiple queues, but each queue is (generally) an independent MAC layer service, with independent QoS configuration and scheduling.".

Also on Mikael's comment. It would be good to add the purpose of the draft to the intro. I did the review with the assumption that the purpose is to document the DOCSIS PIE reommendation/solution. 

Cheers,
Sz.

-----Original Message-----
From: Greg White [mailto:[email-masked]] 
Sent: Monday, March 30, 2015 16:47
To: Szilveszter Nadas; Scheffenegger, Richard; Mikael Abrahamsson; Dave Dolson
Cc: [email-masked]; [email-masked]'
Subject: Re: [aqm] adoption of draft-white-aqm-docsis-pie-01

Szilveszter,

Thank you for the review and comments.  I will update the draft with your suggestions. 

On your question, DOCSIS-PIE does not utilize fair queuing.  DOCSIS modems do support multiple queues, but each queue is (generally) an independent MAC layer service, with independent QoS configuration and scheduling.

The general-purpose PIE algorithm does rate estimation so that it can work in systems where the egress rate is not otherwise known.  We did experiment with an FQ-PIE implementation, as described in:

-Greg

On 3/29/15, 3:16 AM, "Szilveszter Nadas" <[email-masked]>
wrote:

>I did read the document, looks good from clarity perspective. The 
>changes compared to PIE also look reasonable.
>
>variable, is controlled by the modem itself via the pair of token 
>bucket rate shaping equations described". I assume that Fair Queueing 
>is either not implemented then in the modem or it is rarely used 
>as there haven't been any objections, but some indications of support 
>on the list, and based on the responses in the IETF92 meeting in 
>Dallas, we chairs think this document can be adopted as WG-item at this time.
>
>
>would like to invite the following individuals to review this draft, 
>once the updated version becomes available.
>
>Mikael Abrahamsson
>Dave Dolson
>Szilveszter Nádas
>