Subject: Re: [aqm] adoption of draft-white-aqm-docsis-pie-01

From: Dave Dolson <[email-masked]>
Date: Wed, 1 Apr 2015 20:51:19 +0000

I'm also reviewing draft-ietf-aqm-docsis-pie-00
(https://tools.ietf.org/html/draft-ietf-aqm-docsis-pie-00) 

In section 3.4, an exponential delay aspect of PIE is mentioned. I just read https://tools.ietf.org/html/draft-ietf-aqm-pie-00 and saw no mention of this exponential delay. Did I miss it, or is it a mistake for the docsis document to reference this?

draft-ietf-aqm-docsis-pie-00 documents enabling and disabling of PIE control. Is enable/disable used with docsis-pie, or is it always on?

Otherwise, the document seems to contain enough information to document docsis-pie.
The algorithm in section A.2 has quite a few aspects that are not explained, but it seems precise.
(I don't have the knowledge to comment on whether it is accurate.)

-Dave

-----Original Message-----
From: Scheffenegger, Richard [mailto:[email-masked]] 
Sent: Friday, March 27, 2015 5:53 PM
To: Greg White; Mikael Abrahamsson; Dave Dolson; Szilveszter Nadas
Cc: [email-masked]; [email-masked]'
Subject: RE: [aqm] adoption of draft-white-aqm-docsis-pie-01

Hi group,

as there haven't been any objections, but some indications of support on the list, and based on the responses in the IETF92 meeting in Dallas, we chairs think this document can be adopted as WG-item at this time.

Greg, can you please upload the most recent version as draft-ietf-aqm-docsis-pie-00?

Also, as mentioned in the meeting, and to make true of my promise, I would like to invite the following individuals to review this draft, once the updated version becomes available.

Mikael Abrahamsson
Dave Dolson
Szilveszter Nádas

Mostly everybody else who has commented during the meeting is already assigned to other documents (Nobody will be left out :)

Thanks,
  Richard (co-chair)

> -----Original Message-----
> From: aqm [mailto:[email-masked]] On Behalf Of Scheffenegger,
> Richard
> Sent: Donnerstag, 26. Februar 2015 08:45
> To: Greg White; [email-masked]'
> Cc: Rong Pan (ropan); [email-masked]
> Subject: Re: [aqm] adoption of draft-white-aqm-docsis-pie-01
> 
> Hi Greg, group,
> 
> 
> 
> Regarding the adoption call, this is something we can actually (and
> should) start on the list.
> 
> We can confirm that during the Dallas meeting in the room, but even before
> that, we'd like to get responses on the list now...
> 
> Perhaps we have some volunteers to review this new version as well...
> 
> 
> Best regards,
>   Richard
> 
> 
> 
> > -----Original Message-----
> > From: Greg White [mailto:[email-masked]]
> > Sent: Donnerstag, 26. Februar 2015 01:13
> > To: [email-masked]
> > Cc: Rong Pan (ropan)
> > Subject: Re: [aqm] agenda for IETF 92 / Dallas
> >
> > Wes & Richard,
> >
> > Unfortunately I will not be at IETF92 in person, but will attend
> remotely.
> >  For draft-white-aqm-docsis-pie, Rong & I updated it in January and
> > included a new appendix to give a change log, which reads:
> >
> > ===============
> > Appendix B.  Change Log
> > B.1.  Since draft-white-aqm-docsis-pie-01
> >
> >    Added Change Log.
> >
> >    Removed discussion of Packet drop de-randomization, Enhanced burst
> >    protection, and 16ms update interval, as these are now included in
> >    [I-D.ietf-aqm-pie].
> >
> > ===============
> >
> >
> > Regarding WG adoption, I saw some support from Lars (and no objections)
> to
> > adopting it on an Informational track.   Will you do an official
> adoption
> > call at the Dallas meeting?
> >
> > -Greg
> >
> >
> > On 2/23/15, 8:40 PM, "Wesley Eddy" <[email-masked]> wrote:
> >
> > >Greetings AQMers!  We requested a short AQM meeting slot at the
> > >upcoming IETF 92 meeting in Dallas, and we received a 1-hour slot on
> Tuesday:
> > >https://datatracker.ietf.org/meeting/92/agenda.html
> > >
> > >Since this is not a lot of time, we'll need to prioritize the work
> > >that is discussed to what requires the face-to-face time in order to
> > >make progress on.
> > >
> > >For active draft editors, please let us know via this list or
> > >[email-masked] what you think your meeting time needs are,
> > >so we can put together an agenda.  If you don't need meeting time
> > >now, or would like to use an interim telecon to assist in gathering
> > >feedback, please also let us know.
> > >
> > >For others, please read the drafts, comment on this mailing list, and
> > >help us to review and complete them:
> > >https://datatracker.ietf.org/wg/aqm/documents/
> > >
> > >Thanks in advance!
> > >
> > >--
> > >Wes Eddy
> > >MTI Systems
> > >
> > >_______________________________________________
> > >aqm mailing list
> > >[email-masked]
> > >https://www.ietf.org/mailman/listinfo/aqm
> 
> _______________________________________________
> aqm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aqm

---

From: Greg White <[email-masked]>
Date: Thu, 2 Apr 2015 20:48:48 +0000

Thanks for the review Dave.

I double checked with Rong, and the exponential decay of drop probability
was inadvertently removed from the PIE pseudocode (I think she mentioned
this in the other thread as well).

In terms of enable/disable, there are two aspects.  One is that the
DOCSIS-PIE algorithm is enabled by default, but can be disabled via
explicit configuration by the network operator. The other is that the PIE
algorithm has a built-in concept of being ACTIVE vs INACTIVE.  In the
pseudocode of the PIE draft these capitalized terms are used, but in the
description in section 5.1 of the PIE draft, this same functionality is
referred to as "Turning PIE on and off".  Maybe this is an opportunity to
clean up the language in the PIE draft so it is more consistent.
DOCSIS-PIE supports the Active/Inactive aspect, but makes some adjustments
to the logic from what is included in the PIE pseudocode (and uses
different terminology).  I'll add a section that describes the deltas
there and also I'll try to re-align the terminology in the DOCSIS-PIE
pseudocode so that it matches PIE.

-Greg

On 4/1/15, 2:51 PM, "Dave Dolson" <[email-masked]> wrote:

>In section 3.4, an exponential delay aspect of PIE is mentioned. I just
>read https://tools.ietf.org/html/draft-ietf-aqm-pie-00 and saw no mention
>of this exponential delay. Did I miss it, or is it a mistake for the
>docsis document to reference this?
>
>
>draft-ietf-aqm-docsis-pie-00 documents enabling and disabling of PIE
>control. Is enable/disable used with docsis-pie, or is it always on?
>
>
>as there haven't been any objections, but some indications of support on
>the list, and based on the responses in the IETF92 meeting in Dallas, we
>chairs think this document can be adopted as WG-item at this time.
>
>
>Also, as mentioned in the meeting, and to make true of my promise, I
>would like to invite the following individuals to review this draft, once
>the updated version becomes available.
>
>Mikael Abrahamsson
>Dave Dolson
>Szilveszter Nádas
>
>Mostly everybody else who has commented during the meeting is already
>assigned to other documents (Nobody will be left out :)
>
>Thanks,
>  Richard (co-chair)
>
>
>

---

From: "Rong Pan (ropan)" <[email-masked]>
Date: Thu, 2 Apr 2015 21:49:53 +0000

Greg,

Good suggestion of keeping DOCSIS-PIE and PIE drafts consistent. Let's
sync up and make sure they are consistent.

Thanks,

Rong