Subject: [aqm] FQ-PIE kernel module implementation

From: "Hironori Okano -X (hokano - AAP3 INC at Cisco)" <[email-masked]>
Date: Thu, 4 Jun 2015 22:06:59 +0000

Hi all,

I’m Hironori Okano and Fred’s intern.
I’d like to let you know that I have implemented FQ-PIE as a linux kernel module “fq-pie" and iproute2 for fq-pie.
This was done in collaboration with others at Cisco including Fred Baker, Rong Pan, Bill Ver Steeg, and Preethi Natarajan.

The source codes are in my github repository. I attached patch file “fq-pie_patch.tar.gz” to this email also.
I’m using the latest linux kernel (git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git)

fq-pie kernel module
https://github.com/hironoriokano/fq-pie.git

iproute2 for fq-pie
https://github.com/hironoriokano/iproute2_fq-pie.git

If you have any comments, please reach out to me.

Best regards,

Hironori Okano
[email-masked]

---

From: Dave Taht <[email-masked]>
Date: Thu, 4 Jun 2015 15:18:32 -0700

On Thu, Jun 4, 2015 at 3:06 PM, Hironori Okano -X (hokano - AAP3 INC
at Cisco) <[email-masked]> wrote:
> This was done in collaboration with others at Cisco including Fred Baker,
> Rong Pan, Bill Ver Steeg, and Preethi Natarajan.
>
> The source codes are in my github repository. I attached patch file
> “fq-pie_patch.tar.gz” to this email also.
> I’m using the latest linux kernel
> (git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git)
>
> fq-pie kernel module

Very cool. I have been building this as part of my testbed for some
time now with some very impressive results.

I will update my openwrt tree to pull from yours (if possible, openwrt
is still largely linux-3.18 based, otherwise I might have to slip in
some backport code)

https://github.com/dtaht/ceropackages-3.10/tree/master/net/kmod-sched-fq_pie

thanks for such a cool and interesting qdisc!

> Hironori Okano
> [email-masked]
>
> _______________________________________________
> aqm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aqm
>

-- 
Dave Täht
What will it take to vastly improve wifi for everyone?
https://plus.google.com/u/0/explore/makewififast

---

From: Simon Barber <[email-masked]>
Date: Fri, 05 Jun 2015 11:02:56 -0700

Very cool. Does this mean that Cisco are not planning on enforcing any 
IP rights over PIE?

Simon

On 6/4/2015 3:06 PM, Hironori Okano -X (hokano - AAP3 INC at Cisco) wrote:
> I’d like to let you know that I have implemented FQ-PIE as a linux 
> kernel module “fq-pie" and iproute2 for fq-pie.
> This was done in collaboration with others at Cisco including Fred 
> Baker, Rong Pan, Bill Ver Steeg, and Preethi Natarajan.
>
> Bloat mailing list
> [email-masked]
> https://lists.bufferbloat.net/listinfo/bloat

---

From: "Bill Ver Steeg (versteb)" <[email-masked]>
Date: Mon, 8 Jun 2015 10:14:36 +0000

The legal answer is "read the IPR disclosure at the IETF" and "read the copy write notice in the code".

I think that you will like what you find, though....... The broad intent is to fix the bloat problem in as many places as possible.

Bill VerSteeg

From: [email-masked] [mailto:[email-masked]] On Behalf Of Simon Barber
Sent: Friday, June 05, 2015 8:03 PM
To: Hironori Okano -X (hokano - AAP3 INC at Cisco); [email-masked]; [email-masked]
Cc: Rong Pan (ropan); Preethi Natarajan (prenatar)
Subject: Re: [Bloat] FQ-PIE kernel module implementation

Very cool. Does this mean that Cisco are not planning on enforcing any IP rights over PIE?

Simon

I'm Hironori Okano and Fred's intern.
I'd like to let you know that I have implemented FQ-PIE as a linux kernel module "fq-pie" and iproute2 for fq-pie.
This was done in collaboration with others at Cisco including Fred Baker, Rong Pan, Bill Ver Steeg, and Preethi Natarajan.

The source codes are in my github repository. I attached patch file "fq-pie_patch.tar.gz" to this email also.
I'm using the latest linux kernel (git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git)

fq-pie kernel module

iproute2 for fq-pie

Best regards,

Hironori Okano
[email-masked]<mailto:[email-masked]>

Bloat mailing list

[email-masked]<mailto:[email-masked]>

---

From: "Bill Ver Steeg (versteb)" <[email-masked]>
Date: Mon, 8 Jun 2015 10:21:06 +0000

The IETF disclosure statement is here.
http://datatracker.ietf.org/ipr/2187/

The important stuff is copied below.

If this standard is adopted, Cisco will not assert any patents owned or controlled by Cisco against any party for making, using, selling, importing or offering for sale a product that implements the standard, provided, however that Cisco retains the right to assert its patents (including the right to claim past royalties) against any party that asserts a patent it owns or controls (either directly or indirectly) against Cisco or any of Cisco's affiliates or successors in title or against any products of Cisco or any products of any of Cisco's affiliates either alone or in combination with other products; and Cisco retains the right to assert its patents against any product or portion thereof that is not necessary for compliance with the standard.

Royalty-bearing licenses will be available to anyone who prefers that option.

bvs

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bill Ver Steeg (versteb)
Sent: Monday, June 08, 2015 12:15 PM
To: Simon Barber; Hironori Okano -X (hokano - AAP3 INC at Cisco); [email-masked]; [email-masked]
Cc: Rong Pan (ropan); Preethi Natarajan (prenatar)
Subject: Re: [Bloat] FQ-PIE kernel module implementation

Bill VerSteeg

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Simon Barber
Sent: Friday, June 05, 2015 8:03 PM
To: Hironori Okano -X (hokano - AAP3 INC at Cisco); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Rong Pan (ropan); Preethi Natarajan (prenatar)
Subject: Re: [Bloat] FQ-PIE kernel module implementation

Simon

fq-pie kernel module

iproute2 for fq-pie

Best regards,

Hironori Okano

Bloat mailing list

---

From: Polina Goltsman <[email-masked]>
Date: Wed, 10 Jun 2015 10:56:51 +0200

Hello all,

If I understood the code correctly, in fq_pie there is a single PIE 
instance that controls all "fq" queues. In contrast in fq_codel there is 
a separate instance of codel for each queue. Is this the case? If it is, 
doesn't it contradict with original idea of fq_something where each 
queue is supposed to be managed by "its own" AQM?

Thanks in advance,
Best Regards,
   Polina

On 06/05/2015 12:06 AM, Hironori Okano -X (hokano - AAP3 INC at Cisco)

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 17 Jun 2015 20:17:42 +0000

> On Jun 5, 2015, at 11:02 AM, Simon Barber <[email-masked]> wrote:
> 

I think Cisco stands by its IPR statement on the topic.

>> https://github.com/hironoriokano/fq-pie.git <https://github.com/hironoriokano/fq-pie.git>
>> 
>> iproute2 for fq-pie
>> https://github.com/hironoriokano/iproute2_fq-pie.git <https://github.com/hironoriokano/iproute2_fq-pie.git>
>> 
>> [email-masked] <mailto:[email-masked]>
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://lists.bufferbloat.net/listinfo/bloat <https://lists.bufferbloat.net/listinfo/bloat>
>