Subject: [aqm] Alia Atlas' Yes on draft-ietf-aqm-fq-implementation-03: (with COMMENT)

From: "Alia Atlas" <[email-masked]>
Date: Wed, 21 Oct 2015 15:22:20 -0700

Alia Atlas has entered the following ballot position for
draft-ietf-aqm-fq-implementation-03: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-aqm-fq-implementation/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for a clear and well-written draft.

I would like to understand the reference of "Weighted Fair Queues" and
have
that clarified in the draft.  It's a technical concern, but I have
confidence that
the authors and ADs will address it.

1) Sec 2.2.3 refers to "Weighted Fair Queues" as well as "Calendar
Queues".
Perhaps it is due to a lack in my recent background - but what's
described is
nothing like Weighted Fair Queuing
(https://en.wikipedia.org/wiki/Weighted_fair_queueing).
Do you have a reference for "Weighted Fair Queues" or something else in
mind??

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Thu, 22 Oct 2015 15:57:38 +0000

> On Oct 21, 2015, at 6:22 PM, Alia Atlas <[email-masked]> wrote:
> 
> I would like to understand the reference of "Weighted Fair Queues" and have that clarified in the draft. It's a technical concern, but I have confidence that the authors and ADs will address it.
> 
> 1) Sec 2.2.3 refers to "Weighted Fair Queues" as well as "Calendar Queues". Perhaps it is due to a lack in my recent background - but what's described is nothing like Weighted Fair Queuing (https://en.wikipedia.org/wiki/Weighted_fair_queueing). Do you have a reference for "Weighted Fair Queues" or something else in mind??

Thanks for your question. The original intent of this draft was simply to support a discussion, which I expected might be closed without needing to publish an RFC. The working group decided that it wanted to adopt and publish the note, which is fine as well.

I think what you're looking at is the difference between theory and practice. As you know, in theory, they are the same thing, and in practice there can be important differences. If you read early papers, such as McKenny's SFQ or Lixia Zhang's Virtual Clock, they talk a lot about WRR-based implementations; calendar queues came later. But no real implementation I am aware of (I have written two and am aware of several others) attempts to implement GPS as the GPS paper describes it - nor does the GPS paper expect them to. That's why that section in the draft is titled "Approximations to GPS" - any implementation is necessarily an approximation, and GPS describes the theoretical best case they are trying to approximate.

---

From: Alia Atlas <[email-masked]>
Date: Thu, 22 Oct 2015 12:01:38 -0400

Fred,

What I am saying is that I have worked with and verified implementations of
Weighted Fair Queuing - and it is not Calendar Queues - certainly not as
this
draft describes it.  Can you please provide a reference to what Weighted
Fair
Queues means - if it isn't Weighted Fair Queuing, or fix the draft's
description
(which could be merely mentioning Weighted Fair Queuing as a different
work-conserving approach).

I realize that this is tangential to the point of the draft (or it would
have been
a Discuss), but I still would strongly prefer accuracy.

Regards,
Alia

On Thu, Oct 22, 2015 at 11:57 AM, Fred Baker (fred) <[email-masked]> wrote:

> > Please refer to
> https://www.ietf.org/iesg/statement/discuss-criteria.html
> have that clarified in the draft. It's a technical concern, but I have
> confidence that the authors and ADs will address it.
> >
> Queues". Perhaps it is due to a lack in my recent background - but what's
> described is nothing like Weighted Fair Queuing (
> https://en.wikipedia.org/wiki/Weighted_fair_queueing). Do you have a
> reference for "Weighted Fair Queues" or something else in mind??
>
> Thanks for your question. The original intent of this draft was simply to
> support a discussion, which I expected might be closed without needing to
> publish an RFC. The working group decided that it wanted to adopt and
> publish the note, which is fine as well.
>
> I think what you're looking at is the difference between theory and
> practice. As you know, in theory, they are the same thing, and in practice
> there can be important differences. If you read early papers, such as
> McKenny's SFQ or Lixia Zhang's Virtual Clock, they talk a lot about
> WRR-based implementations; calendar queues came later. But no real
> implementation I am aware of (I have written two and am aware of several
> others) attempts to implement GPS as the GPS paper describes it - nor does
> the GPS paper expect them to. That's why that section in the draft is
> titled "Approximations to GPS" - any implementation is necessarily an
> approximation, and GPS describes the theoretical best case they are trying
> to approximate.
>

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Thu, 22 Oct 2015 16:06:56 +0000

> On Oct 22, 2015, at 12:01 PM, Alia Atlas <[email-masked]> wrote:
> 
> Fred,
> 
> Weighted Fair Queuing - and it is not Calendar Queues - certainly not as this
> draft describes it.  Can you please provide a reference to what Weighted Fair
> Queues means - if it isn't Weighted Fair Queuing, or fix the draft's description
> I realize that this is tangential to the point of the draft (or it would have been

I can include a link to http://www.isi.edu/nsnam/ns/doc/node643.html#Brow88:Calendar <http://www.isi.edu/nsnam/ns/doc/node643.html#Brow88:Calendar> if that helps.

> Regards,
> Alia
> 
> On Thu, Oct 22, 2015 at 11:57 AM, Fred Baker (fred) <[email-masked] <mailto:[email-masked]>> wrote:
> 
> > On Oct 21, 2015, at 6:22 PM, Alia Atlas <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html <https://www.ietf.org/iesg/statement/discuss-criteria.html>
> > https://datatracker.ietf.org/doc/draft-ietf-aqm-fq-implementation/ <https://datatracker.ietf.org/doc/draft-ietf-aqm-fq-implementation/>
> >
> >
> >
> > 1) Sec 2.2.3 refers to "Weighted Fair Queues" as well as "Calendar Queues". Perhaps it is due to a lack in my recent background - but what's described is nothing like Weighted Fair Queuing (https://en.wikipedia.org/wiki/Weighted_fair_queueing <https://en.wikipedia.org/wiki/Weighted_fair_queueing>). Do you have a reference for "Weighted Fair Queues" or something else in mind??
>