Subject: Re: [aqm] [tcpm] [tcpPrague] [tsvwg] (Bar) BoF @IETF-95 'Ultra-Low Queuing Delay for All' (L4S, DualQ Coupled AQM, TCP Prague)?

From: Bob Briscoe <[email-masked]>
Date: Fri, 1 Apr 2016 15:16:05 +0100

Aaron,

Thanks for reminding me.
I completely lost track of doing this back in Feb (typically a symptom 
of my machine crashing, 'cos my own memory got corrupted years ago).

I have requested a room from the secretariat for a 1hr session on 
Thursday 8 Apr 2016, preferably 9-10am, otherwise 16:20-17:20pm.
I'll confirm on these lists as soon as I know.

If we get 1st choice, apologies to those who were hoping to enjoy the 
new relaxed 10am start to IETF meetings
The 2nd choice was picked in an attempt to avoid any relevant WG 
sessions, but it does clash with the fun-packed IAOC Meeting Venue 
Selection Criteria & Procedures BoF.

Cheers

Bob

On 30/03/16 21:13, Aaron Falk wrote:
> Did this get scheduled?
>
> --aaron
>
> On Mon, Feb 22, 2016 at 12:21 PM, Spencer Dawkins at IETF 
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
>     Just to try to be helpful ...
>
>     On Mon, Feb 22, 2016 at 2:54 AM, Bob Briscoe <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         John,
>
>         On 19/02/16 18:23, John Leslie wrote:
>
>             Bob Briscoe <[email-masked]
>             <mailto:[email-masked]>> wrote:
>
>                 I'm cross-posting 'cos this impacts 3 IETF WGs and
>                 interested implementers.
>
>                 We would like to propose a Bar BoF at the Buenos Aires
>                 IETF, about L4S,
>                 DualQ and solutions to the TCP Prague Requirements.
>
>                 This feels like it belongs as a non-WG-forming formal BoF.
>
>                 It describes work spanning at least three WGs; and
>             could benefit from
>             formal scheduling to avoid conflicts with those WGs and
>             others.
>
>                 OTOH, it really isn't to the point where a WG charter
>             can reasonably
>             be drafted. First we must decide whether the work _can_ be
>             split among
>             existing WGs.
>
>                 However this may turn out, I wish to participate remotely.
>
>         OK, we'll see if the secretariat can help us with that.
>
>
>     I believe that happens at http://www.ietf.org/meeting/amreq.html.
>     If you put "TSV" in as "type of meeting", your happy TSV ADs would
>     see the request.
>
>     Thanks,
>
>     Spencer
>
>         Unfortunately we ran out of time for the formal BoF deadline
>         on Friday.
>
>
>         Bob
>
>
>             --
>             John Leslie <[email-masked] <mailto:[email-masked]>>
>
>             _______________________________________________
>             tcpPrague mailing list
>             [email-masked] <mailto:[email-masked]>
>             https://www.ietf.org/mailman/listinfo/tcpprague
>
>
>         -- 
>         ________________________________________________________________
>         Bob Briscoe http://bobbriscoe.net/
>
>
>
>     _______________________________________________
>     tcpm mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/tcpm
>
>
>
>
> _______________________________________________
> aqm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aqm

-- 
________________________________________________________________
Bob Briscoe                               http://bobbriscoe.net/

---

From: Bob Briscoe <[email-masked]>
Date: Tue, 5 Apr 2016 13:02:43 +0100

Folks,

We have a time and room for this Bar BoF:
Date/time: 09:00 - 10:00 ART (= 12-13:00 UTC) Thu 7 Apr 2016
Room: Quebracho B

We have the regular IETF remote attendance facilities in that room.
The room is not being used for the following session, so we don't have 
to vacate early.

We're building the agenda - will send shortly.
We want to allow most time for people to talk from the floor.

The general structure will be:
* Introduction/Background
* Clarification Questions
* Recent Activity: Design / Evaluation / Industry
* Build a standardisation roadmap
* Build a BoF for the Berlin timeframe, and should it be non-WG forming.
* Discussion / Q&A

Sorry for delay setting this up. My fault.
I've bcc'd a few people who have been asking about this specifically.

Bob

---

From: Bob Briscoe <[email-masked]>
Date: Thu, 7 Apr 2016 00:44:03 +0100

Folks,

Reminder, agenda & supporting materials below for the Bar BoF on L4S / 
DualQ Coupled AQM / TCP Prague

*Event details**
*Date/time: 09:00 - 10:00 local time (ART = 12-13:00 UTC) Thu 7 Apr 2016
Room: Quebracho B

*Supporting materials / background:**
*https://riteproject.eu/dctth/
To use the time effectively, it will be assumed that people have a 
working knowledge of what the technology is, and a rough idea of how it 
works.
For those wanting an introduction, a useful 2-pager in the IETF Journal 
is linked from the above, plus videos of the demos etc.b
Or chat with us afterwards

*Proposed Agenda:**
***09:00
* Note Well, Agenda Bashing [Bob]
* Introduction/Background (very brief) [Bob]
* Clarification Questions
09:15
* Status updates [Koen to lead], e.g.:
   - what people are doing on parts of the problem:
   - planned work
   - evaluation work
   - interest in implementing
   - willingness to review
09:40
* Build a standardisation roadmap [Bob to lead]
* Build a BoF for the Berlin time-frame
    - should it be non-WG forming?
    - volunteers to help with organisation / writing problem statement, etc.
    - which mailing list?
    - what name?
* Discussion / Q&A
09:55 end

Most time will be allowed for people to talk from the floor.

Cheers

Bob & Koen

On 05/04/16 13:02, Bob Briscoe wrote:
>> <[email-masked]> wrote:
>>
>>     On Mon, Feb 22, 2016 at 2:54 AM, Bob Briscoe
>>     <[email-masked]> wrote:
>>
>>         John,
>>
>>                 We would like to propose a Bar BoF at the Buenos
>>                 Aires IETF, about L4S,
>>             be drafted. First we must decide whether the work _can_
>>             be split among
>>             existing WGs.
>>
>>     If you put "TSV" in as "type of meeting", your happy TSV ADs
>>     would see the request.
>>
>>     Thanks,
>>
>>     Spencer
>>
> Bob Briscoehttp://bobbriscoe.net/
>
> --

---

From: Bob Briscoe <[email-masked]>
Date: Thu, 7 Apr 2016 11:44:50 +0100

Folks,

Some slides to frame the discussion at 9am this morning are uploaded to:
https://riteproject.eu/dctth/#ietf-bar-bof
Nonetheless, we want most of the time to be for discussion.

Phil Eardley has agreed to chair the meeting. He has suggested:
*Aim of meeting:**
** To determine whether there is interest in working on this.
* To work out how to get the IETF to work on these pieces (ie the 
meeting is not primarily a technical discussion)

Aaron Falk has kindly agreed to take notes.
We will need a volunteer for jabber scribe, as we have remote attendees.

Cheers

Bob

On 07/04/16 00:44, Bob Briscoe wrote:
> working knowledge of what the technology is, and a rough idea of how 
> it works.
> For those wanting an introduction, a useful 2-pager in the IETF 
> Journal is linked from the above, plus videos of the demos etc.b
>> The room is not being used for the following session, so we don't 
>> have to vacate early.
>>
>>>                 OTOH, it really isn't to the point where a WG
>>>             charter can reasonably
>>>     I believe that happens at
>>>     http://www.ietf.org/meeting/amreq.html. If you put "TSV" in as
>>>     "type of meeting", your happy TSV ADs would see the request.
>>>
>>>     Thanks,
>>>
>>>     Spencer
>>>
>>>             John Leslie <[email-masked]>
>>>

---

From: Matthew Ford <[email-masked]>
Date: Thu, 7 Apr 2016 08:13:41 -0300

Thanks for sharing these in advance Bob. Slide 10 of the first deck is priceless!

> On 7 Apr 2016, at 07:44, Bob Briscoe <[email-masked]> wrote:
> 
> Folks,
> 
> Aim of meeting:
> * To determine whether there is interest in working on this.
> * To work out how to get the IETF to work on these pieces (ie the meeting is not primarily a technical discussion)
> 
>> Reminder, agenda & supporting materials below for the Bar BoF on L4S / DualQ Coupled AQM / TCP Prague
>> 
>> Event details
>> Date/time: 09:00 - 10:00 local time (ART = 12-13:00 UTC) Thu 7 Apr 2016
>> Room: Quebracho B
>> 
>> Supporting materials / background:
>> https://riteproject.eu/dctth/
>> To use the time effectively, it will be assumed that people have a working knowledge of what the technology is, and a rough idea of how it works.
>> For those wanting an introduction, a useful 2-pager in the IETF Journal is linked from the above, plus videos of the demos etc.b 
>> Proposed Agenda:
>> 09:00
>>> The room is not being used for the following session, so we don't have to vacate early.
>>> 
>>>> On Mon, Feb 22, 2016 at 12:21 PM, Spencer Dawkins at IETF <[email-masked]> wrote:
>>>> On Mon, Feb 22, 2016 at 2:54 AM, Bob Briscoe <[email-masked]> wrote:
>>>> John,
>>>> 
>>>> Bob Briscoe <[email-masked]> wrote:
>>>> I'm cross-posting 'cos this impacts 3 IETF WGs and interested implementers.
>>>> 
>>>> We would like to propose a Bar BoF at the Buenos Aires IETF, about L4S,
>>>>     It describes work spanning at least three WGs; and could benefit from
>>>> formal scheduling to avoid conflicts with those WGs and others.
>>>> 
>>>>     OTOH, it really isn't to the point where a WG charter can reasonably
>>>> be drafted. First we must decide whether the work _can_ be split among
>>>> existing WGs.
>>>> 
>>>> I believe that happens at http://www.ietf.org/meeting/amreq.html. If you put "TSV" in as "type of meeting", your happy TSV ADs would see the request.
>>>> 
>>>> Thanks,
>>>> 
>>>> Spencer
>>>>  
>>>> Unfortunately we ran out of time for the formal BoF deadline on Friday.
>>>> 
>>>> 
>>>> Bob
>>>> 
>>>> 
>>>> --
>>>> [email-masked]
>>>> [email-masked]

---

From: Aaron Falk <[email-masked]>
Date: Thu, 7 Apr 2016 09:03:29 -0300

Note taking is happening here:
http://etherpad.tools.ietf.org:9000/p/notes-ietf-95-l4s-barbof

On Thu, Apr 7, 2016 at 8:13 AM, Matthew Ford <[email-masked]> wrote:

> >>>> I believe that happens at http://www.ietf.org/meeting/amreq.html. If
> you put "TSV" in as "type of meeting", your happy TSV ADs would see the
> request.
> >>>>
> >>>> Thanks,
> >>>>
> >>>> Spencer
> >>>>