Subject: [aqm] Dummynet AQM v0.2- CoDel, FQ-CoDel, PIE and FQ-PIE for FreeBSD's ipfw/dummynet

From: Rasool Al-Saadi <[email-masked]>
Date: Mon, 18 Apr 2016 11:29:55 +0000

Dear all,

I would like to announce that we (myself and Grenville Armitage) released Dummynet AQM v0.2, which is an independent implementation of CoDel, FQ-CoDel PIE and FQ-PIE* for FreeBSD's ipfw/dummynet framework, based on the IETF  CoDel [1], FQ-CoDel [2] and PIE [3] Internet-Drafts.

* "FlowQueue-PIE" (FQ-PIE) implementation combines FQ-CoDel's FlowQueuing with PIE's individual queue management.

In addition to PIE and FQ-PIE, this version includes bugs fixing and improvements to CoDel and FQ-CoDel code.

We prepared patches for FreeBSD11-CURRENT-r297692  and FreeBSD 10.x-RELEASE (10.0, 10.1, 10.2, 10.3), and a technical report  of our implementation.

Patches and documentation can be found in:
http://caia.swin.edu.au/freebsd/aqm

Technical report:
http://caia.swin.edu.au/reports/160418A/CAIA-TR-160418A.pdf

[1] "Controlled Delay Active Queue Management",  https://tools.ietf.org/html/draft-ietf-aqm-codel-03
[2] "FlowQueue-Codel" , https://tools.ietf.org/html/draft-ietf-aqm-fq-codel-06
[3] "PIE: A Lightweight Control Scheme To Address the Bufferbloat Problem", https://tools.ietf.org/html/draft-ietf-aqm-pie-06

Regards,
Rasool Al-Saadi

---

From: Dave Täht <[email-masked]>
Date: Mon, 18 Apr 2016 23:53:19 -0700

> In addition to PIE and FQ-PIE, this version includes bugs fixing and improvements to CoDel and FQ-CoDel code.

thx for addressing nearly all my comments on v0.1!

> We prepared patches for FreeBSD11-CURRENT-r297692  and FreeBSD 10.x-RELEASE (10.0, 10.1, 10.2, 10.3), and a technical report  of our implementation.

Rasool: Can you suggest to this guy that he try a "quantum 300" for his
600kbit uplink? I totally agree with his use of a smaller IW, also.

https://www.mail-archive.com/freebsd-net%40freebsd.org/msg51463.html

As for his headaches with pppoe and other sorts of odd (e.g. DSL/ATM)
framing, it's a real headache with soft shaping. HTB has infrastructure
(in linux) to handle it properly, as does cake, but it's a PITA.

Can this code be configured to run at physical line rates (10Mbit, 100,
1GigE), without a shaper? What is the effect? (BQL was needed for linux
here)

> _______________________________________________
> aqm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aqm
>