Subject: RE: [arch-d] NIC Offload Affect

From: "Bound, Jim" <[email-masked]>
Date: Wed, 23 Nov 2005 12:32:41 -0500

yes there is work in research area and I just sent mail about one that
may be interesting here being prepared for IEEE but not sure its in the
public domain yet.  will come back on that.

Just in case I agree with Tony we don't want to limit our
ideas/views/vision because of IP stacks or any implementation but just
keep it in mind.

I think considering shim affect is important not saying it should be
precluded.

another emerging use of the architecture will be ad hoc nets for example
radios don't have time to do congestion control between each other
"today" because of energy capability.

also on bob's model our RDMA group is dealing with some of that
currently and how IO and memory can be optimized by architecture
decisions is important I think to the vision equation if we can develop
such an equation.

/jim 

> -----Original Message-----
> From: Dave Crocker [mailto:[email-masked]] 
> Sent: Tuesday, November 22, 2005 9:39 PM
> To: Bound, Jim
> Cc: Bob Hinden; Tony Li; [email-masked]
> Subject: Re: [arch-d] NIC Offload Affect
> 
> 
> 
> 
> > on processors etc.  what I am concerned about is 4 years from now
> > 100GbE.  will our architecture sustain what it needs to on a host or
> > embedded software system.  So when we add shims and new 
> layers and new
> > processing that has to be called out from the stack that 
> has performance
> > cost. Keeping the deering hourglass and the middle not bulging is I
> > think very important.
> 
> I suspect that the on-/off-board question merely makes it 
> easier to think of 
> issues to focus on.  So it's not so much that it creates 
> special problems, 
> but perhaps it gets us thinking about thinks with some better focus.
> 
> Bob H's comments about memory processing vs. protocol 
> processing is a good 
> example.  Have there been serious host processing efficiency 
> proposals that 
> purport to do better?
> 
> I suspect the issue with a shim layer is going to be 
> per-packet additional 
> overhead, versus per "host-pair" or "per-session" or the like.
> 
> Are there specific problems already expected?
> 
> d/
> -- 
> 
> Dave Crocker
> Brandenburg InternetWorking
> <http://bbiw.net>
> 

_______________________________________________
Architecture-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/architecture-discuss

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 30 Nov 2005 15:12:28 -0500

Folks, per request from Dave Crocker, over week ago, as example
alternative to hardware NIC offload. I just had to verify paper was
public it is now.

Evaluating Network Processing Efficiency with Processor Partitioning and
Asynchronous I/O

Tim Brechtz, G. (John) Janakiraman, Brian Lynnx, Vikram Saletore, and
Yoshio Turner

(Hewlett Packard Laboratories, Intel Corporation, and University of
Waterloo)

 http://www.hpl.hp.com/research/dca/system/papers/hpl-2005-211.pdf

/jim