Subject: [arch-d] consolidation

From: Jari Arkko <[email-masked]>
Date: Tue, 6 Mar 2018 00:22:55 +0200

One of the topics we’ve discussed recently at the IAB are
consolidation trends in various Internet services, and how
architecture be affected by those trends or vice versa. And
whether there might be IETF work that would be useful
due to all this.

Here’s a blog article on this topic:

https://www.ietf.org/blog/consolidation/ <https://www.ietf.org/blog/consolidation/>

Thoughts?

One good location for discussion of this topic would be
the architecture-discuss list

Jari Arkko for the IAB

---

From: Anthony Caiafa <[email-masked]>
Date: Mon, 05 Mar 2018 22:32:58 +0000

Seems like an interesting thought. I think it would help remove some of the
unwanted traffic clogging the airways and separating out the social
networks and such. One problem I see with this is it would eventually allow
providers to charge for access to those “services”.

On Mon, Mar 5, 2018 at 5:23 PM Jari Arkko <[email-masked]> wrote:

> https://www.ietf.org/blog/consolidation/
>
> Thoughts?
>
> _______________________________________________
> Architecture-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/architecture-discuss
>

---

From: Tony Li <[email-masked]>
Date: Mon, 5 Mar 2018 14:33:46 -0800

> On Mar 5, 2018, at 2:22 PM, Jari Arkko <[email-masked]> wrote:
> 
> 

I was intrigued by the article.  Is the IAB working on improving the speed of light? :-)

Seriously tho, consolidation is a matter of fact in any maturing industry and much tho we might not like it, a look in the mirror reminds us that yes indeed, we are getting on.

Consolidation happens. We cannot fight economies of scale with technology. We have enabled alternatives.  What more would you have us do?

Federation is all well and good, but isn’t the primary issue there non-technical?

I would welcome more specific insights on our architectural direction.

T

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 6 Mar 2018 11:58:28 +1300

> I would welcome more specific insights on our architectural direction.

What he said. Consolidation is a certainty as a market matures, and presumably the market for Internet transit is about ready to be deemed mature. But I think there's another big trend: a much more fuzzy edge. Call it IoT or whatever you want, if the edge expands from a few billion to a few hundred billion nodes, there will be a considerable effect on protocols and practices. I'm beginning to think that's what the IETF must prepare for, to avoid becoming a legacy SDO.

   Brian

---

From: [email-masked]
Date: Mon, 5 Mar 2018 15:01:08 -0800

> 
> But I think there's another big trend: a much more fuzzy edge. Call it IoT or whatever you want, if the edge expands from a few billion to a few hundred billion nodes, there will be a considerable effect on protocols and practices. I'm beginning to think that's what the IETF must prepare for, to avoid becoming a legacy SDO.

Unsurprisingly, I concur with Brian. If the IAB would actually like to push for useful security standards for IoT, that would be beneficial.

Tony

---

From: Bob Hinden <[email-masked]>
Date: Mon, 5 Mar 2018 15:07:52 -0800

Brian, Tony,

> What he said. Consolidation is a certainty as a market matures, and presumably the market for Internet transit is about ready to be deemed mature. But I think there's another big trend: a much more…

Good points.

There is clearly lots of consolation in serving predefined content, for example web and video.  I suspect there is less consolation in audio and video conferencing because it’s interactive and can’t be cached.

I agree that there isn’t much the IETF can do regarding the centralization of predefined content, but as you point out the edge is about to grow significantly and this seems like an area the IETF can add some value.

Bob

---

From: james woodyatt <[email-masked]>
Date: Mon, 05 Mar 2018 16:41:42 -0800

On Mon, Mar 5, 2018 at 3:07 PM, Bob Hinden <[email-masked]> wrote:
>  [Brian Carpenter wrote:]
>> 
>> What he said. Consolidation is a certainty as a market matures, and 
>> presumably the market for Internet transit is about ready to be 
>> deemed mature. But I think there's another big trend: a much more 
>> fuzzy edge. Call it IoT or whatever you want, if the edge expands 
>> from a few billion to a few hundred billion nodes, there will be a 
>> considerable effect on protocols and practices. I'm beginning to 
>> think that's what the IETF must prepare for, to avoid becoming a 
>> legacy SDO.

> Good points.
> 
> There is clearly lots of consolation in serving predefined content, 
> for example web and video.  I suspect there is less consolation in 
> audio and video conferencing because it’s interactive and can’t 
> be cached.
> 
> I agree that there isn’t much the IETF can do regarding the 
> centralization of predefined content, but as you point out the edge 
> is about to grow significantly and this seems like an area the IETF 
> can add some value.

 From where I sit, the architectural centering of content and services 
in warehouse scale computing centers is dominated by the fact that 
first-mile links to retail subscribers are almost never symmetrical.

That edge with the hundred billion nodes? It's where the 
sensor/actuator cells are located, but application state and the 
algorithms that process it are increasingly located elsewhere, closer 
to the core, where network paths have higher bandwidth, lower latency 
and are less asymmetrical. That looks to me *less* fuzzy, not more-- 
intelligence is vacating the edge of  the network and consolidating in 
a small number of central points.

Sure the number of nodes at the edge may be increasing, but the variety 
of the nodes can decrease at the same time, simplifying the 
requirements of the network. In that light, perhaps the best thing for 
IETF to do is to prepare for its role as a legacy SDO, rather than to 
search for ways to avoid it.

--james

---

From: Jari Arkko <[email-masked]>
Date: Tue, 6 Mar 2018 09:22:42 +0200

Tony,

Of course the main driver for consolidation trends is a maturing industry. And, perhaps more importantly, an efficient market (such as the Internet is) that makes it possible for the best to be big aka “winner takes it all”. In a word, economics.

But, I don’t think that removes our need to either understand what is happening to the Internet — this trend is having a major effect — or ask whether the technology choices we make have *some* impact. The answer to the latter question might of course be that any technology impact is negligible. Perhaps, but lets figure that out for each relevant case.

I personally believe our tech and community choices do have an effect. To take a trivial example, I think we all agree that the existence of standards is a key to ensure interoperability and broad market for large number of players. Yet what things get standardised and used isn’t predetermined. For instance, what are the relevant things we could do tech wise for the emerging “fuzzy edge” (as Brian calls it) or the “consolidated intelligent core” (if you believe in James’ darker vision)?

Jari

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 6 Mar 2018 13:32:26 +0000

Hello Jari:

Maybe we can recognize some aspects of the fuzzy edge from which we can derive architecture elements:

- this fuzzy edge is deeper than one hop; it’s really a Fringe
- some addressing and routing happen within the fringe;
- there is an abundance of types of links, topologies are fuzzy, routing itself is best effort 
- the fringe is mobile but its mobility cannot leak in the stable core; this means that overlays will play a major role, billions of them, possibly on demand and short-lived
- with this any-to-any reachability goes away, one device / agent connects to a fringe network (possibly an overlay) on a need to know basis, and cannot be accessed/ attacked from outside 
- the end to end principle may also be impacted with new models such as data aggregation and knowledge diffusion whereby the data goes all the way up the DIKW model inside the network 
- some of the fringe is very low end and autonomic with no possible human intervention but some other pieces are very high end and classical forwarding models may not be sufficient, e.g., introducing determinism vs. Best effort.

Take care,

Pascal

> Le 6 mars 2018 à 08:23, Jari Arkko <[email-masked]> a écrit :
> 
> Tony,
>

---

From: Saleem Bhatti <[email-masked]>
Date: Tue, 6 Mar 2018 14:13:54 +0000

Regarding the fuzzy-edge/fringe, there is the "community networks" (for want of a better label) architecture / technology / systems, e.g. some of the things discussed in the GAIA RG. These can have a very different structure, governance, and growth to current ISPs / IXPs.  One of the objectives of such networks seems to be to provide connectivity to more people and devices, but I do not, however, know what the level of growth and trajectory of such networks are, and how they might impact the core network architecture overall (if at all).

Cheers,
--/Saleem

> On 06 Mar 2018, at 13:32, Pascal Thubert (pthubert) <[email-masked]> wrote:
> 
> Hello Jari:
>

---

From: Niels ten Oever <[email-masked]>
Date: Tue, 6 Mar 2018 15:30:04 +0100

Market consolidation might actually be an euphemism for market
concentration. I would by no means call this a property of a 'maturing
industry', but rather of market failure. It has be shown time and again
in political economics that monopolies and oligarchies are not
beneficial for either standard setting or innovation. Understanding the
process of market concentration as an irreversible aspect of
infrastructure would be buying in to the interest of a limited number of
large companies that have a quite disproportionate power over the worlds
communication infrastructures.

In short, I applaud the IAB for bringing up this issue for discussion,
because market concentration undermines the very distributed nature of
the Internet.

All the best,

Niels

-- 
Niels ten Oever
Head of Digital

Article 19
www.article19.org

PGP fingerprint    8D9F C567 BEE4 A431 56C4
                     678B 08B5 A0F2 636D 68E9

---

From: Hector Santos <[email-masked]>
Date: Tue, 06 Mar 2018 09:49:19 -0500

> What he said. Consolidation is a certainty as a market matures, and presumably the market for Internet transit is about ready to be deemed mature. But I think there's another big trend: a much more…

Consolidation/Centralization, we been through these cycles before 
where we end up decentralizing again in some fashion, so I tend to 
agree with you. In fact, my products future somewhat depends on it. 
Communications at the private/local network levels is still desirable 
and even though it may save people some money (and hardware 
headaches), I'm hearing more and more discontent with the concept of 
the "cloud" and the lost of control to the 3rd party.  Just consider 
the smart TVs becoming the new PCs. Once the consumer can do more with 
it, i.e. programmability, install stuff and run stuff, keep things 
"more private," things will change.  But I do agree that the concept 
of centralized comm (whether thru consolidation) is here to stay. 
Security and Licensing control issues apply. However, that doesn't 
mean "COLT" Communications Of Localized Things" will not happen as well.

-- 
HLS

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 06 Mar 2018 09:29:46 -0800

Hi Jari,

Thanks for posting this! It’s very interesting area of discussion, and one that’s worth more thought.

Reading the article, I am drawn to the question of why it is so difficult to deploy interaction models on the Internet that don’t involve one of the consolidated hubs. There are certainly factors of economics and scale that make it more practical for large private consolidations to provide high-quality services, but there are deeper technical problems that the non-consolidated approach can’t solve with today’s protocols.

Large web services make a lot of sense to be offered through a single entry point into a consolidated set of services. The economies of scale make sense. However, it’s also increasingly common that in order to interact with local and home network devices and peer devices, we communicate via the same consolidated services in the “cloud". Similarly, it’s easier to safely deploy a stable and secure small service as part of a consolidated entity.

If the IETF wanted to make it easier for solutions to not need to use the large consolidated solutions, what gaps would need to be addressed?

- Attacks such as Denial-of-Service (as mentioned in the article)

- Accessibility: If a user needs to go back and access their home network, or a friend’s device, what is the general solution without going through the cloud service offered by the IoT devices/social network? If everyone can get back to their homes without NATs, etc, what other attacks might they be vulnerable to?

- Privacy: While sending all of my traffic through a consolidated service may allow the service to track what I do, at least I’m able to avoid the known dangers on the open network that allow arbitrary snoopers to see what DNS queries I’m doing, what small services I connect to, etc. Consolidation acts as a better-than-nothing privacy measure, as long as you don’t mind trusting the consolidated entity. Until we have better standard privacy-enabling protocols that don’t require obfuscation through one big link, this will be hard to change.

- Protocol ossification: On my local home network, I can install and deploy new networking techniques; in a network behind one of these “consolidated” services, there can also be new techniques deployed. However, the open Internet between these is definitely less tolerant to non-vanilla traffic. So, if someone wants to deploy a networking service that has anything novel about it, it’s best to spend as little time as possible on the open Internet, and quickly get back to the consolidated network. And, if the link between the user and the “cloud” needs to be as standard as possible to work well, it’s easier for a few entities to perfect that link and fight the battles for new technologies rather than requiring individuals or small entities to handle that.

The idea of proposing “federation” to allow smaller entities to work together, and progress things perhaps more openly, is an interesting, if challenging, idea. I would hope that this approach, if it were taken, would try to address the gaps above in a way that can give more benefits to users than what current consolidations can: easier, open endpoints to help securely communicate between devices on the edge; privacy that doesn’t just prevent snooping on local network attachments, but provides some guarantees about privacy in the “cloud” itself; and methods to allow deployment of new technologies that don’t require large corporate sponsorship.

Best,
Tommy

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 6 Mar 2018 10:42:03 -0800

> because market concentration undermines the very distributed nature of

+1

Dino

---

From: Eliot Lear <[email-masked]>
Date: Tue, 6 Mar 2018 22:47:11 +0100

Jari,

Good topic.  I remember mnot raising this concern way back during the
Bruce Schneier IAB plenary.  Glad you guys are taking it forward for
discussion.

I have one question and a comment or three:

> Changes in business landscape may also affect standards work and
> processes. Small sets of significant players can drive standards work
> faster, but at the same time the larger entities are not as dependent
> on standardised solutions as smaller ones would be. 
I don't fully understand how the first sentence ties to the second.  I
think a good example of how all of this is playing out right in front of
our very eyes is Github.  Sure, they used web standards, but their
exported tool set isn't standardized through anyone.  In a way, Open
Source has been disruptive to standards, and so has the Apps model on
devices. 

These sort of platform-related concepts have long been explored. 
Rebecca Henderson (now at Harvard) used to give great talks on it.  The
IAB might want to consider having a conversation with her, if she'd agree.

Eliot

---

From: Tony Tauber <[email-masked]>
Date: Wed, 7 Mar 2018 11:48:59 -0500

I'm glad that the IAB is taking up the topic of a changing Internet.
The business consolidation seems less in scope than the changing landscape
of some changes what I see as fundamental assumptions about the structure
of traffic and different actors.
People here could probably speak better to it than I could but it seems a
tacit assumption of the Internet is relatively well-distributed set of
endpoints with relatively symmetric traffic sent and received.
There are lots of cases where aspects of standards are functionally
foreclosed by the marketplace. If there's little or no demand for a given
feature, what's the point of expending resources to implement and maintain
it.
Geoff Huston for instance has been making some interesting presentations
which I think are in this vein for about 18 months or so (ex. one at NANOG
https://www.nanog.org/meetings/abstract?id=2948). One assertion is that the
Internet was modeled on the phone network of any-to-any reachability, etc.
which is not really the way things are these days, for better or worse.

Let's keep the discussion going...

Tony

On Tue, Mar 6, 2018 at 9:49 AM, Hector Santos <[email-masked]> wrote:

>> presumably the market for Internet transit is about ready to be deemed
>> mature. But I think there's another big trend: a much more fuzzy edge. Call
>> it IoT or whatever you want, if the edge expands from a few billion to a
>> few hundred billion nodes, there will be a considerable effect on protocols
>> and practices. I'm beginning to think that's what the IETF must prepare
>> for, to avoid becoming a legacy SDO.
>>
>>     Brian
>>
>
> Consolidation/Centralization, we been through these cycles before where we
> end up decentralizing again in some fashion, so I tend to agree with you.
> In fact, my products future somewhat depends on it. Communications at the
> private/local network levels is still desirable and even though it may save
> people some money (and hardware headaches), I'm hearing more and more
> discontent with the concept of the "cloud" and the lost of control to the
> 3rd party.  Just consider the smart TVs becoming the new PCs. Once the
> consumer can do more with it, i.e. programmability, install stuff and run
> stuff, keep things "more private," things will change.  But I do agree that
> the concept of centralized comm (whether thru consolidation) is here to
> stay. Security and Licensing control issues apply. However, that doesn't

---

From: Geoff Huston <[email-masked]>
Date: Thu, 8 Mar 2018 09:00:19 +1100

Thats true Tony, and I said much the same to the IAB in a tech chat in December. There is little doubt that the bulk traffic volume is streamers using localised content caching and last mile delivery. It seems that long haul transit is not as valued any more and most of the money in networks is no longer carrying users through the network to access services, but in spanning CDNs that bring content to users. This is reflected in a number of ways: the ownership of new undersea cable projects is a good indicator, and perhaps indirectly, the bit rot that is affecting the default free BGP space (most ISPs don;t have all routes any more, which is an unwelcome development, but, more critically, most ISPs don't seem to care about what they are missing. I suspect that the money is just not there to justify taking corrective measures.).

It seems that we are building lots of CDN ‘service cones” and the interconnection between them is private CDN feeder networks, not the public Internet. If we contine down this path it raises the serious question of what exactly is a “public” address and what is a public domain name?

You could call is “consolidation”, you could call it “privatisation” - there are many ways to look at this, but the basic observation is that the content folk have corralled the bulk of the inherent value in the network and are using their investment capability to selectively build infrastructure that servers their particular interests. I am trying to be careful to label this “good" or “bad” - I’m not so nostalgic that I want to return to massive trans-oceanic delays and the current world of services works far better for me than previous incarnations. But I am trying to say that the model of what the Internet is today, namely a set of sparsely connected CDN service cones, is far away from the template we originally imagined

Geoff

On 8 Mar 2018, at 3:48 am, Tony Tauber <[email-masked]> wrote:

I'm glad that the IAB is taking up the topic of a changing Internet.
The business consolidation seems less in scope than the changing landscape of some changes what I see as fundamental assumptions about the structure of traffic and different actors.
People here could probably speak better to it than I could but it seems a tacit assumption of the Internet is relatively well-distributed set of endpoints with relatively symmetric traffic sent and received.
There are lots of cases where aspects of standards are functionally foreclosed by the marketplace. If there's little or no demand for a given feature, what's the point of expending resources to implement and maintain it.
Geoff Huston for instance has been making some interesting presentations which I think are in this vein for about 18 months or so (ex. one at NANOG https://www.nanog.org/meetings/abstract?id=2948). One assertion is that the Internet was modeled on the phone network of any-to-any reachability, etc. which is not really the way things are these days, for better or worse.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 9 Mar 2018 08:09:19 +1300

Switching to the architecture list...

On 09/03/2018 04:00, Josh Howlett wrote:
...
> Other drivers for federation include sovereignty and compliance, which stem from political or legal considerations. Given the increasingly global character of governance and regulation (e.g., the extraterritoriality of the GDPR), I suspect that we will see an increasingly homogenous environment. 

Really? I don't. I think we will see increasing diversity in legal constraints and requirements for trans-border data flow, for example with privacy-sensitive rule-of-law countries having very different rules from more authoritarian ones. Attempts at extra-territorial laws will only succeed up to a point.

> I would argue that this is a positive development, as federation within a heterogenous environment tends to increases costs and complexity, and reduces the capabilities of the entire system to that supported by the lowest common denominator. 

Yes. IMHO the "open Internet" is by its nature forced to be a lowest common denominator, and for that reason it is already becoming less important (e.g., see Geoff Huston's recent comment at https://mailarchive.ietf.org/arch/msg/architecture-discuss/D2d4lfIP2lHF8K5z7VYF_6rsUvs ). 

> To that end, I think an argument could be made that the internet architecture needs to a greater extent with the regulatory environment (and ideally take a lead in helping to define that, rather than follow with heels dragging), as that both facilitates federation and reduces compliance costs for users.

We certainly have to design for the real world, but that means designing for a varied and rather unpredictable regulatory environment.

    Brian

---

From: Josh Howlett <[email-masked]>
Date: Fri, 9 Mar 2018 09:38:33 +0000

> From: Brian Carpenter <[email-masked]> On Behalf Of Brian E
> 
> > Other drivers for federation include sovereignty and compliance, which
> stem from political or legal considerations. Given the increasingly global
> character of governance and regulation (e.g., the extraterritoriality of the
> GDPR), I suspect that we will see an increasingly homogenous environment.
> 
> Really? I don't. I think we will see increasing diversity in legal constraints and
> requirements for trans-border data flow, for example with privacy-sensitive
> rule-of-law countries having very different rules from more authoritarian
> ones. Attempts at extra-territorial laws will only succeed up to a point.

I think this is true to the extent that the network's rapid growth inevitably results in it tripping regulation that was drafted for the pre-Internet epoch. However, that regulation is gradually becoming more harmonised, as we see with data protection. States take much more interest in the network today, of course, but they are acting collectively and organising new regulation through intergovernmental mechanisms.

> > I would argue that this is a positive development, as federation within a
> heterogenous environment tends to increases costs and complexity, and
> reduces the capabilities of the entire system to that supported by the lowest
> common denominator.
> 
> Yes. IMHO the "open Internet" is by its nature forced to be a lowest common
> denominator, and for that reason it is already becoming less important (e.g.,
> see Geoff Huston's recent comment at
> https://mailarchive.ietf.org/arch/msg/architecture-
> discuss/D2d4lfIP2lHF8K5z7VYF_6rsUvs ).

Yes. I can't recall the numbers for our own peerings, but commodity transit is certainly a diminishing fraction of the total. This is the invisible hand at work; and unless we can point to harm (economic externalities, social inequities, weakened security, etc.) it is just a matter of accepting that the world has moved on.

> > To that end, I think an argument could be made that the internet
> architecture needs to a greater extent with the regulatory environment (and
> ideally take a lead in helping to define that, rather than follow with heels
> dragging), as that both facilitates federation and reduces compliance costs
> for users.
> 
> We certainly have to design for the real world, but that means designing for a
> varied and rather unpredictable regulatory environment.

Yes. I would just argue that it would be possible to reduce the unpredictability if the design of regulation and architecture were more joined up. As the saying goes, the best way to predict the future is to invent it. 

Josh.

Jisc is a registered charity (number 1149740) and a company limited by guarantee which is registered in England under Company No. 5747339, VAT No. GB 197 0632 86. Jisc’s registered office is: One Castlepark, Tower Hill, Bristol, BS2 0JA. T 0203 697 5800.

Jisc Services Limited is a wholly owned Jisc subsidiary and a company limited by guarantee which is registered in England under company number 2881024, VAT number GB 197 0632 86. The registered office is: One Castle Park, Tower Hill, Bristol BS2 0JA. T 0203 697 5800.

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 19 Mar 2018 02:18:01 +0000

Sorry to be so late responding here - but I am glad this topic has been 
raised and it would be a great pity if there was no way those gathered 
here could influence the course of events.

I think one thing is clear - there does not appear to be a technical 
solution to the consolidation problem. However, I don't think that means 
that there is no role whatsoever for IAB and the technical community.

What happened with old media as consolidation occurred is that national 
regulation occurred in different ways in many countries - with varying 
degrees of effectiveness. However, such regulation on a national basis 
is not effective in the case of the Internet - which requires a 
different sort of regulation which is not based on nation states acting 
unilaterally with differing approaches.

The problem is - there is no body capable of achieving this necessary 
regulation - and the prevailing attitude of dominant nation states to 
the dominating corporate players is "give us access to your data, and we 
won't regulate you"  (I realise that the EU Data Directive is an 
exception to this in some ways).

What is lacking in the internet field is a governance achitecture - and 
I am wondering if it totally outside of the remit of an Internet 
Architecture Board to outline a governance architecture? (or at least to 
be involved in its development)

A governance architecture would be a useful thing to have, and could be 
used to consolidate the theory of multistakeholder collaboration. It 
could be very useful in a number of different fields, and I think there 
is an opportunity for IAB to play a positive role here is outlining a 
useful proposal and approach. I am interested in what others think about 
this.

Just a thought.

Ian Peter

------ Original Message ------
From: "Geoff Huston" <[email-masked]>
To: "Tony Tauber" <[email-masked]>
Cc: "Hector Santos" <[email-masked]>; [email-masked]
Sent: 8/03/2018 9:00:19 AM
Subject: Re: [arch-d] consolidation

>Thats true Tony, and I said much the same to the IAB in a tech chat in 
>December. There is little doubt that the bulk traffic volume is 
>streamers using localised content caching and last mile delivery. It 
>seems that long haul transit is not as valued any more and most of the 
>money in networks is no longer carrying users through the network to 
>access services, but in spanning CDNs that bring content to users. This 
>is reflected in a number of ways: the ownership of new undersea cable 
>projects is a good indicator, and perhaps indirectly, the bit rot that 
>is affecting the default free BGP space (most ISPs don;t have all 
>routes any more, which is an unwelcome development, but, more 
>critically, most ISPs don't seem to care about what they are missing. I 
>suspect that the money is just not there to justify taking corrective 
>measures.).
>
>It seems that we are building lots of CDN ‘service cones” and the 
>interconnection between them is private CDN feeder networks, not the 
>public Internet. If we contine down this path it raises the serious 
>question of what exactly is a “public” address and what is a public 
>domain name?
>
>You could call is “consolidation”, you could call it “privatisation” - 
>there are many ways to look at this, but the basic observation is that 
>the content folk have corralled the bulk of the inherent value in the 
>network and are using their investment capability to selectively build 
>infrastructure that servers their particular interests. I am trying to 
>be careful to label this “good" or “bad” - I’m not so nostalgic that I 
>want to return to massive trans-oceanic delays and the current world of 
>services works far better for me than previous incarnations. But I am 
>trying to say that the model of what the Internet is today, namely a 
>set of sparsely connected CDN service cones, is far away from the 
>template we originally imagined
>
>Geoff
>
>
>>The business consolidation seems less in scope than the changing 
>>landscape of some changes what I see as fundamental assumptions about 
>>the structure of traffic and different actors.
>>People here could probably speak better to it than I could but it 
>>seems a tacit assumption of the Internet is relatively 
>>well-distributed set of endpoints with relatively symmetric traffic 
>>sent and received.
>>foreclosed by the marketplace. If there's little or no demand for a 
>>given feature, what's the point of expending resources to implement 
>>and maintain it.
>>Geoff Huston for instance has been making some interesting 
>>presentations which I think are in this vein for about 18 months or so 
>>(ex. one at NANOG https://www.nanog.org/meetings/abstract?id=2948). 
>>One assertion is that the Internet was modeled on the phone network of 
>>any-to-any reachability, etc. which is not really the way things are 
>>these days, for better or worse.
>>

---

From: Dan York <[email-masked]>
Date: Mon, 19 Mar 2018 06:33:20 +0000

I, too, am very pleased to see the IAB taking up the topic of consolidation / centralization as it has been one of great concern for me as I've watched the evolution of the Internet's architecture, particularly over the last decade. I have a number of thoughts to share in another note, but I wanted to respond to something Geoff wrote:

------ Original Message ------
From: "Geoff Huston" <[email-masked] <mailto:[email-masked]>>
> But I am trying to say that the model of what the Internet is today, namely a set of sparsely connected CDN service cones, is far away from the template we originally imagined

The rise of CDNs and other similar overlay networks is definitely not well understood outside the circles of those of us involved with Internet technologies and issues. Many people I speak with still have this idea that when they connect to a company's content (website, video, etc.) they are actually connecting to the company's own servers, not realizing that this whole layer of CDNs now exist.  Users are very seldom interacting directly with the company's servers.[1] Usually they are connecting to edge servers of whatever CDN the company is using.

I'm not sure yet that there are technical actions here, but I do think it would be worth exploring how to help a wider range of Internet users understand more about how the underlying architecture of the Internet has evolved. Some of those users are people seeking to make policies or regulations. Some of them are people seeking to develop new solutions. Helping them understand more could be useful. Perhaps through some documents or papers or articles... not sure of the exact mechanisms. I just know that others out there don't understand that the mental model they are using for "the Internet" is no longer an accurate representation.

My 2 cents,
Dan

P.S. I noticed a recent blog post from Comcast [2] that was talking about the need for a "network of networks" - but it was actually talking about the value of using multiple CDNs to deliver content. Which is, indeed, taking "network of networks" to an even larger scale when you are talking about having a network of already-massive networks.

[1] Unless, of course, the company owns the CDN, too.
[2] https://www.comcasttechnologysolutions.com/blog/content-delivery-network-networks

---

From: Greg Skinner <[email-masked]>
Date: Tue, 20 Mar 2018 00:30:12 -0700

Is this something the ISOC could take up, perhaps by updating the Internet Ecosystem paper <https://cdn.prod.internetsociety.org/wp-content/uploads/2017/09/ISOC-Internet-Ecosystem.pdf> or something like it with a CDN section?

Greg

> On Mar 18, 2018, at 11:33 PM, Dan York <[email-masked]> wrote:
> 
> [2] https://www.comcasttechnologysolutions.com/blog/content-delivery-network-networks <https://www.comcasttechnologysolutions.com/blog/content-delivery-network-networks>
> 
>