Subject: [art] [Technical Errata Reported] RFC6902 (5239)

From: RFC Errata System <[email-masked]>
Date: Fri, 19 Jan 2018 06:49:12 -0800 (PST)

The following errata report has been submitted for RFC6902,
"JavaScript Object Notation (JSON) Patch".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5239

--------------------------------------
Type: Technical
Reported by: Grzegorz Olszewski <[email-masked]>

Section: A.16

Original Text
-------------
An example target JSON document:

   { "foo": ["bar"] }

   A JSON Patch document:

   [
     { "op": "add", "path": "/foo/-", "value": ["abc", "def"] }
   ]

   The resulting JSON document:

   { "foo": ["bar", ["abc", "def"]] }

Corrected Text
--------------
An example target JSON document:

   { "foo": ["bar"] }

   A JSON Patch document:

   [
     { "op": "add", "path": "/foo/-", "value": ["abc", "def"] }
   ]

   The resulting JSON document:

   { "foo": ["bar", "abc", "def"] }

Notes
-----
surplus square brackets in resulting JSON document

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6902 (draft-ietf-appsawg-json-patch-10)
--------------------------------------
Title               : JavaScript Object Notation (JSON) Patch
Publication Date    : April 2013
Author(s)           : P. Bryan, Ed., M. Nottingham, Ed.
Category            : PROPOSED STANDARD
Source              : Applications Area Working Group APP
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Julian Reschke <[email-masked]>
Date: Fri, 19 Jan 2018 16:04:30 +0100

On 2018-01-19 15:49, RFC Errata System wrote:
> ...

The original text looks correct to me.

    ["abc", "def"]

is inserted at the end of

    ["bar"]

yielding

    ["bar", ["abc", "def"]]

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 22 Jan 2018 15:19:54 +1100

Concur with Julian; this is REJECT.

> On 20 Jan 2018, at 2:04 am, Julian Reschke <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/