Subject: Re: [Asrg] A New Plan for No Spam / DNSBLS

From: "Jon Kyme" <[email-masked]>
Date: Tue, 29 Apr 2003 15:41:26 +0100

> >> >>[ May be there is a time to create new category on
> www.rfc-ignorant.org
> >>  ]
> >>  >>
> >>  >
> >>  >And I'd like a good explanation of how you'd detect that behavior.
> >>  > 
> >>  >
> >> * In one case I detected it by non email communication (phone: Why
 >
> >But what if the "recipient" was (gasp) lying?
> >
> 
> 
> Oh come on.
> Are you really just trying to pester this guy?

Apologies to Andrzej, I should have said:
"And I'd like a good explanation of how ONE would detect that behavior"

But would you be happy if a sender/receiver collusion could get you
blacklisted (rfc-ignorant-like)? Or would the presentation of relevant logs
be a sufficient defence?

Bottom line. I'm agreeing with him.

If the sender doesn't have a reliable means for distinguishing between
non-deliveries with and without user control... well, it gives scope for
misunderstanding. And it's not feasible to ring up everybody I send mail to
so I can close the loop.

AF said:
> Whenever you send a email message you should always get message 
> delivered or info why it can not be delivered or info why some server 
> refused to deliver your message.

I agree, pretty much. That would be the ideal state of affairs.

Apologies for causing offence / confusion.

--
_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: Jim Youll <[email-masked]>
Date: Tue, 29 Apr 2003 10:58:37 -0400

>"And I'd like a good explanation of how ONE would detect that behavior"

whew, that's a relief

>blacklisted (rfc-ignorant-like)? Or would the presentation of relevant logs

So no, bad idea to make protocols that make it too easy for tiny numbers of
third parties to gang up on others silently. Sometimes just balancing a
protocol by allowing tiny numbers of third parties to un-do the problem
may be enough, however. I think this design ethic is often not considered,
yet potentially powerful.

>misunderstanding. And it's not feasible to ring up everybody I send mail to

Occasionally i still get messages with "return receipt requested"
on them and my Eudora client dutifully offers a button to generate an 
acknowledgement...
so people seem to be generally aware of this sort of function and desire it
from time to time.

>I agree, pretty much. That would be the ideal state of affairs.

So you're AOL and you have just received 300 million pieces of 
undeliverable mail...
do you drop them or try to generate 1 billion bounces that may come 
right back at
you, not to mention the complaints as your mailers are used in reverse attacks?
_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: Andrzej Filip <[email-masked]>
Date: Tue, 29 Apr 2003 18:46:08 +0200

Jim Youll wrote:
> [...]

Why have you accepted them in first place ?
Why have not you rejected the messages during original SMTP session ?
* reply to "mail from:"
* reply to "rctp to:"
* reply to "the final dot"
Do not say it can be done. You can say "AOL can't do it" or "AOL can't 
do it at reasonable cost".

AOL took over the responsibility for the best effort delivery by sending 
250 reply to "the final dot".

-- 
Andrzej [pl>en: Andrew] Adam Filip http://www.polbox.com/a/anfi/