Subject: RE: [Asrg] porkhash: flexible anti-impersonation mail signatures

From: "Bob Atkinson" <[email-masked]>
Date: Wed, 2 Apr 2003 16:59:26 -0800

Sorry, perhaps I was misunderstood.

I was concerned not about the theft of the secret (which I agree would
be analogous to S/MIME), but rather about the theft of a valid
porkhash/MAC from a header of a valid porkhashed message. Such stolen
MAC can seem to be reused (fraudulently) on a million other messages.

I'm probably missing something,

	Bob

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, April 02, 2003 2:24 PM
To: Bob Atkinson
Cc: [email-masked]

Same as with S/MIME certs - if they got hold of your key, they can
pretent 
to be you.

[...]

On Wed, 2 Apr 2003, Bob Atkinson wrote:

> I see how this sort of approach can tie a particular timestamp and
> sender_id / email address together in a MAC which can be validated,
but
> I'm missing how the MAC gets coupled to a given message. 
> 
> Was such a coupling intended?
> 
> If not, what's to prevent a spammer who gets his hands on one of these
> (a valid one) from then using it to send a million messages of his own
> (where of course he'll force all the other headers as necessary).
> 
> Confused,
> 
> 	Bob
> 

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: "Eric D. Williams" <[email-masked]>
Date: Fri, 4 Apr 2003 11:53:31 -0500

On Friday, April 04, 2003 1:02 AM, J C Lawrence [SMTP:[email-masked]] wrote:
8<...>8
> Note that the Porkhash proposal doesn't use signatures or keys, just an
> MD5 hash of items with a secret.  Under the porkhash proposal anybody
> wishing to verify a hash has to contact a system which possesses the
> secret, for re-computation of the hash to see if it matches.  This
> requires the secret to:
>
>   a) be on an exposed system.
>
>   b) be on a system which can be systematically explored and tested in
>   attempt to deduce the hash.
>
> Neither are optimal conditions.

I see, I have to admit I had only been following this thread in a cursory 
manner.  I take your points.
Thanks.

-e