Subject: RE: [Asrg] Turing Test ...

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Thu, 3 Apr 2003 08:06:24 -0800

> > 1) How do I distinguish the messages from these robots from spam?
> > 	A lot of them advertise these horrible services.
> 
> Use a VERP. Another robot should reply to the VERP, whereas a human 
> should reply to the Reply-To.

Please explain

> > 2) How do two people who use the service talk to each other?
> > 	Your message to me will be challenged by your service. There
> > 	is a strong possibility that some of the more clueless bots
> > 	will livelock here, others will never allow the
> > 	communication.
> 
> Clueless bots are always going to be a problem (see vacation 
> messages). 
> You have to use cluefull bots and complain to the ISP of 
> those who use 
> dumb bots.

Again, how does a 'smart bot' work? Don't tell me that it
meets the specification, show that it is possible to meet 
the specification.

I don't think that is possible if everyone uses them for
personal email.

The only reason people accept them for mailing lists is that
they know that subscribing other people to lists had become
a common prank and the callback is to protect them. It is
very different when the callback is to protect someone else.

Even then very few mailing lists had the callbacks until 
a prankster signed up the whitehouse to 70,000 mailing lists
and then subscribed the lists to each other so that a single
mail sent to one list created an avalanche of a million or 
so to the whitehouse. That was a fun couple of days.

		Phill 
_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: Matt Sergeant <[email-masked]>
Date: Thu, 3 Apr 2003 18:04:56 +0100

On Thursday, Apr 3, 2003, at 17:06 Europe/London, Hallam-Baker, Phillip 

>> should reply to the Reply-To.

OK. But first let me say I hate C/R solutions, so I almost want to not 
explain and let you continue believing they can't work ;-)

The C/R system sends a challenge with a return address of 
"[email-masked]" or something, but a reply-to field of 
"[email-masked]".

If two C/R systems start communicating it stops quickly because the cr 
bounce handler gets it. The challenge goes into the originators 
"pending validation" folder, so in order to validate the original he 
has to find it in that folder. Eventually if everyone uses C/R you 
might as well have your "pending validation" folder become your inbox.

Ah, I think I've just proved the point that these systems are 
fundamentally broken in the large scale. Excellent ;-)

Matt.