Subject: Re: [Asrg] C/R Interworking Framework

From: Yakov Shafranovich <[email-masked]>
Date: Wed, 04 Jun 2003 19:13:32 -0400

At 01:11 PM 6/4/2003 -0600, Vernon Schryver wrote:

> > From: Yakov Shafranovich <[email-masked]>
>
> > ...
> > The main problem with VRFY is that it allows the spammer to verify 
> addresses.
> > ...
>
>This is a minor issue, but pleast note that the main problem with VRFY
>is that many and perhaps most SMTP servers have it turned off.  No
>one with the faintest familiarity with how spam, spam filters, and
>even general STMP installation testing today uses VRFY.  Instead we
>all do what the spammers do many 10's of millions and perhaps billions
>of times every day.  Instead of sending the sequence of SMTP commands
>
>    HELO
>    VRFY
>
>we send
>
>    HELO
>    MAIL From
>    RCPT To
>
>The result of the second sequence is not perfect (e.g with Yahoo),
>but it is far more likely to work than the first.

However, if we are defining an SMTP process for CRI protocols, can we use 
the VRFY command as a part of an ESMTP extension?

Yakov  

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: Vernon Schryver <[email-masked]>
Date: Wed, 4 Jun 2003 18:01:15 -0600 (MDT)

> the VRFY command as a part of an ESMTP extension?

What about deployment and adoption rates?  Do you want it to work
even with MTAs not running your new protocol?
In other words, do you want it to work only in theory or to also have a
glimmer of a hope of working in the real Internet within the next 20 years?

Vernon Schryver    [email-masked]
_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg