Subject: Re: [Asrg] New proposal for spam blocking: Greylisting

From: Scott Nelson <[email-masked]>
Date: Fri, 20 Jun 2003 10:20:11 -0700

At 10:29 AM 6/20/03 -0500, Evan Harris wrote:
>
>Over the past few months, I've been working on a new method of blocking spam
>that I've termed "Greylisting".  From my testing it appears to be over 97%
>effective.
>
>It requires no changes to the infrastructure, is resistant to spammer
>adaptation, and is very effective, yet very lightweight.
>
>The paper outlining the method is at
>http://projects.puremagic.com/greylisting/ and I have also posted an example
>implementation for a Sendmail Milter written in perl.
>
>Please look it over and try to poke holes in it, but I've worked pretty hard
>to make it as bulletproof as possible.
>

My summary of the greylisting;
 Tempfail all new (IP+sender+recipient) triplets.

I only made one pass through the paper, but it looks pretty good to me.
97% feels high for this technique, but it's looks clean enough and
safe enough that I'll run some tests on my own and see if I get similar
numbers.

Scott Nelson <[email-masked]>

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: Evan Harris <[email-masked]>
Date: Fri, 20 Jun 2003 13:16:54 -0500 (CDT)

> Scott Nelson <[email-masked]>

Please send me an email and let me know how your tests come out.  You'll get
best results when you complement this method with using dns blacklists or
other methods of IP based blocking for known spammers.

Evan