Subject: RE: [Asrg] 6. Proposals - CRI Draft - 4.1 Loop Avoidance

From: "Peter Kay" <[email-masked]>
Date: Thu, 2 Oct 2003 06:33:57 -1000

Eric,

> 
> If we start adding various messaging such as with DSNs...I 
> don't think that we should be hijacking a sender's email 
> address to carry various protocol information.
> 

I'm not sure what you mean by that. If CRI is a protocol between two
people, instead of two systems, I don't see what's wrong w/ using the
user's email addresses.  

> Of course, that's just my opinion and why it's merely a 
> recommendation rather than a must, shall...
> 

If its just a recommendation, then why not recommend something which
simplifies the situation and reduces overhead?

> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Peter
> > Kay
> > Sent: Wednesday, October 01, 2003 12:08 PM
> > To: [email-masked]
> > Subject: [Asrg] 6. Proposals - CRI Draft - 4.1 Loop Avoidance
> > 
> > I finally had a chance to come up for air to respond to 
> Eric/Yakov's 
> > draft at 
> > 
> http://www.ietf.org/internet-drafts/draft-irtf-asrg-cri-00.txt
  . ASRG 
> owes you much for your hard work in creating this document and I 
> personally thank you for furthering an important area of 
> interoperability.
> 
> On loop avoidance section, specifically:
> 
> "For CRI systems that issue challenge messages, it is also recommended

> that each CRI system use a local systemwide user, such as [email-masked],

> for issuing challenges rather than preserving the original sender's 
> email address as the sender of the challenge message."
> 
> We disgree.
> 
> Most CR systems automatically/dynamically add the recipient to the 
> sender's whitelist.  So if I send an email to [email-masked], he's 
> automatically added to my whitelist.  If the mail-from on his
challenge
> is [email-masked], his email comes straight to my inbox without delays
or
> filters and certainly won't get challenged.  If the mail-from on his 
> challenge is "[email-masked]", the CRI protocol needs to be
invoked,
> possibly creating unecessary overhead.
> 
> Keeping the mail-from consistent allows CRI systems to naturally 
> interoperate and assuming that the CR system adds recipients to the 
> whitelist, elegantly solves the problem of CR systems challenging
other
> challenges.
> 
> Peter
> 
> 
> 
> 
> 
> _______________________________________________
> Asrg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/asrg

_______________________________________________
Asrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/asrg

---

From: "Eric Dean" <[email-masked]>
Date: Thu, 2 Oct 2003 13:41:34 -0400

Again, I am not claiming that it's wrong.  I'm am just offering guidance
one way or another.

If the CRI systems are going to automate the challenge response
mechanism...then it's kinda nice to separate the control messages from
the email messages...that's all.  

From a programming perspective...I'd like to allow a
white,black,grey-listed messages to simply take an action based upon the
sender address rather than have to statefully inspect every message for
CRI MIME headers...a little too much for SMTP servers.

If the CRI messages are sent from the actual CRI system using a local
email address, then it's simple...the message is addressed to me.

However, I'm not requiring one or another...just stating a preference. 

Peter
> Kay
> Sent: Thursday, October 02, 2003 12:34 PM
> To: Eric Dean; [email-masked]
> Subject: RE: [Asrg] 6. Proposals - CRI Draft - 4.1 Loop Avoidance
> 
> Eric,
> 
> >