Subject: RE: apsCommandSwitch in draft-ietf-atommib-sonetaps-mib-04

From: Muly Ilan <[email-masked]>
Date: Sat, 19 May 2001 14:46:04 +0200

I think that the description should indicate that an SNMP error should be
returned in this case. I agree that the specific error value may not be
needed:

      If the APS switch command cannot be executed because an
      equal or higher priority request is in effect, an error
      should be returned.

The additional text is required because otherwise it is not clear what to do
i.e. should an error be returned in the first place. The uncertainty is
because on one hand the apsCommandSwitch only holds the last command
written, regardless if it was executed or not. But on the other hand, there
is no point in keeping a command that will never be executed since there is
no pending of external commands and in addition the NE should indicate to
the EMS that there is something wrong with the last command.

Muly Ilan

> -----Original Message-----
> From: Michael Thatcher [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 7:32 PM
> To: Jim Kuhfeld
> Cc: Muly Ilan; [email-masked]
> Subject: Re: apsCommandSwitch in draft-ietf-atommib-sonetaps-mib-04
> 
> 
> I don't belive this additional text is required.  It is clear 
> that snmp requires an
> error return when a set cannot complete for whatever reason.  
> What error is returned
> is dependent on when during set processing the problem is detected.
> 
> miket
> 
> Jim Kuhfeld wrote:
> 
> > I would expect an error in that case, and could add 
> language to that effect to the
> > description.
> >
> >      If the APS switch command cannot be set because an
> >      equal or higer priority request is in effect, an
> >      inconsistentValue error is returned.
> >
> > On Thu, May 17, 2001 at 09:47:18PM +0200, Muly Ilan wrote:
> > > All,
> > >
> > > The description of the attribute apsCommandSwitch 
> includes " .... The return
> > > of the last command written does not imply that this 
> command is currently in
> > > effect. This request may have been preempted by a higer 
> priority local or
> > > remote request. ...."
> > >
> > > What happens, SNMP wise,  in the opposite case when a 
> command is sent to the
> > > NE but can't be executed because of existing higher 
> priority local or remote
> > > request?
> > > Should the SNMP set-response indicate an error? Should 
> the last value
> > > written be kept in the apsCommandSwitch object or maybe 
> ignore the last
> > > value because it was never performed and according to 
> GR-253-CORE there is
> > > no pending of external requests?
> > >
> > > BTW, the spelling of "higer" is not mine, it's in the 
> original draft.
> > >
> > >
> > > Muly Ilan
> > > Corrigent Systems
> > >
>

---

From: Jim Kuhfeld <[email-masked]>
Date: Sat, 19 May 2001 14:05:58 -0700

>       equal or higher priority request is in effect, an error

This adds the command failure criteria from GR-253-CORE, "unless a request
of equal or higher priority is in effect," which isn't otherwise stated,
so I think this provides worthwhile information.